LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-22-2006, 05:02 PM   #1
usg
LQ Newbie
 
Registered: Oct 2005
Location: Aachen, DE
Distribution: Mandriva 2009
Posts: 17

Rep: Reputation: 0
Problems playing AAC 5.1 with xine


As the version of xine-lib that came with my Slackware 10.2 distro did not support h.264, I installed the current v1.1.1 (from source). Now, h.264 decoding does work, but AAC 5.1 audio tracks come out as noise. AAC 2.0 is fine though. (The files in question are Matroska format.)

Any ideas? I searched the web for a solution, but could not find one.
 
Old 01-25-2006, 03:59 PM   #2
halvy
Member
 
Registered: Aug 2005
Location: Anchorage, Alaska (soon EU, hopefully)
Distribution: Anything NOT SystemD (ie. M$) related.
Posts: 918

Rep: Reputation: 42
is that the newest version.

maybe you need to compile everything

good luck.
 
Old 03-02-2006, 11:54 AM   #3
aeknor
LQ Newbie
 
Registered: Jul 2005
Distribution: slackware
Posts: 12

Rep: Reputation: 0
I just experienced the same problem last night (mkv 5.1 aac sound is all slow and scratchy). It seems that xine/mpeg4ip still doesn't support aac audio fully (I have mpeg4ip installed already).

The way I solved this was to download libfaad2 from the audiocoding site, and then I installed mplayer. Works perfectly. I was hoping to get totem to work with aac so I could play files on my server, but no luck so far.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Xine/MPlayer and AAC+ streams ilikejam Linux - Software 6 10-07-2005 11:37 PM
Totem playing off of network, Xine playing local iammike Ubuntu 0 04-30-2005 11:43 AM
xine playing very slowly, and other misc problems. JackSmith Linux - Software 2 02-22-2005 08:23 AM
Xine memory problems when playing video shazam75 Linux - Software 1 10-23-2004 12:48 AM
problems playing DVDs in xine nakedjohn Linux - Newbie 4 07-14-2003 07:30 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 08:23 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration