LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   problems mounting and unmounting iso images. (https://www.linuxquestions.org/questions/linux-software-2/problems-mounting-and-unmounting-iso-images-207606/)

Snerkel 07-20-2004 07:22 PM

problems mounting and unmounting iso images.
 
hi im trying to install a game using the "mount iso660 -o loop /dir/to/iso /mnt/cdrom" and it works fine but when i try and umount it during the installiation it wont let me and gives me the error

[root@localhost iso]# umount /mnt/cdrom
umount: /mnt/cdrom: device is busy
umount: /mnt/cdrom: device is busy

all i can do is quit. but still after ive quit i cant unmount the image.

Can anyone help ??

Ben

darin3200 07-20-2004 07:26 PM

Quote:

[root@localhost iso]# umount /mnt/cdrom
umount: /mnt/cdrom: device is busy
umount: /mnt/cdrom: device is busy
It looks like you are in the iso folder of the mounted images. Try doing a 'cd /' 'umount /mnt/cdrom' so then you aren't using the iso by viewing it.

larrykeenan 07-20-2004 07:37 PM

umount -d -l /mnt/cdrom

Have Fun,
Larry

Snerkel 07-20-2004 07:43 PM

Quote:

Originally posted by darin3200
I. Try doing a 'cd /' 'umount /mnt/cdrom'
I just tried what you said and it worked but i have just logged out and logged in again myself to see if i could make it work. but now when i try and mount it again (to restart the install as i quit it before) and now i get this error:

[root@localhost games]# mount iso660 -o loop /mnt/cdrom /dir/to/iso
Usage: mount -V : print version
mount -h : print this help
mount : list mounted filesystems
mount -l : idem, including volume labels
So far the informational part. Next the mounting.
The command is `mount [-t fstype] something somewhere'.
Details found in /etc/fstab may be omitted.
mount -a [-t|-O] ... : mount all stuff from /etc/fstab
mount device : mount device at the known place
mount directory : mount known device here
mount -t type dev dir : ordinary mount command
Note that one does not really mount a device, one mounts
a filesystem (of the given type) found on the device.
One can also mount an already visible directory tree elsewhere:
mount --bind olddir newdir
or move a subtree:
mount --move olddir newdir
A device can be given by name, say /dev/hda1 or /dev/cdrom,
or by label, using -L label or by uuid, using -U uuid .
Other options: [-nfFrsvw] [-o options] [-p passwdfd].
For many more details, say man 8 mount .

why would it be saying this now !?

if you can help more i would be very greatful

Ben


edit: ok dont worry i just noticed that i was missing the -t from the mount command :$. thank you larry, you where a huge help it worked perfectly :)

michaelk 07-20-2004 08:19 PM

Quote:

mount iso660 -o loop /mnt/cdrom /dir/to/iso
Was this a typo or the command verbatim? You didn't include the -t for filesystem type which caused the error.

Should be:
mount -t iso9660 -o loop /dir/to/iso /mnt/cdrom

See man mount pages for options and syntax.

danhill 08-21-2004 06:57 PM

command to kill busy mount
 
A friend showed me a command to cope with mount:

fuser -k /here/the/mount/point

will kill all the processes that use the resource. Most of the times it works, but sometimes KDE is so stubborn that there is no way but logout (at least none I know) to free the resource.


All times are GMT -5. The time now is 11:13 AM.