LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-21-2006, 03:41 AM   #1
depam
Member
 
Registered: Sep 2005
Posts: 856

Rep: Reputation: 30
Problems installing VMWare server in Mepis


Hi! Last time, I was able to install VMWare on a Ubuntu machine with the help of this forum. Right now, I can't make VMWare work on Mepis. I am using Mepis 3.3.1 with a kernel of 2.6.10. I've read in some of the forum that I need to recompile/upgrade the kernel for it to work. I downloaded Linux-source 2.6.15 based on the how-to I found in google. However, everytime I issue the command "make", it does not end correctly and I always get a segmentation fault error.

Hope someone out there can help me on this. I am trying to install VMWare for 2 days and still unsuccessful. I've tried qemu though, but I want VMware to run on Mepis. Everytime I run vmware-config.pl, it says that the there is no modules for my kernel. Please help.
 
Old 03-21-2006, 10:34 PM   #2
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid/RPIOS
Posts: 4,820
Blog Entries: 26

Rep: Reputation: 501Reputation: 501Reputation: 501Reputation: 501Reputation: 501Reputation: 501
Not sure if this will work for MEPIS but it does in PCLinuxOS.

In the file '/usr/bin/vmware-config.pl' find:


. 'not have the same address space size as your running '
. 'kernel.' . "\n\n", 0);
}
return '';
}
}

and change to:

. 'not have the same address space size as your running '
. 'kernel.' . "\n\n", 0);
}
# return '';
}
}


Hopefully vmware will fix their vmware-config.pl script one day and we won't have
to modify anything in the future.
 
Old 03-22-2006, 06:56 AM   #3
depam
Member
 
Registered: Sep 2005
Posts: 856

Original Poster
Rep: Reputation: 30
Thanks dude. I'll give it a try. I was able to resolve it by recompiling the kernel from 2.6.10 to 2.2.15..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems installing two ethernet cards in Mepis 3.4.3 depam Linux - Software 2 03-15-2006 02:38 AM
Problems installing Mepis live cd 3.3.1.1 to partioned hd jammeramd64 MEPIS 6 10-14-2005 05:32 AM
Vmware & Mepis BittaBrotha MEPIS 4 10-09-2005 10:38 PM
Mepis and VMWare problem aguerra Linux - Distributions 1 03-15-2005 06:12 PM
installing VMware..having problems... kurrupt Linux - Software 6 10-02-2004 11:10 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:03 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration