LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-22-2009, 07:32 AM   #1
Rakaballa
LQ Newbie
 
Registered: Jun 2007
Location: Antwerp, BELGIUM
Distribution: Fedora 7
Posts: 11

Rep: Reputation: 0
Problems installing ndiswrapper fc 7


I try to install ndiswrapper under fedora core 7 but i get following eror message when running MAKE and MAKE INSTALL:

[root@localhost ndiswrapper-1.48]# make
make -C driver
make[1]: Map '/usr/src/redhat/SOURCES/ndiswrapper-1.48/driver' wordt binnengegaan
Makefile:24: *** Kernel tree not found - please set KBUILD to configured kernel. Gestopt.
make[1]: Map '/usr/src/redhat/SOURCES/ndiswrapper-1.48/driver' wordt verlaten
make: *** [all] Fout 2
[root@localhost ndiswrapper-1.48]# make install
make -C driver install
make[1]: Map '/usr/src/redhat/SOURCES/ndiswrapper-1.48/driver' wordt binnengegaan
Makefile:24: *** Kernel tree not found - please set KBUILD to configured kernel. Gestopt.
make[1]: Map '/usr/src/redhat/SOURCES/ndiswrapper-1.48/driver' wordt verlaten
make: *** [install] Fout 2

Then I tried to figure out what the system is asking for and on the internet I found some usefull commands:

KBUILD=/usr/src/linux-`uname -r`
cp -p /boot/config-`uname -r` $KBUILD/.config

I tried these commands but I got the same error.

Does anybody know how I can solve this issue?
 
Old 10-22-2009, 10:19 AM   #2
lazlow
Senior Member
 
Registered: Jan 2006
Posts: 4,363

Rep: Reputation: 172Reputation: 172
1st F7(the core was dropped after FC6) hit EOL(End Of Life) several years ago. There has been and will be no further support since that time. Currently F10 and F11 are the only supported versions. One month after F12 is released(November?) support for F10 will drop. Make life easier on yourself and switch to a supported version.

The ndiswrapper package is still available in the archive repos:

(above) has the dkms-ndiswrapper-1.53-1.fc7.rf.i386.rpm .

If you decide you must build from source (to be avoided on package based distros), grab the source rpm and look at the spec file. It will show you what tricks and patches the packager had to use to build the package.

Last edited by lazlow; 10-22-2009 at 10:23 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problems installing ndiswrapper Kubrn Linux - Software 3 05-16-2007 09:55 PM
Problems installing ndiswrapper cucolin@ Ubuntu 3 06-05-2006 04:17 PM
Problems installing ndiswrapper-1.2 on Mandrake 10.1 ChillyWillie Mandriva 2 07-20-2005 03:53 PM
problems installing Ndiswrapper joshknape Linux - Wireless Networking 9 07-19-2005 02:25 AM
problems installing ndiswrapper slack---line Linux - Wireless Networking 2 01-17-2005 04:40 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration