LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-16-2009, 03:21 PM   #1
displacedtexan
LQ Newbie
 
Registered: May 2007
Posts: 22

Rep: Reputation: 15
Problems installing mplayer on fresh Debian XFCE install "


Ok... I just did a fresh install of Debian 5 on an old laptop that I would like to use in the car as a portable media player. I chose the XFCE desktop environment and added the following to my /etc/apt/sources.list:
Code:
deb http://www.debian-multimedia.org lenny main
deb-src  http://www.debian-multimedia.org lenny main
When I try to install mplayer I get the following:

Code:
# apt-get install mplayer
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  mplayer: Depends: libartsc0 (>= 1.5.9) but it is not installable
           Depends: libaudio2 but it is not installable
           Depends: libcdparanoia0 (>= 3.10.2+debian) but it is not installable
           Depends: libdv4 but it is not installable
           Depends: libfribidi0 (>= 0.10.9) but it is not installable
           Depends: libggi2 (>= 1:2.2.2) but it is not installable
           Depends: libgif4 (>= 4.1.6) but it is not installable
           Depends: liblircclient0 but it is not installable
           Depends: liblzo2-2 but it is not installable
           Depends: libopenal1 but it is not installable
           Depends: mplayer-skin but it is not installable
E: Broken packages
Google didn't seem to help much.

Anybody have any ideas how to correct?

Thanks!
 
Old 09-16-2009, 03:28 PM   #2
the trooper
Senior Member
 
Registered: Jun 2006
Location: England
Distribution: Debian Buster
Posts: 1,508

Rep: Reputation: Disabled
If you just want mplayer with no gui try:

Code:
aptitude install mplayer-nogui
Or if you would like a front end try:

Code:
aptitude install mplayer-nogui smplayer
You can substitute aptitude for apt-get if you prefer.

Edit:Looking at those error messages again,it might be worth posting the full output of your sources.list

Last edited by the trooper; 09-16-2009 at 03:32 PM.
 
Old 09-16-2009, 03:38 PM   #3
displacedtexan
LQ Newbie
 
Registered: May 2007
Posts: 22

Original Poster
Rep: Reputation: 15
Thanks for the help, but it was self-inflicted.

I disabled the cd repository in the sources.list yet I didn't add replace it with the normal Debian repository.

Dogh!
 
Old 09-16-2009, 03:42 PM   #4
the trooper
Senior Member
 
Registered: Jun 2006
Location: England
Distribution: Debian Buster
Posts: 1,508

Rep: Reputation: Disabled
Quote:
Originally Posted by displacedtexan View Post
Thanks for the help, but it was self-inflicted.

I disabled the cd repository in the sources.list yet I didn't add replace it with the normal Debian repository.

Dogh!
No worries,it's an easy fix then.

Last edited by the trooper; 09-16-2009 at 03:54 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems on installing Tor on Debian/Xfce bojingles Linux - Software 22 07-24-2007 07:24 AM
Problems installing kdm with fresh install of Mandriva 2007.0 Free NobeyamaGP Mandriva 5 01-29-2007 02:48 PM
"Skin not found" problem from installing Mplayer in Debian/Sarge !!! Blue Jacket Linux - Software 2 10-05-2005 01:58 AM
Debian "etch" install problems - no NIC found SharkeyNor Debian 2 08-14-2005 04:12 AM
installing mplayer...... problems occured when "make" was typed.... kublador Linux - General 5 02-22-2003 08:19 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:20 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration