LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-10-2002, 06:35 AM   #1
tundra
Member
 
Registered: Jun 2002
Location: Koom Valley
Distribution: rh8
Posts: 528

Rep: Reputation: 31
problems installing eroaster on slackware


ah... yes the nefarious slackware install prbs rears its ugly head now...

ok. i'm trying to install eroaster now. as i try to run the 'configure' script, i end up with a dependency problem with gnome-python
i've figured out the dependencies for the gnome-python package and compiled the required packages successfully.
then i come to the actual gnome-python stuff. here's what i did:

$./configure --with-gnome
$make
$make install

then i edited the /etc/ld.so.conf file by adding this line:
/usr/local/lib/python2.2/site-packages/gtk-1.2

then i ran the command:
$/sbin/ldconfig

(there were no problems with the installation of gnome-python)

when i ran the configure script for eroaster, it couldnt' find gnome-python.

appreciate any help on this.
 
Old 09-10-2002, 08:26 AM   #2
Bert
Senior Member
 
Registered: Jul 2001
Location: 406292E 290755N
Distribution: GNU/Linux Slackware 8.1, Redhat 8.0, LFS 4.0
Posts: 1,004

Rep: Reputation: 46
In the eroaster program, try

./configure --help

There should be a prefix for telling the config where gnome-python is?

eroaster rocks! Like a heroin rush on a warm evening! (well maybe not quite)

Bert
 
Old 09-11-2002, 06:45 AM   #3
tundra
Member
 
Registered: Jun 2002
Location: Koom Valley
Distribution: rh8
Posts: 528

Original Poster
Rep: Reputation: 31
tried it. there's no such option. i saw the libdir option and tried this:

./configure --libdir=/usr/loca/lib/python2.2/site-packages/gtk-1.2

still no good.

anyone with anything else?

Last edited by tundra; 09-11-2002 at 06:46 AM.
 
Old 09-11-2002, 01:53 PM   #4
Bert
Senior Member
 
Registered: Jul 2001
Location: 406292E 290755N
Distribution: GNU/Linux Slackware 8.1, Redhat 8.0, LFS 4.0
Posts: 1,004

Rep: Reputation: 46
Could you post the output of config.log ?

Bert
 
Old 09-12-2002, 05:06 AM   #5
tundra
Member
 
Registered: Jun 2002
Location: Koom Valley
Distribution: rh8
Posts: 528

Original Poster
Rep: Reputation: 31
it doesn't tell more than i already have.
here's the output:

This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

configure:573: checking for a BSD compatible install
configure:627: checking for python
configure:649: checking for python version >= 1.5.2
configure:681: checking for gnome-python

Last edited by tundra; 09-14-2002 at 02:46 AM.
 
Old 09-14-2002, 02:46 AM   #6
tundra
Member
 
Registered: Jun 2002
Location: Koom Valley
Distribution: rh8
Posts: 528

Original Poster
Rep: Reputation: 31
no more suggestions? anyone with any ideas?
 
Old 09-14-2002, 04:06 AM   #7
NSKL
Senior Member
 
Registered: Jan 2002
Location: Rome, Italy ; Novi Sad, Srbija; Brisbane, Australia
Distribution: Ubuntu / ITOS2008
Posts: 1,207

Rep: Reputation: 46
maybe delete config.cache from Eroaster dir, and then try ./configure again. Sometimes it works.
If not try to copy gnome pytthon libs somewhere obvious such as /lib or /usr/local/lib run ldconfig again and try ./configure again.
Good luck
-NSKL
 
Old 09-15-2002, 10:45 AM   #8
tundra
Member
 
Registered: Jun 2002
Location: Koom Valley
Distribution: rh8
Posts: 528

Original Poster
Rep: Reputation: 31
i deleted the entire folder and did the configure again before this post, but it didn't work either... i'm just short of copying the gnome python libs thing
sounds a lil unorthodox (not that i didn't do it before... lol) but just wondering how the slackers here do it and if there's a 'cleaner' way around it.

well ok. i'll wait out a few more posts before i try the copy thing... keep 'em coming if you have any good suggestions.

thanks to all of you who has answered so far.
 
Old 09-16-2002, 11:31 AM   #9
tundra
Member
 
Registered: Jun 2002
Location: Koom Valley
Distribution: rh8
Posts: 528

Original Poster
Rep: Reputation: 31
hm. since no more posts, so i copied the python gnome libs from the /usr/local/lib directory to /usr/lib/ and the configure script went nicely. it's installed and working smoothly now.

thanks for all your help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
eroaster problems chilehead Linux - Software 0 05-08-2004 08:41 PM
cd writing, getting/installing the app, k3b? eroaster? itsjustme Linux - General 1 11-02-2003 04:12 PM
problem installing eroaster 2.2.0 cpv204 Linux - Software 4 06-10-2003 09:29 AM
eroaster dependency problems ShibbyLinux Linux - Software 5 04-15-2002 10:13 AM
Eroaster Problems Stephanie Linux - General 0 06-29-2001 11:09 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration