-   Linux - Software (
-   -   problems compiling mediatomb (

z3rosh0t 01-06-2010 08:55 PM

problems compiling mediatomb
First off I'm using OpenSUSE 11.2.

I'm trying to compile mediatomb and I'm having difficulty when I run './configure'

This is the message I get when it fails:


configure: error: Support of at least one of mysql or sqlite3 must be configured
I have both sqlite3 and mysql installed.

Let me know if I need to post any other information. Thanks in advance for the help!

bibble_235 01-06-2010 10:24 PM

sqlite-devel perhaps.

z3rosh0t 01-06-2010 10:49 PM

Nice! That worked perfectly (used sudo zypper install sqlite3-devel)

Getting another error now, gonna work more on it in the morning.


configure: error: unable to configure expat support
I installed expat using zypper.

evo2 01-06-2010 10:51 PM

Seems the same as your first question: how about expat-devel (or similar)?


knudfl 01-07-2010 06:35 AM

# zypper in libexpat-devel
.. will do.

When 'configure' asks for <name> it usually means :

(lib)<name>-devel .

z3rosh0t 01-09-2010 09:59 AM

So I've gotten the configure to run thanks to all of your help.
Now I'm trying to run 'make' and I'm getting some errors. Any ideas would be greatly appreciated!


../src/ error: invalid conversion from ‘const char*’ to ‘char*’
../src/ error: invalid conversion from ‘const char*’ to ‘char*’
../src/ In function ‘zmm::String url_unescape(zmm::String)’:
../src/ error: invalid conversion from ‘const char*’ to ‘char*’
../src/ error: invalid conversion from ‘const char*’ to ‘char*’
make[2]: *** [libmediatomb_a-tools.o] Error 1
make[2]: Leaving directory `/usr/src/packages/SOURCES/mediatomb-0.11.0/build'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/packages/SOURCES/mediatomb-0.11.0'
make: *** [all] Error 2

The beginning is where it starts spitting errors. I understand why the compiler doesn't like what the code is trying to do, I'm just nervous about changing the code. Thanks in advance!

knudfl 01-10-2010 02:58 AM

Well, you could just set up the Packman.repo to get it
.. with : # zypper in mediatomb



bibble_235 01-11-2010 12:24 AM

has a patch you might want to try.

knudfl 01-11-2010 07:36 AM

@ bibble_235 , Thank you.
To fix further issue(s), I also applied this patch ..
And did : make CC=gcc-4.1 CXX=g++-4.1
Unfortunately, still no luck. So it's time to get the bugfixed code
with this command :
svn co mediatomb

( See :
the last lines on the page.)

This "SVN revision 2052" is also fixed so the default gcc, g++ can be used :
version 4.4.1 .

If you want the most options included :
# zypper in file-devel libexif-devel libjs-devel taglib-devel

And then : 1) cd mediatomb/
2) libtoolize && aclocal && autoheader && automake --add-missing \
&& autoconf && ./configure

3) make
.. which will now run with no errors.

All times are GMT -5. The time now is 10:06 AM.