LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-05-2004, 12:08 PM   #1
bloglos
LQ Newbie
 
Registered: Jun 2004
Posts: 4

Rep: Reputation: 0
Problems compiling avifile


I'm trying to compile transcode, which needs avifile to run.

I've tried compiling avifile from tar's and from the latest cvs but I keep getting this error message when ./configure is run.

checking for DPMSQueryExtension in -lXdpms... no
checking for main in -lqt-mt... no
checking for Qt library (version >= 200)... no
configure: WARNING:
*** Could not run Qt test program, checking why...
*** Configure discovered/uses these settings:
*** Qt libraries: /usr/local/qt/lib
*** Qt headers: /usr/local/qt/include
*** Note:
*** Compilation of Qt utilities also might be turned off (if not wanted).
*** If you are experiencing problems which will not be described
*** bellow please report then on 'avifile@prak.org' mailing list
*** (i.e. some misdetection or omitted path)

configure: error:
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means Qt was incorrectly installed
*** or that you have moved Qt since it was installed. In the latter case, you
*** may want to set QTDIR shell variable
***
*** Another possibility is you try to link Qt libraries compiled with
*** different version of g++. Unfortunately you can not mix C++ libraries
*** and object files created with different C++ compiler
*** i.e. g++-2.96 libraries and g++-2.95 objects
*** The most common case: Some users seems to be downgrading their
*** compiler without thinking about consequencies...






OK, I know Qt is installed correctly. I've compiled other programs that need it and it's worked fine. QTDIR shell variable is set to the correct directory.

Can anyone offer any advise? This is getting very frustrating.
 
Old 08-06-2004, 02:55 AM   #2
theYinYeti
Senior Member
 
Registered: Jul 2004
Location: France
Distribution: Arch Linux
Posts: 1,897

Rep: Reputation: 66
Before running configure, you have to run autogen. See this excellent site:
http://www.funix.org/fr/linux/main-l...ideo&page=menu

Yves.
 
Old 08-06-2004, 11:12 AM   #3
bloglos
LQ Newbie
 
Registered: Jun 2004
Posts: 4

Original Poster
Rep: Reputation: 0
I did

I ran autogen

Worked fine.

Tried ./configure and no matter what, I get the above error message.
 
Old 08-08-2004, 02:46 PM   #4
theYinYeti
Senior Member
 
Registered: Jul 2004
Location: France
Distribution: Arch Linux
Posts: 1,897

Rep: Reputation: 66
Sorry, it is autogen.sh! I typed too fast. After running autogen.sh, this error disappeared for me...

Yves.
 
Old 08-09-2004, 09:54 AM   #5
bloglos
LQ Newbie
 
Registered: Jun 2004
Posts: 4

Original Poster
Rep: Reputation: 0
yes I know.

Yes, I know you meant autogen.sh. But it changed nothing.

Same error msg. I'm tried RPM's and compiling from many different versions of the src. Nothing works.
 
Old 08-24-2004, 03:49 PM   #6
lulin
LQ Newbie
 
Registered: Jul 2004
Posts: 1

Rep: Reputation: 0
can not compile avifile

I first run the autogen.sh Problem happened after ruuning ./confiure

checking for xvid.h... yes
checking for xvid_init in -lxvidcore... no
configure: WARNING: Could not run XviD test program, checking why...
*** The test program compiled, but did not run. This usually means
*** that the run-time linker is not finding XviD or finding the wrong
*** version of XviD. If it is not finding XviD, you'll need to set your
*** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point
*** to the installed location Also, make sure you have run ldconfig if that
*** is required on your system
***
*** If you have an old version installed, it is best to remove it, although
*** you may also be able to get things to work by modifying LD_LIBRARY_PATH
--- Sources to build XviD xvidcore library can be found at http://www.xvid.org

I did install the Xvid and follow the guid to make the link for .so files

I also modify the LD_LIBRARY_PATH as below
LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/lib:/usr/lib:/usr/local/lib:/usr/lib/qt-3.3/lib
export LD_LIBRARY_PATH

Can anyone provide some help?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
avifile problem jasonmcneil0 Linux - Software 3 11-03-2003 12:50 PM
Avifile -- HELP roccoman Linux - General 3 12-11-2002 09:46 PM
avifile digital bots Linux - Newbie 2 03-21-2002 02:29 PM
avifile doesn't work.... Risc91 Linux - General 1 01-18-2002 03:14 PM
Help installing avifile..please Risc91 Linux - Software 1 01-17-2002 10:01 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:15 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration