LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-18-2018, 10:53 PM   #1
bsmile
Member
 
Registered: Oct 2017
Posts: 71

Rep: Reputation: Disabled
problems after a pip upgrade, python package installation always fails now


I was urged to upgrade pip from 8.1 to 18.1 and then every time I run pip, it gives an error message like the following,

john@vb ~/work/software/nlopt-master $ pip --version
/home/john/.local/lib/python2.7/site-packages/pip/_vendor/requests /__init__.py:83: RequestsDependencyWarning: Old version of cryptography ([1, 2, 3]) may cause slowdown.
warnings.warn(warning, RequestsDependencyWarning)

So, I followed the advice to upgrade cryptography by doing the following, and get a direct error message,

john@vb ~/work/software/nlopt-master $ sudo pip install --upgrade cryptography
Traceback (most recent call last):
File "/usr/bin/pip", line 9, in <module>
from pip import main
ImportError: cannot import name main

don't quite know whether the issue is due to the recent upgrade of pip. If so, is there way to wind back to my old version? How to further fix these issues? My os is linux mint 18.2.
 
Old 10-20-2018, 03:51 PM   #2
bsmile
Member
 
Registered: Oct 2017
Posts: 71

Original Poster
Rep: Reputation: Disabled
find the answer myself.

(1) downgrade from 18.1 to 8.1.1
sudo python -m pip install pip==8.1.1

(2) fix broken links
hash -r

then everything comes back to life, or at least pip freeze works as expected
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot upgrade Python/Pip, SSL errors Zeno McDohl Linux - Newbie 1 06-01-2018 09:01 AM
LXer: pip Uninstall | Uninstall a Package Installed with pip LXer Syndicated Linux News 0 03-01-2018 11:30 AM
[SOLVED] Getting Python 3 pip access? penyuan Arch 2 02-05-2016 09:19 AM
Adding an extra python repo for 'yum' & finding 'pip' package NikosGr Linux - Newbie 4 06-04-2013 05:25 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:13 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration