LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-15-2005, 02:02 AM   #1
scott231ca
LQ Newbie
 
Registered: Oct 2003
Distribution: Mandrake 9.1
Posts: 24

Rep: Reputation: 15
Problems 'make installing' Winex


I'm using Gentoo Linux and the most recent versions of everthing I can including Winex (I did an emerge -Du world last night) and when I try to make install Winex I get the following error:
Code:
make[3]: `x11drv.o' is up to date.
make[3]: Leaving directory `/home/scott/cvs/winex/windows/x11drv'
[ -d /usr/local/lib ] || mkdir -p /usr/local/lib
/bin/install -c libx11drv.so /usr/local/lib/libx11drv.so
make[3]: Entering directory `/home/scott/cvs/winex/windows/x11drv'
gcc  -I. -I. -I../../include -I../../include  -g -O2 -Wall -mpreferred-stack-boundary=2 -fno-keep-static-consts -D__const=const -fno-strict-aliasing -D__int8=char -D__int16=short -D__int32=int "-D__int64=long long" -fPIC -D__WINE__ -DBINDIR="\"/usr/local/bin\"" -D_REENTRANT  -o wineclipsrv ./wineclipsrv.c  -lSM -lICE -lXxf86dga -lXxf86vm -lXv -lGL -lGLU -lXext -lX11  -lm
/usr/lib/gcc-lib/i386-pc-linux-gnu/3.3.5/../../../libGLU.so: undefined reference to `operator new[](unsigned)'
/usr/lib/gcc-lib/i386-pc-linux-gnu/3.3.5/../../../libGLU.so: undefined reference to `vtable for __cxxabiv1::__si_class_type_info'
/usr/lib/gcc-lib/i386-pc-linux-gnu/3.3.5/../../../libGLU.so: undefined reference to `operator delete(void*)'
/usr/lib/gcc-lib/i386-pc-linux-gnu/3.3.5/../../../libGLU.so: undefined reference to `__gxx_personality_v0'
/usr/lib/gcc-lib/i386-pc-linux-gnu/3.3.5/../../../libGLU.so: undefined reference to `__cxa_pure_virtual'
/usr/lib/gcc-lib/i386-pc-linux-gnu/3.3.5/../../../libGLU.so: undefined reference to `vtable for __cxxabiv1::__class_type_info'
/usr/lib/gcc-lib/i386-pc-linux-gnu/3.3.5/../../../libGLU.so: undefined reference to `operator delete[](void*)'
/usr/lib/gcc-lib/i386-pc-linux-gnu/3.3.5/../../../libGLU.so: undefined reference to `vtable for __cxxabiv1::__vmi_class_type_info'
/usr/lib/gcc-lib/i386-pc-linux-gnu/3.3.5/../../../libGLU.so: undefined reference to `operator new(unsigned)'
collect2: ld returned 1 exit status
make[3]: *** [wineclipsrv] Error 1
make[3]: Leaving directory `/home/scott/cvs/winex/windows/x11drv'
make[2]: *** [../../windows/x11drv/wineclipsrv] Error 2
make[2]: Leaving directory `/home/scott/cvs/winex/dlls/x11drv'
make[1]: *** [x11drv/__install__] Error 2
make[1]: Leaving directory `/home/scott/cvs/winex/dlls'
make: *** [dlls/__install__] Error 2
Does anyone have any idea what's wrong? I want to see if one of my commonly used Windows programs works in Winex instead of Wine.

If it's of any significance to this problem:

AMD Athlon 1Ghz Processor
256MB RAM
Nvidia 128MB Geforce 4 Ti 4200 MSI Graphics Card
Gentoo Linux
KDE 3.3.2
Winex 3.3.2 (I think...)

That should be enough info to help me with this problem I hope.
 
Old 03-15-2005, 09:19 AM   #2
scott231ca
LQ Newbie
 
Registered: Oct 2003
Distribution: Mandrake 9.1
Posts: 24

Original Poster
Rep: Reputation: 15
*bump*

Certainly someone has to have some idea about this.
 
Old 03-15-2005, 09:24 AM   #3
gerardt
Member
 
Registered: Feb 2005
Location: South Africa
Distribution: SuSE
Posts: 60

Rep: Reputation: 15
I'm as interested as you are seeing as although I have the source on my box I have as yet been unable to get winex to work.
 
Old 03-15-2005, 09:29 AM   #4
scott231ca
LQ Newbie
 
Registered: Oct 2003
Distribution: Mandrake 9.1
Posts: 24

Original Poster
Rep: Reputation: 15
I had Winex working on Mandrake and Slackware, but now I'm using Gentoo. I'm probably missing something so I would just emerge it, but I need someone to tell me what that something is.
 
Old 03-15-2005, 09:34 AM   #5
gerardt
Member
 
Registered: Feb 2005
Location: South Africa
Distribution: SuSE
Posts: 60

Rep: Reputation: 15
Using SuSE 9.1. I had normal wine running and uninstalled it to replace with winex but typing wine returns the following message.

Invalid path 'c:\windows\system32\' for system directory: does not exist
Perhaps you have not properly edited or created your Wine configuration file.
This is (supposed to be) '/home/gerard/.wine/config'
 
Old 03-15-2005, 09:39 AM   #6
scott231ca
LQ Newbie
 
Registered: Oct 2003
Distribution: Mandrake 9.1
Posts: 24

Original Poster
Rep: Reputation: 15
Sounds like you haven't configured it. Go download and install winesetuptk then run it. That's a graphical configure tool for Wine and Winex, it should fix your problem.
 
Old 03-16-2005, 09:46 AM   #7
scott231ca
LQ Newbie
 
Registered: Oct 2003
Distribution: Mandrake 9.1
Posts: 24

Original Poster
Rep: Reputation: 15
*bump*

Certainly SOMEONE has to know what's wrong...
 
Old 03-16-2005, 08:26 PM   #8
Almighty-Bob
LQ Newbie
 
Registered: Mar 2005
Location: Eastern U.S.
Distribution: Slackware-current
Posts: 7

Rep: Reputation: 0
I was able to get winex working under Slackware 10 very easily.using this guide.

http://frankscorner.org/index.php?p=cedegacvs

There are some other lnks on that page that will help you get some of your applications running as well.

Cheers
 
Old 03-17-2005, 08:56 AM   #9
scott231ca
LQ Newbie
 
Registered: Oct 2003
Distribution: Mandrake 9.1
Posts: 24

Original Poster
Rep: Reputation: 15
That has nothing to do with my problem. That shows the most basic way to get WineX installed but fails to mention anything about the compiler not workking.
 
Old 03-18-2005, 09:17 AM   #10
scott231ca
LQ Newbie
 
Registered: Oct 2003
Distribution: Mandrake 9.1
Posts: 24

Original Poster
Rep: Reputation: 15
*bump*
 
Old 03-19-2005, 12:01 PM   #11
charris
LQ Newbie
 
Registered: Oct 2003
Distribution: Linux tuxstar 2.6.10-gentoo-r6
Posts: 8

Rep: Reputation: 0
Try the Gentoo forums.
 
Old 03-20-2005, 11:51 AM   #12
scott231ca
LQ Newbie
 
Registered: Oct 2003
Distribution: Mandrake 9.1
Posts: 24

Original Poster
Rep: Reputation: 15
I tried the Gentoo IRC channel which normally gets me a quick reply, but I couldn't get an answer out of them either.
 
Old 03-21-2005, 06:21 AM   #13
scott231ca
LQ Newbie
 
Registered: Oct 2003
Distribution: Mandrake 9.1
Posts: 24

Original Poster
Rep: Reputation: 15
*bump*
 
Old 03-21-2005, 07:41 AM   #14
cain_eve
Member
 
Registered: Nov 2004
Posts: 93

Rep: Reputation: 15
seems to be some problem of your gcc version?
I don't know exactly

because I see the last line is:
ld returned 1 exit status

Last edited by cain_eve; 03-21-2005 at 07:43 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
error at make with winex cvs lonrot_m Linux - Software 1 03-07-2005 07:12 PM
WineX Make Depend Errors Gryphix Linux - Games 4 09-25-2004 05:36 PM
Just downloaded winex and cannot figure out how to make it run scooter_scott Linux - Software 7 05-26-2004 01:24 PM
Error in Make Depend while CVS install of WineX calmlikeabomb Mandriva 1 04-28-2004 06:46 PM
make problems installing Bundle:Bugzilla on SuSE 9 mosko Linux - Software 0 03-20-2004 04:01 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:07 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration