LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-30-2004, 06:10 PM   #1
Tears Of Blood
LQ Newbie
 
Registered: Aug 2004
Distribution: SuSE
Posts: 15

Rep: Reputation: 0
Problem with Wine on SuSE


im trying to install a program with Wine and im running SuSE 9.1 and this is the first time im using wine. Im trying to install Msn Messenger and when i run the command to install the program it gives me this error:

linux:/home/rgreene/documents # wine SetupDl.exe
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

x11drv: Can't open display: :0.0
Please ensure that your X server is running and that $DISPLAY is set correctly.
linux:/home/rgreene/documents #

if someone can please explain what im doing wrong or what is wrong it would be greatly appreciated! thanks!
 
Old 08-30-2004, 06:14 PM   #2
geniarse
Member
 
Registered: May 2003
Location: UK
Distribution: Gentoo
Posts: 141

Rep: Reputation: 15
I can't help you with the wine problem, but rather than using msn messenger, why not use a native linux client i.e. amsn from http://amsn.sf.net so you dont't have to bother with wine
 
Old 08-30-2004, 06:34 PM   #3
Tears Of Blood
LQ Newbie
 
Registered: Aug 2004
Distribution: SuSE
Posts: 15

Original Poster
Rep: Reputation: 0
well the thing is i have amsn and it dosent support all the features that the real msn does..they are working on the features now i guess.
 
Old 08-30-2004, 06:41 PM   #4
geniarse
Member
 
Registered: May 2003
Location: UK
Distribution: Gentoo
Posts: 141

Rep: Reputation: 15
I can;t iamgine msn runnig easily on linux especially for the more advanced featues like the games as they will use activeX which will cause problems with wine, I just can't see how it is worth the hassle for the benefits using msn messenger gives you. Just persuade all you mates to use another worthwhile instant messenger (good luck cos I failed with my mates)
 
Old 08-30-2004, 08:34 PM   #5
Tears Of Blood
LQ Newbie
 
Registered: Aug 2004
Distribution: SuSE
Posts: 15

Original Poster
Rep: Reputation: 0
i see. Thanks
 
Old 09-01-2004, 11:38 AM   #6
mhearn
LQ Guru
 
Registered: Nov 2002
Location: Durham, England
Distribution: Fedora Core 4
Posts: 1,565

Rep: Reputation: 57
It didn't work because you are running it as root, and SuSE (like most other distros) still hasn't figured out how to use pam_xauth - grrr.
 
Old 12-09-2004, 05:20 PM   #7
Donboy
Member
 
Registered: Aug 2003
Location: Little Rock, Arkansas
Distribution: RH, Fedora, Suse, AIX
Posts: 736

Rep: Reputation: 31
I'm running as an unpriv user and it does the same thing to me.

Quote:
donboy@linux:~> wine Notepad.exe
Could not stat /media/floppy (No such file or directory), ignoring drive A:
Could not stat /media/cdrom (No such file or directory), ignoring drive M:
x11drv: Can't open display:
Please ensure that your X server is running and that $DISPLAY is set correctly.
donboy@linux:~>
 
Old 12-10-2004, 12:25 PM   #8
mhearn
LQ Guru
 
Registered: Nov 2002
Location: Durham, England
Distribution: Fedora Core 4
Posts: 1,565

Rep: Reputation: 57
Your $DISPLAY is not set correctly. Try:

DISPLAY=:0 wine Notepad
 
Old 12-10-2004, 12:30 PM   #9
raynet11
LQ Newbie
 
Registered: Aug 2003
Location: U.S.A
Distribution: RedHat , Mandrake
Posts: 28

Rep: Reputation: 15
Try this:

If you login as root in Suse you don't have X access.. Try logging into root with the -m option, this will allow you to fire up windows from the console.
 
Old 12-10-2004, 12:46 PM   #10
Donboy
Member
 
Registered: Aug 2003
Location: Little Rock, Arkansas
Distribution: RH, Fedora, Suse, AIX
Posts: 736

Rep: Reputation: 31
Quote:
Originally posted by mhearn
Your $DISPLAY is not set correctly. Try:

DISPLAY=:0 wine Notepad
Ok, that worked! Now, how can I set my display everytime I login? Or do I need to append this to every wine command I run?
 
Old 12-12-2004, 01:19 PM   #11
mhearn
LQ Guru
 
Registered: Nov 2002
Location: Durham, England
Distribution: Fedora Core 4
Posts: 1,565

Rep: Reputation: 57
I think you have a broken system. DISPLAY should always be set.
 
Old 12-12-2004, 02:56 PM   #12
SlackerLX
Senior Member
 
Registered: Dec 2004
Location: Herzliyya, Israel
Distribution: SuSE 10.1; Testing Distros
Posts: 1,832

Rep: Reputation: 47
Lightbulb

There is nothing wrong with system guys!
Suse just does not handle Wine well. I mean in my terms it does not handle it at all.
Suse has problems with wine and winex and cedega, does not matter!
That is why I went to Slackware
I still puzzled why MSN messenger?? I am really not for windows and gates and other sort of fences
Use either Gaim or Kopete.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
WINE in Suse 9.2 laniyi SUSE / openSUSE 3 04-04-2005 07:23 PM
A little WINE with SuSE? lhgrubbs SUSE / openSUSE 4 10-21-2004 05:07 AM
Suse 9.1 wine help Yoda Sabre Linux - Newbie 6 08-09-2004 01:35 AM
Suse and Wine JROCK1980 Linux - Games 2 05-10-2004 06:08 AM
wine problem with suse shamz Linux - Software 2 09-07-2003 05:38 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:18 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration