LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-12-2004, 10:50 AM   #1
nice_indian
Member
 
Registered: Oct 2004
Location: India
Distribution: redhat 9
Posts: 32

Rep: Reputation: 15
Unhappy problem with wine


hi,
i have just installed wine-20041019-1fc1winehq rpm on redhat9. i m getting following error while issuing wine command.

/usr/bin/wineserver: relocation error: /usr/bin/wineserver: symbol epoll_create, version GLIBC_2.3.2 not defined in file libc.so.6 with link time reference

what is wrong here?
 
Old 11-12-2004, 11:28 AM   #2
rjlee
Senior Member
 
Registered: Jul 2004
Distribution: Ubuntu 7.04
Posts: 1,991

Rep: Reputation: 76
There are two possible problems: your install of glibc-2.3.2 does not contain the function epoll_create(), or you do not have version 2.3.2 of glibc at all.

This probably means that the version of wine you downloaded was not compiled for your Red Hat 9 system. In this case, your best bet is to find either a static binary (which will run on any x86 Linux system), or a source RPM that you can compile yourself, for your system.
 
Old 11-12-2004, 11:44 AM   #3
crimsen
LQ Newbie
 
Registered: Aug 2003
Location: Ottawa Ontario Canada
Distribution: Fedora 2 64bit
Posts: 4

Rep: Reputation: 0
I noticed that you installed the Fedora Core 1 version of wine. There is a Red Hat 9 version. Here's the link to that rpm http://prdownloads.sourceforge.net/w...6.rpm?download . I would remove the FC1 version and then install RH9 version.

crimsen
 
Old 11-16-2004, 12:33 PM   #4
hanbin
LQ Newbie
 
Registered: Nov 2004
Posts: 9

Rep: Reputation: 0
i have the same problem too...
hope somebody can help us...

i'm running Redhat 9.0 also, and installing wine using the wine-20041019-1rh9winehq.i686.rpm i've download. the error messages is exactly same as nice_indian...

pls let us know what's wrong... and most important.... how to solve this?
 
Old 11-16-2004, 02:07 PM   #5
jon3k
Member
 
Registered: Jun 2003
Posts: 52

Rep: Reputation: 15
Quote:
Originally posted by hanbin
i have the same problem too...
hope somebody can help us...

i'm running Redhat 9.0 also, and installing wine using the wine-20041019-1rh9winehq.i686.rpm i've download. the error messages is exactly same as nice_indian...

pls let us know what's wrong... and most important.... how to solve this?
Check your glibc version.

Try this:
[username@host /] rpm -qa | grep glibc

You should see one package listed w/ the name glibc-X.X.X-XX (where the X's represent the actual version number).

Now compare that version fo the error message. I'd suggest upgrading to at LEAST the version listed in the error, but in reality, the latest possible for your platform/architecture.
 
Old 11-17-2004, 09:44 AM   #6
nice_indian
Member
 
Registered: Oct 2004
Location: India
Distribution: redhat 9
Posts: 32

Original Poster
Rep: Reputation: 15
hi,
btw i checked the verson of glibc and found it the same(GLIBC_2.3.2). I also tried same verson wine for rh9. And removed the prev rmp and installed new1 but it didnt work. So finally i got binaries and compiled it.
Although it took lotof time of mine but i guess its working fine now

Last edited by nice_indian; 11-17-2004 at 09:47 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Link targets - problems with Wine (Though not Wine specific - Wine site doesn't help) Kevjml Linux - Newbie 1 01-13-2006 07:53 AM
Wine problem bungle_42 Linux - Software 2 10-22-2004 10:27 AM
problem with wine exigent Linux - Software 1 03-04-2004 06:59 AM
wine problem Please help~!~!~!~! demmylls Linux - Software 2 03-03-2004 02:20 PM
wine problem tylerb Linux - Software 0 02-16-2004 03:41 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration