LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-11-2010, 01:16 PM   #1
sternocera
LQ Newbie
 
Registered: Oct 2008
Posts: 10

Rep: Reputation: 0
Problem with system services on opensuse 11.1 - blocking occurs during init


Hello,

I have a number of Opensuse 11.1 x86 machines. Their hardware is largely or completely identical, as is their disk image, because I've cloned them using dd.

When init starts services, I find that it blocks on the portmap daemon service. When I disabled that in Yast, auditd blocked in much the same manner instead (which wasn't blocking previously). When I disabled that, syslog blocked instead. The blocking lasts for over 5 minutes. I also find that a utility that should be started by boot.local isn't. I cannot ping my default gateway on an affected machine, for no good reason.

When I ps aux | grep auditd (for example) I can see that auditd does eventually start. It's just a mystery as to why it blocks. I couldn't find anything untoward in /var/log, although admittedly I am no expert at analysing log files.

A few weeks ago, I replaced one of the clones, which was faulty as described. Now, the issue has arisen again. I'd like to understand the problem, and learn from it.

What should I do? Can it be fixed?

I've run my distro's recovery disk, which runs fsck on all partitions among other things. This didn't bring anything up.

Thanks,
Sternocera
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
When Opensuse 11 machine cloned with dd, problem with serial port blocking sternocera Linux - Hardware 2 03-03-2011 06:38 PM
[SOLVED] C - For system calls, is blocking or non-blocking default? golmschenk Programming 4 03-23-2010 10:29 PM
System Beep Occurs at Login Screen (and I want it gone) lazeeboy Linux - Newbie 2 03-24-2008 03:29 PM
On RH9 NVidia Splash screen occurs and system hangs SidA Red Hat 0 06-19-2004 07:53 PM
CRC error --System Halted occurs occasionally quinnculator Linux - General 4 06-19-2003 11:46 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 03:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration