-   Linux - Software (
-   -   Problem with switching to named workspaces in i3 4.2 (

TobiSGD 05-15-2012 09:39 AM

Problem with switching to named workspaces in i3 4.2
On my never ending journey to find the optimal tiling WM I am currently fiddling with i3 and til now I like it.

All is working fine, it is very configurable and easy to do that.
The only problem I have is that I can't switch to named workspaces that begin with a number, like described here in the manual.
For example, I want to auto-start Firefox and also want it to launch every time on the workspace named 1: Web, which is easily done with these lines in the configuration file:

exec firefox
assign [class = "Firefox"] 1: Web

There is no problem with that. The problem is that I can't switch to workspaces named like that using the keyboard.
I tried all of the following lines in my configuration file, but none worked:

bindsym Mod4+1 workspace 1
bindsym Mod4+1 workspace 1: Web
bindsym Mod4+1 workspace "1: Web"
bindsym Mod4+1 workspace number 1

Has anyone a clue what I am doing wrong? I simply can't figure it out.

TobiSGD 05-16-2012 05:19 AM

After having an email conversation with the i3 developer (a very friendly person that answered almost immediately), who asked me to check my configuration file for trailing whitespaces on those commands I decided to write a new configuration file from scratch and now it works.
So for future reference, check for trailing whitespaces.
Problem solved.

dragon_788 06-19-2017 05:16 PM

Hate to thread necro but the "correct" way to do this is you want to access by a number and show a name is to add 'number' after the workspace call. You can also use the numberstrip option if you want to hide the number but keep the sorted order.


bindsym Mod4+1 workspace number 1: Web

All times are GMT -5. The time now is 03:54 PM.