LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-01-2008, 06:12 PM   #1
stardotstar
Member
 
Registered: Nov 2002
Location: /au/qld/bne/4157
Distribution: Gentoo mactel-linux
Posts: 238

Rep: Reputation: 30
problem with "screen" Cannot access '/newroot/dev/pts/0' - in a chroot - not /newroot


Hi guys,

I am struggling to get screen to work for me whilst doing a gentoo install via ssh when in the chroot.

The basics of the setup are:

booted with SystemRescCD

mounted install disks made mount binds etc including:

mount -t proc none /mnt/gentoo/proc
mount -o bind /dev /mnt/gentoo/bind

and even

mount -t devpts none /mnt/gentoo/dev/pts

Then chroot /mnt/gentoo/ /bin/bash ; env-update ; . /etc/profile

and screen won't play:

Code:
sysresccd etc # nano screenrc
sysresccd etc # screen
Cannot access '/newroot/dev/pts/0': No such file or directory
sysresccd etc # screen /dev/pts/0
Cannot access '/newroot/dev/pts/0': No such file or directory
sysresccd etc # cd /dev
sysresccd dev # ls
agpgart        fuse     loop6   ptmx   ram6    sdc1  sg1     tty1   tty22  tty35  tty48  tty60           usbdev1.2_ep00  usbdev1.6_ep82  usbmon5  vcsa4
bus            gpmctl   loop7   pts    ram7    sdc2  sg2     tty10  tty23  tty36  tty49  tty61           usbdev1.2_ep02  usbdev2.1_ep00  vcs      vcsa5
cdrom          hpet     mapper  ram0   ram8    sdc3  sg3     tty11  tty24  tty37  tty5   tty62           usbdev1.2_ep81  usbdev2.1_ep81  vcs1     vcsa6
cdrom1         initctl  md      ram1   ram9    sdc4  sg4     tty12  tty25  tty38  tty50  tty63           usbdev1.3_ep00  usbdev3.1_ep00  vcs12    watchdog
cdrom2         input    md0     ram10  random  sdd   sg5     tty13  tty26  tty39  tty51  tty7            usbdev1.3_ep02  usbdev3.1_ep81  vcs2     zero
cdrw           kmsg     mem     ram11  rd      sdd1  shm     tty14  tty27  tty4   tty52  tty8            usbdev1.3_ep81  usbdev4.1_ep00  vcs3
cdrw1          log      misc    ram12  rtc     sdd2  sr0     tty15  tty28  tty40  tty53  tty9            usbdev1.4_ep00  usbdev4.1_ep81  vcs4
console        loop     mouse   ram13  scd0    sdd3  stderr  tty16  tty29  tty41  tty54  ttyS0           usbdev1.4_ep03  usbdev5.1_ep00  vcs5
core           loop0    mouse1  ram14  sda     sdd4  stdin   tty17  tty3   tty42  tty55  ttyS1           usbdev1.4_ep84  usbdev5.1_ep81  vcs6
dac960_gam     loop1    mptctl  ram15  sda1    sde   stdout  tty18  tty30  tty43  tty56  ttyS2           usbdev1.5_ep00  usbmon0         vcsa
device-mapper  loop2    null    ram2   sda2    sde1  tgt     tty19  tty31  tty44  tty57  ttyS3           usbdev1.5_ep01  usbmon1         vcsa1
disk           loop3    nvram   ram3   sdb     sde2  tts     tty2   tty32  tty45  tty58  urandom         usbdev1.5_ep82  usbmon2         vcsa12
fd             loop4    oldmem  ram4   sdb1    sde3  tty     tty20  tty33  tty46  tty59  usbdev1.1_ep00  usbdev1.6_ep00  usbmon3         vcsa2
full           loop5    port    ram5   sdc     sg0   tty0    tty21  tty34  tty47  tty6   usbdev1.1_ep81  usbdev1.6_ep81  usbmon4         vcsa3
sysresccd dev # cd pts
sysresccd pts # ls
0
sysresccd pts #
the devpts is there but screen seems to be worried about the chroot state?

Mirrorselect fails in a similar way:

Code:
sysresccd pts # mirrorselect -i
* Downloading a list of mirrors... Got 221 mirrors.
* Stripping hosts that only support ipv6... Removed 8 of 221

cannot open tty-output
Something missing??

In general this install is going much the same way as every other ;-)

(BTW I am in the chroot I just didn't change PS1)

TIA
Will

Last edited by stardotstar; 05-01-2008 at 06:15 PM. Reason: corrections and clarification
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem using screen: Cannot open your terminal '/dev/pts/0' - please check. stefaandk Linux - General 18 06-17-2014 08:52 PM
Symlinks working from "inside" 'chroot' to "outside" ? amn Linux - Newbie 2 12-07-2007 02:09 AM
How do I switch the labels "/dev/sda1" with "/dev/sda3" vonst Linux - General 10 05-27-2006 11:48 PM
I've got a message about "/dev/null: access denied" Saulo SUSE / openSUSE 2 04-14-2006 11:37 AM
Problem with "Jail Chroot Project 1.9" Agento- Linux - General 2 01-19-2003 08:52 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:03 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration