LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   problem with RT installation (https://www.linuxquestions.org/questions/linux-software-2/problem-with-rt-installation-343038/)

robertngo 07-14-2005 02:06 AM

problem with RT installation
 
Hi,


i have installed RT: Request Tracker on the my RHEL3 server with apache 1.3.27 and mod_perl 1.26

i add in the httpd.conf the following line

<VirtualHost 10.35.3.1>
ServerAdmin webmaster
ServerName rt.example.com
ServerAlias rt
DocumentRoot /opt/rt3/share/html
AddDefaultCharset UTF-8

PerlModule Apache::DBI
PerlRequire /opt/rt3/bin/webmux.pl

<Location />
SetHandler perl-script
PerlHandler RT::Mason
</Location>
</VirtualHost>

when i restart the httpd server there is a error message

Stopping httpd: [ OK ]
Starting httpd: [Thu Jul 14 14:51:27 2005] [error] Can't locate strict.pm in @INC (@INC contains: /usr/lib/perl5/5.6.1/i386-linux /usr/lib/perl5/5.6.1 /usr/lib/perl5/site_perl/5.6.1/i386-linux /usr/lib/perl5/site_perl/5.6.1 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.6.1/i386-linux /usr/lib/perl5/vendor_perl/5.6.1 /usr/lib/perl5/vendor_perl . /etc/httpd/ /etc/httpd/lib/perl) at /usr/lib/perl5/vendor_perl/5.6.1/i386-linux/Apache.pm line 3.!BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.6.1/i386-linux/Apache.pm line 3.!Compilation failed in require at (eval 1) line 3.!
Syntax error on line 2653 of /etc/httpd/conf/httpd.conf:
Can't locate Apache/DBI.pm in @INC (@INC contains: /usr/lib/perl5/5.6.1/i386-linux /usr/lib/perl5/5.6.1 /usr/lib/perl5/site_perl/5.6.1/i386-linux /usr/lib/perl5/site_perl/5.6.1 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.6.1/i386-linux /usr/lib/perl5/vendor_perl/5.6.1 /usr/lib/perl5/vendor_perl . /etc/httpd/ /etc/httpd/lib/perl) at (eval 2) line 3.

[FAILED]

what is wrong with this httpd setting?

merana 07-15-2005 07:06 AM

First troubleshooting step:

Verify that the perl modules RT is calling are where RT is looking (path). It's having problem finding the following:

strict.pm
Apache/DBI.pm

Code:

/usr/lib/perl5/5.6.1/i386-linux /usr/lib/perl5/5.6.1
/usr/lib/perl5/site_perl/5.6.1/i386-linux
/usr/lib/perl5/site_perl/5.6.1
/usr/lib/perl5/site_perl
/usr/lib/perl5/vendor_perl/5.6.1/i386-linux
/usr/lib/perl5/vendor_perl/5.6.1
/usr/lib/perl5/vendor_perl
. /etc/httpd/ /etc/httpd/lib/perl) at
/usr/lib/perl5/vendor_perl/5.6.1/i386-linux/Apache.pm line 3.!BEGIN failed--compilation aborted at
/usr/lib/perl5/vendor_perl/5.6.1/i386-linux/Apache.pm line 3.!Compilation failed in require at (eval 1) line 3.!

Shows places that are in the perl path... You may be missing some dependencies...

Did you install this from RPM or Source? :confused:

robertngo 07-17-2005 10:08 PM

i have updated perl to 5.8.3 why does it still search in the 5.6.1 directory?


All times are GMT -5. The time now is 06:05 PM.