-   Linux - Software (
-   -   Problem with openoffice 2.0-Getting installed but not opening (

deepugopi 07-10-2007 05:34 AM

Problem with openoffice 2.0-Getting installed but not opening
Hi ,
I'm using Red Hat desktop version 4 (64 bit)with update 2 - it contains openooffice 1.
Recently i downloaded openoffice 2.2.i was able to install it successfully - I went to the RPMS folder & performed rpm -Uvh *rpm & then i went into desktop-integration directory & installed the redhat rpm also.
But when i tried to run the program its not responding.From GNOME nothing is showing. In KDE atleast something is trying to open. After 10-15 seconds that too failed.But I'm able to open the old openoffice one.
I tried the openoffice 2(both OO 2.0 & 2.2) by uninstalling version 1.But still it didn't work.
The rpm's inside the openoffice 2 RPMS folder is of i586.Whether that could be the reason?

Please help as soon as possible since i cant open any .odt or .ods file from openoffice 1

Expecting a quick reply
Deepu G.

Lenard 07-10-2007 05:59 AM

Works perfectly fine for me, you did exit out of the GUI Desktop session then back in after installing OpenOffice 2.X via the rpms???

You should verify and (if need be) that you did in fact remove the older version 1 openoffice packages: rpm -e <the version 1 OOo packages here>

$ uname -a
Linux Aspire5100 #3 SMP Thu Jun 14 12:41:34 EDT 2007 x86_64 x86_64 x86_64 GNU/Linux

$ cat /etc/*release
Red Hat Enterprise Linux Client release 5 (Tikanga)

$ rpm -qa --qf="%{n}-%{v}-%{r}.%{arch}\n" 'openoffice*' | sort

b0uncer 07-10-2007 06:01 AM

First thing to do when something is not opening is to launch a terminal emulator/console session and start the program from there. Most programs spit their error/other information to stdout which is visible this way - you get to see what's happening.

deepugopi 10-16-2007 05:29 AM

Finally i came to know what was causing this strange thing from the following link

I just did the following things & now everything seems fine

cd /opt/openoffice.org2.3/program
vi soffice

Search for the the following line:

java_ld_library_path=`"$sd_prog/javaldx" $BOOTSTRAPVARS`

and replace it with:


Hopes this post will help someone like me ....

All times are GMT -5. The time now is 06:15 AM.