LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Closed Thread
  Search this Thread
Old 07-14-2005, 04:43 PM   #1
triley
Member
 
Registered: Oct 2003
Posts: 74

Rep: Reputation: 15
Problem with openLDAP and SASL


Hello and thanks in advance for any help that might be posted,

I am currently trying to configure openLDAP (openldap-2.2.26), Cyrus SASL (cyrus-sasl-2.2.21), and BerkeleyDB (db-4.3.28.NC) on Fedora Core 2. I have some experience with Linux, but mainly programming with Emacs, and not much on the system admin side.

Currently I am following a guide posted at:

http://en.tldp.org/HOWTO/LDAP-HOWTO/sasl.html

I get most of the way down the page with no problems, since I changed some of the file locations to match my versions; other than that the file structure is the same. I get to the line "slapadd -c -l Ever.ldif -f slapd.conf -v -d 256", at which point the command fails with the message:

slap_sasl_init: SASL library version mismatch: expected 2.1.21, got 2.1.18
slapadd: slap_init failed

I get the same message when i try to start up slapd. I read a few forums across the internet and most seem to point to an error with the LD_LIBRARY_PATH link. I do not know how to modify this, or if this is even the problem, but any input would be appreciated.
 
Old 07-11-2016, 03:25 PM   #2
nrajiv80
LQ Newbie
 
Registered: Jul 2016
Posts: 3

Rep: Reputation: Disabled
Hi triley,

Hope your SASL library version mismatch issue got resolved.

I am trying to setup Openldap server running on port 636 with SASL as authentication mechanism.
OS : Centos7

Can you please share the LDAP with SASL configurations details will be of great help.

-Rajiv
 
Old 07-11-2016, 04:21 PM   #3
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 24,469

Rep: Reputation: 7243Reputation: 7243Reputation: 7243Reputation: 7243Reputation: 7243Reputation: 7243Reputation: 7243Reputation: 7243Reputation: 7243Reputation: 7243Reputation: 7243
Quote:
Originally Posted by nrajiv80 View Post
Hi triley,

Hope your SASL library version mismatch issue got resolved.

I am trying to setup Openldap server running on port 636 with SASL as authentication mechanism.
OS : Centos7

Can you please share the LDAP with SASL configurations details will be of great help.

-Rajiv
Read the LQ Rules, nrajiv80. DO NOT post the same question in multiple places. Thread reported to moderators.
 
Old 07-11-2016, 04:23 PM   #4
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 24,469

Rep: Reputation: 7243Reputation: 7243Reputation: 7243Reputation: 7243Reputation: 7243Reputation: 7243Reputation: 7243Reputation: 7243Reputation: 7243Reputation: 7243Reputation: 7243
Quote:
Originally Posted by triley View Post
Hello and thanks in advance for any help that might be posted,
I am currently trying to configure openLDAP (openldap-2.2.26), Cyrus SASL (cyrus-sasl-2.2.21), and BerkeleyDB (db-4.3.28.NC) on Fedora Core 2. I have some experience with Linux, but mainly programming with Emacs, and not much on the system admin side.

Currently I am following a guide posted at:
http://en.tldp.org/HOWTO/LDAP-HOWTO/sasl.html

I get most of the way down the page with no problems, since I changed some of the file locations to match my versions; other than that the file structure is the same. I get to the line "slapadd -c -l Ever.ldif -f slapd.conf -v -d 256", at which point the command fails with the message:

slap_sasl_init: SASL library version mismatch: expected 2.1.21, got 2.1.18
slapadd: slap_init failed

I get the same message when i try to start up slapd. I read a few forums across the internet and most seem to point to an error with the LD_LIBRARY_PATH link. I do not know how to modify this, or if this is even the problem, but any input would be appreciated.
You don't say what version/distro of Linux you're using, but chances are you have a mismatch between your cyrus-sasl packages, either the library or the devel package. Hard to say how to solve it, when we don't know details about your system, but try to install/update the cyrus-sasl-devel package.
 
  


Closed Thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slack 10.2 and sendmail with sasl problem mago Slackware 1 11-03-2005 11:49 AM
cyrus-sasl authentication problem nobu Red Hat 1 11-01-2005 07:54 PM
cyrus-sasl & openldap issue jiawj Slackware 2 09-18-2005 01:53 AM
Postfix problem:: SASL MD5 support adrianmak Linux - Software 0 08-16-2005 06:36 AM
postfix,sasl problem strace Mandriva 1 09-02-2004 10:00 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration