LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-08-2003, 01:40 PM   #1
lakshan
LQ Newbie
 
Registered: Aug 2003
Location: Sri Lanka
Posts: 28

Rep: Reputation: 15
Problem with mplayer for Red hat 9


I have everything pretty much working in (1152x864 screen size, with Nvidia Riva TNT 2 Model 64, 32 Mb VGA card etc.), except when I play video files, they are not played full screen. Instead, they are played in a small window that is centered in the middle of the monitor. When I play file formats, which support to mplayer-0.90-fr2.i386 I cannot view it in full screen mode. I tried by pressing F but it still the same. But when I –zoom it and play it gets in to full screen mode but there is a problem with that too after playing voice plays 1stly and then video moves. I tried mplayer filename –vm –fs but it didn’t work on.
But as I said when I tried the –zoom it gives this problem as well

********************************
Your system is too SLOW to play this!
********************************

Possible reasons, problems, workarounds:
- Most common: broken/buggy _audio_ driver
- Try -ao sdl or use ALSA 0.5 or the OSS emulation of ALSA 0.9.
- Experiment with different values for -autosync, 30 is a good start.
- Slow video output
- Try a different -vo driver (-vo help for a list) or try -framedrop!
- Slow CPU
- Don't try to play a big DVD/DivX on a slow CPU! Try -hardframedrop.
- Broken file
- Try various combinations of -nobps -ni -forceidx -mc 0.
- Slow media (NFS/SMB mounts, DVD, VCD etc)
- Try -cache 8192.
- Are you using -cache to play a non-interleaved AVI file?
- Try -nocache.
Read DOCS/video.html and DOCS/sound.html for tuning/speedup tips.
If none of this helps you, read DOCS/bugreports.html.


How can I over come with this?


Please let me know by email me to dlakshan99@hotmail.com
Or send me the link

Thanks
 
Old 08-08-2003, 02:08 PM   #2
funtoos
Member
 
Registered: Jun 2003
Location: US
Distribution: Gentoo x86/AMD64, KDE 4.13
Posts: 38

Rep: Reputation: 25
>> - Try a different -vo driver (-vo help for a list)

This will solve your problem. try -vo x11 or -vo xv. -autosync 30 is another option which you should have if your cpu is slow.
 
Old 08-08-2003, 05:22 PM   #3
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984
well as he's using the -zoom option i'd assume he's already using X11. X11 is horrendously cpu hungry compared to dga or xv, so definitely try XV. you didn't give any CPU specs either....
 
Old 08-08-2003, 05:29 PM   #4
synaptical
Senior Member
 
Registered: Jun 2003
Distribution: Mint 13/15, CentOS 6.4
Posts: 2,020

Rep: Reputation: 48
i think acid_kewpie is right. i had that same symptom until i changed to the xv driver.
 
Old 08-09-2003, 06:11 AM   #5
linux_pioneer
Member
 
Registered: May 2003
Distribution: Solaris 10, Solaris 8.0, Fedora Core 3
Posts: 203

Rep: Reputation: 30
Okay I already had it set to the xv driver. Can I specify the autosync 30 in graphical mode (w/ gmplayer)? Any other suggestions to avoid that message?
 
Old 08-09-2003, 06:32 AM   #6
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984
if -zoom is changing the behaviour of fullscren mode then you will *not* be using xv output.
 
Old 08-09-2003, 06:44 AM   #7
Muddy
Member
 
Registered: May 2002
Location: Ohio
Distribution: Mandrake 9.2 Custom Kernel & Mythtv!
Posts: 256

Rep: Reputation: 30
did you install mplayer from tar or rpm ??
 
Old 08-09-2003, 01:01 PM   #8
funtoos
Member
 
Registered: Jun 2003
Location: US
Distribution: Gentoo x86/AMD64, KDE 4.13
Posts: 38

Rep: Reputation: 25
advice: listen to acid!

following are set in my env and my card is much slower than yours. Mplayer plays fullscreen amazingly well for 1GHz and 16MB intel card.

in gmplayer, change the prefs for video: choose X11/Xv, enable double buffering, enable frame dropping( not the HARD one).

under 'misc', enable cache, set it to 8192(load time is slightly more, but its smart enough to not fill the whole cache before starting depending on the size). enable autosync, and set it to 30 to start with.

try each one, 1-by-1 and see if any of it helps.

Last edited by funtoos; 08-09-2003 at 01:03 PM.
 
Old 08-09-2003, 01:42 PM   #9
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984Reputation: 1984
Quote:
Originally posted by funtoos
advice: listen to acid!
you and me could go a long lnog way...
 
Old 08-11-2003, 12:54 PM   #10
funtoos
Member
 
Registered: Jun 2003
Location: US
Distribution: Gentoo x86/AMD64, KDE 4.13
Posts: 38

Rep: Reputation: 25
Oh yes we will!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Where to get RPM for MPlayer/Xine for Red Hat 9? AskMe Linux - Software 4 07-29-2004 09:49 AM
mplayer is not installing on Red Hat Linux 9.0 chinmay nautiya Linux - Software 18 03-12-2004 10:21 AM
Problem with mplayer for Red hat 9(modify) lakshan Linux - Software 2 08-09-2003 02:37 PM
Red Hat 9 & Mplayer mikeshn Linux - Software 15 05-25-2003 11:33 PM
Mplayer, GCC and Red Hat 7.1 cyrille Linux - Newbie 7 04-26-2002 09:52 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration