LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   problem with mounting ext4 in fstab file! (https://www.linuxquestions.org/questions/linux-software-2/problem-with-mounting-ext4-in-fstab-file-739559/)

everplays 07-12-2009 12:48 PM

problem with mounting ext4 in fstab file!
 
hi

i'm running opensuse 11.1 as it doesn't support ext4 ( actually ext4 was on development - ext4dev ) so i compiled 2.6.30.1 kernel on it. now i can mount my partition using mount command but it's not gonna mount in fstab file. the partition i want to mount was my /home on sabayon & now i can't access it. here's lsmod:
Code:

linux-mrvx:/home/behrooz # lsmod | grep ext4
ext4                  223600  0
jbd2                  68744  1 ext4
crc16                  2560  1 ext4
mbcache                9252  2 ext4,ext3
linux-mrvx:/home/behrooz #

& here's my fstab file:
Code:

linux-mrvx:/home/behrooz # cat /etc/fstab
/dev/disk/by-id/ata-Hitachi_HTS541616J9SA00_SB2451SJJTM6UE-part5 swap                swap      defaults              0 0
/dev/sda6 / ext3 noatime,acl,user_xattr,extents,barrier=0,mballoc 1 1
/dev/sda7 /home ext4 atime,acl,user_xattr,extents,barrier=0,mballoc 1 2
/dev/disk/by-id/ata-Hitachi_HTS541616J9SA00_SB2451SJJTM6UE-part3 /media/os            ntfs-3g    users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
/dev/disk/by-id/ata-Hitachi_HTS541616J9SA00_SB2451SJJTM6UE-part2 /media/recovery      ntfs-3g    users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
proc                /proc                proc      defaults              0 0
sysfs                /sys                sysfs      noauto                0 0
debugfs              /sys/kernel/debug    debugfs    noauto                0 0
devpts              /dev/pts            devpts    mode=0620,gid=5      0 0

where's problem & how i can solve it?

everplays 07-13-2009 04:38 AM

ok, problem was fstab, here's right code:

Quote:

/dev/disk/by-id/ata-Hitachi_HTS541616J9SA00_SB2451SJJTM6UE-part5 swap swap defaults 0 0
/dev/sda6 / ext3 noatime,acl,user_xattr 1 1
/dev/sda7 /home ext4 relatime 1 2
/dev/disk/by-id/ata-Hitachi_HTS541616J9SA00_SB2451SJJTM6UE-part3 /media/os ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
/dev/disk/by-id/ata-Hitachi_HTS541616J9SA00_SB2451SJJTM6UE-part2 /media/recovery ntfs-3g users,gid=users,fmask=133,dmask=022,locale=en_US.UTF-8 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0


All times are GMT -5. The time now is 10:41 AM.