LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-06-2004, 10:55 PM   #1
mar122999
LQ Newbie
 
Registered: Sep 2004
Posts: 12

Rep: Reputation: 0
Problem with Linux Suse PE multi-boot!


Hi. I am new to linux so bear with me. I used partition magic in Windows XP to make a new partition for my linux OS (Suse Personal Edition) that I just purchased. Well, I rebooted and started the linux installation with the CD. During the installation, I chose that I wanted to use the 7.0Gb partition (which I reserved for linux OS) and to format it. I didn't format the primary Windows OS. Anyway, I chose to let the boot sector files reside on the Windows OS partition (don't know if I should have done this, but I did this because that is what it defaulted to). I went though the installation and everything worked fine and the OS works great. BUT there is only one problem, I can not boot to my Windows OS. Whenever the computer boots up, it automatically loads the linux OS and doesn't give me an option to choose which OS that I want. I don't know where to start looking inside of Linux to possibly change a boot setting to allow me to get into Windows. Can you help me? Thanks!!!
 
Old 09-07-2004, 03:25 AM   #2
linux_terror
Member
 
Registered: Aug 2004
Location: Northbrook, Illinois
Distribution: CentOS-5
Posts: 311

Rep: Reputation: 30
Are you using grub or lilo? take a look in your /boot directory for either grub.conf or lilo.conf you will most likely have to edit one of them and just add your wins os to it.

linux_terror
 
Old 09-07-2004, 08:12 AM   #3
mar122999
LQ Newbie
 
Registered: Sep 2004
Posts: 12

Original Poster
Rep: Reputation: 0
It says GRUB whenever it starts to load linux.
 
Old 09-07-2004, 08:14 AM   #4
mar122999
LQ Newbie
 
Registered: Sep 2004
Posts: 12

Original Poster
Rep: Reputation: 0
How do I edit and which one?
 
Old 09-07-2004, 11:41 AM   #5
mar122999
LQ Newbie
 
Registered: Sep 2004
Posts: 12

Original Poster
Rep: Reputation: 0
This may help. This is what my "boot loader configuration" looks like under the control center:

Boot Loader Type: GRUB
Boot Loader location: dev/hda2
Disk Order: dev/hda
Default Section: Linux
Availiable Sections: Linux (default), Floppy, Failsafe
Activate boot loader partition: No
Replace code in MBR: leave untouched
Back up affected disk areas: No
Add saved MBR to boot loader menu: No
Save method: save only changed files
----------------
Color: white/blue black/light-gray
timeout: 8s
gfx menu: (hd0,1)/boot/message

I believe that my NTFS Windows XP partition is dev/hda2. I recently changed the top option "boot loader location" from "MBR of dev/hda" to "Boot Sector of dev/hda2". Didn't seem to do anything.
 
Old 09-07-2004, 11:45 AM   #6
mar122999
LQ Newbie
 
Registered: Sep 2004
Posts: 12

Original Poster
Rep: Reputation: 0
Also my grub.conf was not under the /boot section of my hard disk. It was under the /etc folder. Anyway, here is what it says:

root (hd0,1)
install --stage2=/boot/grub/stage2
/boot/grub/stage1 d (hd0,1) /boot/grub/stage2
0x8000 (hd0,1)/boot/grub/menu.lst
quit


Please Help!!!

Last edited by mar122999; 09-07-2004 at 11:46 AM.
 
Old 09-07-2004, 11:57 AM   #7
linux_terror
Member
 
Registered: Aug 2004
Location: Northbrook, Illinois
Distribution: CentOS-5
Posts: 311

Rep: Reputation: 30
I have a grub.conf in /boot/grub/grub.conf AND in /etc/grub.conf ...not too sure why. Anyway, here's my grub.conf...

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,0)
# kernel /vmlinuz-version ro root=/dev/hdd2
# initrd /initrd-version.img
#boot=/dev/hdc
default=0
timeout=10
splashimage=(hd0,0)/grub/splash.xpm.gz
password --md5 $1$uCRfSShL$DdzndKdvdKDkxnmY6RTVW0
title Red Hat Enterprise Linux AS (2.4.21-4.EL)
root (hd0,0)
kernel /vmlinuz-2.4.21-4.EL ro root=LABEL=/ hda=ide-scsi
initrd /initrd-2.4.21-4.EL.img

As I don't have a machine that is dual booting with windows I don't know that this will help you that much....maybe if someone who is dual booting to wins could post their grub.conf *hint* *hint*

Thanks all.
linux_terror
 
Old 09-07-2004, 12:56 PM   #8
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
Firstly, mar122999, please post your /boot/grub/menu.lst. This is the same file as what we are calling /boot/grub/grub.conf. The main GRUB configuration file can be named either.

Until you have done so, we cannot be sure, but I think the consensus here is that you most likely do not have a menu entry for Windows in your GRUB configuration, thus do not have the opportunity to boot Windows.

It also seems likely that your menu timeout is set to 0 seconds, so that you never even see the menu, which would explain why you boot directly into Linux, and also indicates that there is no menu entry for Windows, since the only time you don't need to see the menu at all is if there is only one choice on the menu (Linux, in this case, but Windows does the same thing with its bootloader menu, which you never see unless you have two versions of Windows installed).

I am no longer dual-booting, but since I simply commented out the Windows entry in /boot/grub/grub.conf from when I was dual-booting (rather than rewriting the whole thing), it's still available for me to post. So here it is (my current entries removed to minimize confusion, as I'm using several new features of the framebuffer):

Quote:
default 0
timeout 7
splashimage=(hd0,0)/grub/lila.xpm.gz

title=Gentoo Linux 2.6.7-gentoo-r11
root (hd0,2)
kernel /kernel-2.6.7-gentoo-r8 root=/dev/hda4 video=vesafb:ywrap,mtrr,noaccel vga=794 splash=silent
initrd=/boot/initrd-1280x1024

title=Win2K
rootnoverify (hd0,0)
chainloader +1
(hd0,0) is the first primary partition of the first drive, which is where Windows was located since that is its preferred location; GRUB is installed to (hd0), meaning the MBR of the first drive, and my root partition for Linux is (hd0,2), also known as /dev/hda3,

In any case, I think what people are saying is that you need an entry for Windows, similar to the one for Win2K above, in your /boot/grub/menu.lst. You should also check the timeout setting, and raise it to something reasonable above 0, so that you have sufficient time to choose the menu entry that you want.

Hope this helps.
 
Old 09-07-2004, 03:53 PM   #9
mar122999
LQ Newbie
 
Registered: Sep 2004
Posts: 12

Original Poster
Rep: Reputation: 0
Great info. But one question, It seems like I don't have proper permissions to access menu.lst. It has a lock over the file and says that I cannot access the file when I try to open it. Can you help me set my self up to be able to access that file?
 
Old 09-07-2004, 04:32 PM   #10
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
Open a terminal (Konsole, I guess, since SuSE uses KDE by default).

Type su at the prompt and hit Enter.

A Password: prompt will appear. Type the root password (very carefully, as it will not be echoed to the screen, even with stars), and hit Enter.

If the password was correctly typed, and the user is a member of the wheel group (if the user is not a member of the "wheel" group, open KUser and add the user to this group before proceeding), the prompt will change from whatever $ to whatever #. The # symbol indicates root access, meaning that any commands you type into that terminal will be carried out as if root had asked for them (because, atm, root is asking for them). Root access only applies to commands in that terminal; any commands executed from the desktop, panel, or menus will be executed with user access. The su command (along with its slightly bigger brother, su -, and its much bigger brother, sudo) is the reason that you as a user should never have to log in as root under normal circumstances-- meaning, unless the system does not boot, or your user login is broken.

Once you have root access, type mount /boot, if /boot is on a separate partition (which it probably is) and hit Enter. You should be returned to the prompt without a message, unless something has gone wrong.

Then type which kedit. This will return the path to the kedit executable (which I'm only telling you to find because in my experience, the KDE text editors do not like to be run with just the executable name in a terminal, like every other text editor I know. They don't seem to want to run from a terminal without the full pathname).

Once you have the path to kedit, type /path/to/kedit /boot/grub/menu.lst. This will open /boot/grub/menu.lst in kedit, with write privileges, because root is allowed to write to this file, and root has opened the file in the text editor.

An alternative manner of doing this would be to go through your Kicker menu (the K menu) and find the entry for "File Manager (Super User Mode)". I would tell you where it is, but every version of KDE I've ever used under various distros seems to put it somewhere else. Try System=>More Programs, for a start. When you select this entry, you'll have to type in the root password at the prompt, but then you have a file manager open with root privileges, so you can right-click on any text file, choose "Open With..." and open that file in a text editor, also with root privileges.

The only reason I didn't tell you to do it that way in the first place was that it won't work if /boot is on a separate partition, because you have to mount /boot first in order to access any files on that partition, and you would need to open a term and su to root in order to mount the /boot partition. Once you have the term open and have su-ed to root to mount the /boot partition, you might as well just do the whole thing from the term anyway (imo). But if /boot is not on a separate partition, you could do it from KFM (Super User Mode). (kfm stands for "Konqueror File Manager", in case you ever need to know the executable name for Konq in file management mode, rather than web browsing mode, where it is called 'konqueror').

Edit the /boot/grub/menu.lst file to your needs (or post it here first, and edit it later), save (if you edited it), and exit the text editor. If you used a terminal, but want to keep it open in user mode, type 'exit' to end the root access. If you don't need the terminal any more you can just close it via the close button, or type 'exit' twice (once to end the root access, once to end the user access, which will close the term).

After that, there's nothing to do but reboot and see if it worked.

Hope this helps.

Last edited by motub; 09-07-2004 at 04:36 PM.
 
Old 09-07-2004, 11:19 PM   #11
mar122999
LQ Newbie
 
Registered: Sep 2004
Posts: 12

Original Poster
Rep: Reputation: 0
Thanks for the long explanation! I think I learned enough from just following the directions. Thanks! Anyway, here is my menu.lst. It doesn't show Windows XP and the timeout looks OK. What do you think next?

# Modified by YaST2. Last modification on Thu Jun 10 04:25:33 2004


color white/blue black/light-gray
default 0
timeout 8
gfxmenu (hd0,1)/boot/message

###Don't change this comment - YaST2 identifier: Original name: linux###
title Linux
kernel (hd0,1)/boot/vmlinuz root=/dev/hda2 vga=0x31a splash=silent desktop resume=/dev/hda3 showopts
initrd (hd0,1)/boot/initrd

###Don't change this comment - YaST2 identifier: Original name: floppy###
title Floppy
root (fd0)
chainloader +1

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe
kernel (hd0,1)/boot/vmlinuz root=/dev/hda2 showopts ide=nodma apm=off acpi=off vga=normal noresume nosmp noapic maxcpus=0 3
initrd (hd0,1)/boot/initrd
 
Old 09-08-2004, 03:54 AM   #12
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
Well, firstly you would want to add an entry for Windows. There's no reason that you can't use the one I posted above, changing the title= to whatever you find appropriate, and the (hd#,#) to the correct designation for your Windows drive and partition.

The fact that you don't see a menu giving you the 3 options currently listed, for 8 seconds, is more of a problem, since if you aren't getting the menu, it won't matter whether Windows is on the menu or not.

Or was the problem indicated by
Quote:
Whenever the computer boots up, it automatically loads the linux OS and doesn't give me an option to choose which OS that I want.
not meant to indicate that you don't see the menu at all, but just that Windows was not on it, so after 8 seconds, it timed out and loaded the default, which is (unsurprisingly) SuSE?
 
Old 09-08-2004, 08:27 AM   #13
mar122999
LQ Newbie
 
Registered: Sep 2004
Posts: 12

Original Poster
Rep: Reputation: 0
No. I'm sorry. I get the menu that gives me a selection between Linux, Floppy, and Failsafe. I tried to enter in Windows (you can actually easily do it from Control Center > Yast2 Moduls > System > Boot Loader Configuration. In the boot loader conf., you can add or change everything inside of the menu.lst file. It will properly put a new menu item in there for you or change the timeout secs. Anyway, I have my primary partition setup with my Windows XP (C:, NTFS). Then I have another swap file before Linux. Then I have the linux partition. The only problem is, I don't know what my Windows XP hard drive is going to be (hd0,0), (hd0,2), hd(0,1). I've already tried both of these with no luck. It just says that nothing is on that partition. Here is my info from "boot loader configuration":

Boot Loader Type: GRUB
Boot Loader location: dev/hda2
Disk Order: dev/hda
Default Section: Linux
Availiable Sections: Linux (default), Floppy, Failsafe
Activate boot loader partition: No
Replace code in MBR: leave untouched
Back up affected disk areas: No
Add saved MBR to boot loader menu: No
Save method: save only changed files
----------------
Color: white/blue black/light-gray
timeout: 8s
gfx menu: (hd0,1)/boot/message

Now, whenever I click on the one that says "Availiable sections", I can choose that I want to "add" another boot partition (Windows). It gives me a prompt and I enter the name. Then I go down to three more options that I am not too familiar about. The first one is "root". By looking at the linux selection under this menu, I can tell that the root is for the: (hd0,0) or (hd0,1) or etc... The next option is "kernel". I tried to put chainloader +1 inside of here with no luck though. I'm not really sure what this one is exactely asking for. Lastly, which I haven't put anything in yet, is "initrd". Don't know what that one is.

Anyway, these are the options that I am giving to easily add another OS. Here are them in detail and what I have currently:

(This is inside the boot loader conf. menu "availiable sections" that is shown above)

Section Name: Windows XP
Section Type: image (this is what all of the other ones had)
---------------
root: (hd0,0)
kernel: chainloader +1
initrd :

Last edited by mar122999; 09-08-2004 at 08:32 AM.
 
Old 09-08-2004, 08:38 AM   #14
mar122999
LQ Newbie
 
Registered: Sep 2004
Posts: 12

Original Poster
Rep: Reputation: 0
Also, one more thing... I don't know if this matters, but I can't see my Windows XP partition within the "my computer" file browser on the desktop. I looked everywhere and really can't seem to find it. The only time that I have seen it was when I typed in something (forgot what it was) in the terminal and got a list of the partitions and how much space each partition was using. Everthing looked OK. Anyway, when I was setting up the partitions in "partition manager" within Windows, I did notice that the Windows XP partition said "hidden"??? I believe that it originally said this too before I started to partition the drives. Don't know if that matters?

Now, I can go into Suse "partitioner" that is located in the Control Center as well and see all of the partions there. Here is what they look like:

/dev/hda is my entire hard drive
/dev/hda1 is my hidden HPFS/NTFS partition
/dev/hda2 is my Linux partition
/dev/hda3 is my 500mb swap file

Whenever you "edit" the NTFS partition, you can see that it is set to a file system ID of 0x17 and the linux partition is set to 0x83. Don't know if that matters either.

Last edited by mar122999; 09-08-2004 at 08:45 AM.
 
Old 09-08-2004, 08:56 AM   #15
stevie_velvet
Member
 
Registered: Aug 2004
Location: Italia + UK
Distribution: RHEL 4 + Fedora FC5
Posts: 118

Rep: Reputation: 15
check its mounted in /etc/fstab & not as a hidden partition
...also read-write capability i think is experiemental ons suse 9.1 under the 2.6 kernel, so i would edit files on a NTFS partition when you do unhide it
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Multi boot problem (2 linux, 1 Win) Tim_Foust Linux - Newbie 5 10-06-2005 11:23 AM
How to Boot Multi Windows & Multi Linux olkar Linux - Newbie 5 10-03-2005 11:52 AM
SuSE, FC & Windows multi-boot powah Linux - Newbie 10 04-26-2005 02:08 AM
Multi-boot PC - Slack/SuSe/WinXP idris1388 Linux - Newbie 2 03-21-2004 08:04 AM
GRUB, Multi Linux/Multi Disk Boot gtnorton Linux - Software 1 03-16-2003 03:48 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:03 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration