LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-14-2011, 12:16 PM   #1
sharonshabtai
LQ Newbie
 
Registered: Mar 2011
Posts: 7

Rep: Reputation: 0
Problem with libassimp while running gazebo


Hi,
I have installed and built gazebo and it passed without any errors.
I'm running on ubunto 10.10, and I installed gazebo version 0.10 (straight from their website)
while trying to run it ( with a given world or without as shown below) I get the following error:
root:~# gazebo
gazebo: error while loading shared libraries: libassimp.so: cannot open shared object file: No such file or directory

I tried installing libassimp again, I have installed the 2.0 version from this link
http://sourceforge.net/projects/assi...es/assimp-2.0/

when searching for libassimp I get the following results:
root:~#find / | grep libassimp.so
/home/admin123/Downloads/gazebo-0.10.0/build/3rd_party/assimp/code/libassimp.so
/home/admin123/Downloads/assimp--2.0.863-sdk/build/code/libassimp.so.2.0.0
/home/admin123/Downloads/assimp--2.0.863-sdk/build/code/libassimp.so
/home/admin123/Downloads/assimp--2.0.863-sdk/build/code/libassimp.so.2
/usr/local/bin/libassimp.so
/usr/local/lib/libassimp.so

I would appreciate any help you can offer.
Thanks
 
Old 03-14-2011, 01:27 PM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2019 CentOS6.10 CentOS7.7 + 50+ other Linux OS, for test only.
Posts: 17,316

Rep: Reputation: 3578Reputation: 3578Reputation: 3578Reputation: 3578Reputation: 3578Reputation: 3578Reputation: 3578Reputation: 3578Reputation: 3578Reputation: 3578Reputation: 3578
Quote:
root:~# gazebo
Why are you running gazebo as root ? ?
Should be done as 'unprivileged user' only, I think.


My guess is that gazebo looks for libassimp.so in /usr/lib/
and not /usr/local/lib/

( One of say 400 binaries are hard coded to look in /usr/lib/ only.)

..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Error installing Player/Stage/Gazebo ksatyaki Linux - Software 1 01-24-2011 04:35 PM
[SOLVED] Problem running sa1 in HP-UX kaplan71 Other *NIX 4 11-17-2010 06:23 PM
graphic card problem with gazebo mustafa parlaktuna Fedora 0 07-21-2008 11:12 PM
some problem about running totalview ztdep Programming 0 07-25-2005 02:41 AM
Running 'cdrecord' problem satimis *BSD 12 06-05-2004 06:08 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:34 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration