LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-05-2006, 02:45 PM   #1
Deep-Blue-ro
LQ Newbie
 
Registered: Mar 2004
Location: Romania - TM
Distribution: slackware10, rh9
Posts: 21

Rep: Reputation: 15
problem with k3b and cdrecord


Hello

here is an issue:

I have a Slackware with kernel 2.6.17 but I can not write cd's from k3b.
Writing was working well with old kernel 2.4.31, but now cdrecord does not want to accept parameters passed from k3b.
I can write with:
Quote:
$ cdrecord dev=ATAPI:0,0,0 k3b_0.iso
and
Quote:
$ cdrecord -dummy dev=ATA:1,0,0 k3b_0.iso
BTW I do not know what is the difference between ATAPI:0,0,0 and ATA:1,0,0 from the cdrecord point of view.
When I try with k3b it tells:
Quote:
System
-----------------------
K3b Version:0.11.17
KDE Version: 3.4.2
QT Version: 3.3.4

cdrecord
-----------------------
Cdrecord-Clone 2.01 (i686-pc-linux-gnu) Copyright (C) 1995-2004 Jörg Schilling
TOC Type: 1 = CD-ROM
Using libscg version 'schily-0.8'.
Driveropts: 'burnfree'
/usr/bin/cdrecord: Warning: Running on Linux-2.6.17
/usr/bin/cdrecord: There are unsettled issues with Linux-2.5 and newer.
/usr/bin/cdrecord: If you have unexpected problems, please try Linux-2.4 or Solaris.
scsidev: '/dev/hdc'
devname: '/dev/hdc'
scsibus: -2 target: -2 lun: -2
Warning: Open by 'devname' is unintentional and not supported.
Linux sg driver version: 3.5.27
SCSI buffer size: 64512
/usr/bin/cdrecord: Cannot allocate memory. Cannot get SCSI I/O buffer.

cdrecord comand:
-----------------------
/usr/bin/cdrecord -v gracetime=2 dev=/dev/hdc speed=24 -tao driveropts=burnfree -eject -data -tsize=117081s -

mkisofs
-----------------------
117081
Warning: creating filesystem that does not conform to ISO-9660.
Warning: ISO-9660 filenames longer than 31 may cause buffer overflows in the OS.

mkisofs comand:
-----------------------
/usr/bin/mkisofs -gui -graft-points -volid K3b data project -volset -appid K3B THE CD KREATOR VERSION 0.11.17 (C) 2003 SEBASTIAN TRUEG AND THE K3B TEAM -publisher -preparer K3b - Version 0.11.17 -sysid LINUX -volset-size 1 -volset-seqno 1 -sort /tmp/kde-rteodor/k3bATnVoa.tmp -rational-rock -hide-list /tmp/kde-rteodor/k3b7ike7b.tmp -allow-leading-dots -full-iso9660-filenames -relaxed-filenames -allow-lowercase -no-iso-translate -allow-multidot -max-iso9660-filenames -iso-level 2 -path-list /tmp/kde-rteodor/k3b9m4Iha.tmp /home/rteodor/.kde/share/apps/k3b/temp/dummydir0/
In k3brc
Quote:
device_search_path=/dev/hdc
,
here I can not replace it with ATA:1,0,0 because , is a separator.

How can I tell k3b to use the dev ATA, because it does not work with /dev/hdc ?

Thank you
 
Old 08-06-2006, 07:05 AM   #2
aus9
LQ 5k Club
 
Registered: Oct 2003
Location: Western Australia
Distribution: voidlinux with LXDE
Posts: 5,509

Rep: Reputation: Disabled
hmmm until you get a better reply here are my tips

1) check /dev/hdc....atapi.....ata I suspect you have a hdc but not likely to have atapi or ata

2) permissions for (say) hdc need to set to allow your username....to belong to a group (in Mandriva I belong to burning group.....and ) whichever that group is....give it a rw- aka 6

3) In mandriva /usr/bin/cdrao has 755 aka rwx,r-x,r-x
ditto /usr/bin/cdrecord

and see if that helps?

btw I run k3b in KDE no probs with a 2.6.17.7 kernel
 
Old 08-06-2006, 08:20 AM   #3
Deep-Blue-ro
LQ Newbie
 
Registered: Mar 2004
Location: Romania - TM
Distribution: slackware10, rh9
Posts: 21

Original Poster
Rep: Reputation: 15
I think I was not very precisely with explanations:
1) /dev/hdc exists and is actualy the correct hardware. I can mount it and read.
But, ... you mean I should have a device /dev/ata ? and /dev/atapi ?
Even if they exist there it would not help, because as I previously said actualy I can burn with:
cdrecord dev=ATAPI:0,0,0 k3b_0.iso and
cdrecord -dummy dev=ATA:1,0,0 k3b_0.iso
but not with
cdrecord dev=/dev/hdc k3b_0.iso
and k3b is running cdrecord only with last command I printed.

2) and 3) permision on hdc is 777 in order to not having any worries about this. I will fill /etc/group when everyting will be running.

What I would like to know is how I can make k3b to make the request by the first or second comand.
Or maybe it is better to install a smarter version of cdrecord ..., I do not know yet.
 
Old 08-07-2006, 09:08 AM   #4
aus9
LQ 5k Club
 
Registered: Oct 2003
Location: Western Australia
Distribution: voidlinux with LXDE
Posts: 5,509

Rep: Reputation: Disabled
I was trying to say your /devices folder will only have a hdc entry.

Now CLI man cdrecord gives some tips.

cdrecord --scanbus for my atapi cable dvd burner gives this output

0,0,0 0) 'ATA ' 'WDC WD800JD-00LS' '06.0' Disk

As I use the gui ...for k3b this is new for me but it stands for Western digital so its my SATA hard drive.

The change occurred with the 2.6 kernel and it now allows scsi functions on ata type devices.

this link altho Mdk explains it better than me
http://www.brunolinux.com/02-The_Ter...Kernel_26.html


so to confirm why hdc fails retry this
cdrecord dev=ATA -scanbus

if you still get hdc.......onto your last question


2) so....you have hdc but you have to use atapi...etc and can not use the gui.

In which case create a script.....create a folder (called ISO and only have the target iso in there and name it iso.iso

your script will look something like this assuming you have bash

#! /bin/bash
cd /home/yourname/ISO
cdrecord dev=ATAPI:0,0,0 iso.iso

save the script maybe in /home/your name/ISO and create a desktop shortcut to it assuming you have access to KDE

You then re-enter properties for icon and change the permissions to allow EXECUTE.


This allows you to download a iso somewhere then you copy it to the ISO folder and with one click hopefully burn the iso?
 
Old 08-07-2006, 09:13 AM   #5
masonm
Senior Member
 
Registered: Mar 2003
Location: Following the white rabbit
Distribution: Slackware64 -current
Posts: 2,300

Rep: Reputation: 90
Easy solution. Remove k3b completely.

Install version 0.12.16 and run k3b setup.
 
Old 08-07-2006, 08:14 PM   #6
Deep-Blue-ro
LQ Newbie
 
Registered: Mar 2004
Location: Romania - TM
Distribution: slackware10, rh9
Posts: 21

Original Poster
Rep: Reputation: 15
Well I installed k3b v0.12.16 and it worked. But I do not understand why k3b need to be replaced and not cdrecord.

The command used this time:
Quote:
/usr/bin/cdrecord -v gracetime=2 dev=/dev/hdc speed=10 -tao driveropts=burnfree -eject -multi -xa -tsize=117087s -
is pretty much the same as the command that did not work.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
K3b Cdrecord inescapeableus Linux - Software 5 03-16-2005 02:27 AM
k3b; cdrecord; cdda2wav PROBLEM! pepeq SUSE / openSUSE 2 10-20-2004 01:35 PM
Suse 9.1; k3b; cdrecord; cdda2wav PROBLEM. pepeq Linux - Software 5 10-20-2004 01:33 PM
k3b + cdrecord problem on Slackware 10? kemplej Linux - Software 0 07-01-2004 10:15 AM
K3B problem (unable to find cdrecord / cdrdao) zeadriche Linux - Newbie 3 06-04-2004 07:50 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration