-   Linux - Software (
-   -   Problem with Grub configuration (updated kernel) (

Patrique 06-05-2004 05:21 AM

Problem with Grub configuration (updated kernel)

At first I think you'd like to see my grub.conf file:
# grub.conf generated by anaconda
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You do not have a /boot partition. This means that
# all kernel and initrd paths are relative to /, eg.
# root (hd0,2)
# kernel /boot/vmlinuz-version ro root=/dev/hda3
# initrd /boot/initrd-version.img
title Red Hat Linux (2.4.20-8)
root (hd0,2)
kernel /boot/vmlinuz-2.4.20-8 ro root=LABEL=/ hdc=ide-scsi
initrd /boot/initrd-2.4.20-8.img

title tekram
root (hd0,2)
kernel /boot/bzImage ro root=LABEL=/ hdc=ide-scsi

title Windows XP
rootnoverify (hd0,0)
chainloader +1

I had to compile a new kernel version because I wanted to install the tekram DC315U scsi drivers. So far everything worked fine.
Now I tried to implement the new kernel, named bzImage, which I copied into the /boot directory.
I used the same options as they are used for booting the original kernel 2.4.20-8 and changed only the name of the kernel file from vmlinuz-2.4.20-8 to bzImage.
But when I choose the tekram-option in grub at startup I get an error message, that now boot device could be found.
The original Kernel still works fine.

Is there anything wrong in my grub.conf file? (despite the fact, that I'm using WinXP as default OS :)
I'm going to restart now and will write down the full error message, because I don't have it in mind. I'll post it later.

thanks for any help!

lacerto 06-05-2004 05:25 AM

I notice you are using initrd in the other configuration. You may need to create an initrd for you new kernel.

mkinitrd -i initrd-bzImage -k bzImage

lacerto 06-05-2004 05:27 AM

Then add it it to your grub file of course

karans 06-05-2004 05:46 AM


Yes , you will need the initrd to boot into the newly compiled image


Patrique 06-05-2004 08:56 AM

You were absolutely right.

I made the init-file, implemented it into grub.conf and now everything is fine!

Thank you.

All times are GMT -5. The time now is 10:42 AM.