LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-01-2007, 01:31 PM   #1
RemusX2
Member
 
Registered: Oct 2003
Location: Bozeman, Montana
Distribution: Gentoo 2010, Ubuntu 9.04
Posts: 175

Rep: Reputation: 30
Problem with growisofs


Through K3b, I mounted a DVD and browsed through it within K3b. Then I unmounted the dvd and pressed eject, nothing happened. I could then no longer eject the dvd normally. ie: unmounting, pressing the eject button, or eject /dev/sr0, etc...

Now whenever I try to burn something within k3b or via command line I get this error:

:-( unable to O_EXCL /dev/sr0: someone was in time to remount?

I've googled around and havn't found anything.

Any help would be greatly appreciated.

Thanks
Brandon
 
Old 11-01-2007, 02:13 PM   #2
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian stable
Posts: 5,908

Rep: Reputation: 356Reputation: 356Reputation: 356Reputation: 356
A look at the k3b log might prove helpful. Try this:
cat ~/.kde/share/apps/k3b/lastlog.log | tail -n 20

The -n 20 shows the last 20 lines of the log. Increase/decrease the number to change the numer of lined to view.
 
Old 01-14-2009, 07:50 PM   #3
Earp1848
LQ Newbie
 
Registered: Jan 2009
Posts: 1

Rep: Reputation: 0
Quote:
Originally Posted by RemusX2 View Post
Through K3b, I mounted a DVD and browsed through it within K3b.
Now whenever I try to burn something within k3b or via command line I get this error:

:-( unable to O_EXCL /dev/sr0: someone was in time to remount?
I have spent a lot of time today trying to eliminate this error when trying to burn a dvd using K3b.

I finally looked for the rest of the error "someone was in time to remount" and found a reference to the fstab file located at /etc/fstab. It's the config file for storage devices.

There I saw a line setting up my cdrom/dvd like this:
/dev/cdrom /media/cdrom auto rw,noauto,user,exec 0 0

I have read that this is the correct setup line for a cdrom. Anyway, I changed the first "auto" to the more precise "iso9660." I rebooted and K3b had no problems. I had spent a lot of time before this changing permissions and installing a newer growisofs.

The change also fixed a strange boot error about a missing UUID.(By the way, X-CD-Roast found the cdrom drive anyway without the fstab fix. Weird.)

I still can't believe this simple change solved it.

Last edited by Earp1848; 01-14-2009 at 09:05 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
growisofs question/problem eagle63 Linux - Newbie 2 12-23-2005 07:55 PM
growisofs problem scng Linux - Software 1 10-07-2005 07:38 PM
growisofs DVD Burning Problem dAdA_X Linux - General 0 01-03-2005 07:09 AM
Problem with K3b and growisofs Machinegun Linux - Software 0 07-06-2004 03:37 AM
growisofs sethgeekx86 Slackware 4 04-20-2004 06:23 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration