-   Linux - Software (
-   -   Problem with Gnome fonts (DPI) after installining GTK+2 (

satellitejune 12-26-2003 09:26 PM

Problem with Gnome fonts (DPI) after installining GTK+2
Hey guys, hope someone can bestow some wisdom upon me.

I'm somewhat of a new linux user. I'm running RH9 with 2.6.0 kernel on a laptop and so far, pretty much no problems.

I compiled and installed GTK+2, which I needed for some programs but I would get a gtk-config not found error, while trying to compile the programs that needed it (even though I'm fairly certain I put the write paths in the environmont variables)

After installing GTK however, I have found that the fonts in all my GTK applications in Gnome are about 75% of the size they used to be. This goes for my desktop icons, window text, window borders and I guess everything else that uses gtk (or resembles something in the gtk-demo program).

I have already tried a variety of things to fix this. For instance, going into the Applications->Preferences->Font->Details and changing the Font Resolution DPI only seems to change non-GTK dependent applications. An example of this is Terminal, where the text in term gets scaled by the DPI setting. Also, if I set the terminal font to Sans 12, which is the supposed desktop font, the terminal Sans 12 is what I'm used to (correct) and much larger than my now shrunken desktop font.

I've also tried editing my fonts.conf file to have 100 dpi fonts load first before 75 dpi, but I'm not sure these solutions are in the right direction. Is there perhaps a gtk file that could be tweaked so I can correct the sizes of my fonts?

Thanks to anyone who can help,

satellitejune 12-26-2003 09:41 PM

I forgot to add... when I go into Display Properties and change the monitor's (it's a laptop LCD and unprobable) physical DPI to W: 12 in, H: 9 in.. the fonts became incredibly huge, so much so that two lines take up the whole screen and can't display more than 6 characters or so width wise. Strange that this affects GTK font dpi while Font Rendering Details does not.

All times are GMT -5. The time now is 07:29 PM.