Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 08-27-2003, 05:28 PM   #1
LQ Newbie
Registered: Aug 2003
Posts: 5

Rep: Reputation: 0
Problem with GLib

I sucessfully installed glib-2.2.0 from source
but getting error when i install some software dependent on glib ...
Im using Red Hat Linux 7.3. i need some software (XChat) which requires me to
install GLib >= 2.0.2. so i downloded the latest version from www_gtk_org]
(2.2.0) and begin installation process. I did the following:
1: installed GLib via
#make install
2: put a line in /etc/
3: run /sbin/ldconfig
Everyrthing seems OK, but when i try to install atk-1.0.3 from source i get
the error:
"*** 'pkg-config --modversion glib-2.0' returned 2.2.0, but GLIB (2.0.1)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files"

#export LD_LIBRARY_PATH=/usr/local/lib
#export PKG_CONFIG_PATH=/usr/local/glib-2.2.0
Im still getting the same erorr. I uninstall the old GLib via
# rpm -e --nodeps glib
#rpm -e -no --deps glib-devel
and delete all glib specific modules / executables from /usr/bin. But still
getting the same error!!! :S

...Sometimes I can run the configure script (in case of pango-1.0.5 not
atk-1.0.3). But Then I have make error.

Im using KDE 3.0 not GNOME...
I dont want to install glib via RPM because it requires me to install lots of
other RPMs...

when it didnt work, i also built GLib RPM via checkinstall and install it but
still getting the same error (RPM installed successfully problem is with GLib
Dependent Software)...

Please help me solve my problem...

thanks in advance...

PS: I dont use apt-get as does not response to my domain, i
Old 08-27-2003, 05:47 PM   #2
Registered: Jul 2003
Location: Cincinnati, Ohio
Distribution: Slackware 9 (current), Gentoo 1.4, Redhat shrike
Posts: 86

Rep: Reputation: 15
Did you remove your old Glib before you installed the new one, as the error asks? If you didn't, the first thing I'd to is go back and remove both versions (not only the one you just installed but the one you had on there before that.)

If you removed your old glib before building the new one on top of that one, then I'd ask you to post your /etc/ file.
Old 08-28-2003, 04:40 PM   #3
LQ Newbie
Registered: Aug 2003
Posts: 5

Original Poster
Rep: Reputation: 0
i remove it all. but now im getting error:
"checking for GLIB - version >= 2.0.0... no
*** Could not run GLIB test program, checking why...
*** The test program compiled, but did not run. This usually means
*** that the run-time linker is not finding GLIB or finding the wrong
*** version of GLIB. If it is not finding GLIB, you'll need to set your
*** LD_LIBRARY_PATH environment variable, or edit /etc/ to point
*** to the installed location Also, make sure you have run ldconfig if that
*** is required on your system
*** If you have an old version installed, it is best to remove it, although
*** you may also be able to get things to work by modifying LD_LIBRARY_PATH
configure: error:
*** GLIB 2.0.0 or better is required. The latest version of
*** GLIB is always available from
i modified /etc/ as /usr/local/glib-2.2.0/glib
and set LD_LIBRARY_PATH=/usr/local/glib-2.2.0/glib
but still getting the same error! please tell me whats wrong now. is the path of glib library is worng...??? I mean which folder i must point to???
Old 08-31-2003, 01:41 PM   #4
Registered: Jul 2003
Distribution: Slackware 9.1
Posts: 195

Rep: Reputation: 30

Don't know if this will help, but when installing 2.2.3, i found "make install" doesn't copy the libs to a dir in my default path.

What I had to do is go into /glib_directory/glib/.libs

and copy to /usr/lib and then do the symlinking: -> ->

You also have to do this for the following subdirs of glib:

gobjects, gmodules, gthread

Note that the name of the libdirs for these folders is also ".libs" so it won't show up with just "ls". Do the symlinking and hey-presto the libs are in place.

The next error you'll probably get when compiling dependent source is: "can't find glib-config". =|

If you find out how to sort that out, let me know!


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
conflicting glib versions and glib-config scius Linux - Software 5 06-03-2008 03:35 AM
xmms install (needs glib>1.22), just installed glib 2.4.8 and still get error message eskiled Linux - Software 2 12-19-2005 10:12 PM
glib problem sameer666 Linux - Newbie 2 12-03-2005 01:49 PM
can't install gtk 2.4.4: "Requested 'glib-2.0 >= 2.4.0' but version of GLib is 2.2.3 webazoid Linux - Software 0 07-15-2004 07:07 PM
Glib problem Crazystorm2002 Mandriva 4 09-23-2003 09:41 PM > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:53 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration