Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 01-23-2005, 11:23 AM   #1
LQ Newbie
Registered: Jan 2005
Location: Switzerland
Distribution: debain lenny, slackware 10.0, vectorlinux 4.3, kubuntu feisty
Posts: 23

Rep: Reputation: 15
Problem with ffmpeg compiling vlc


I am running Slackware 10.0, kernel 2.4.26 and trying to install vlc.
got vlc from


and ffmpeg also,

when i try to make ./configure for vlc, i got the follwing problems:

it didnt find

(i compiled ffmpeg with --enable-gpl --enable-pp --enable-share-pp)

well i found something in ffmpeg/libavcodec/libpostproc/postprocess.h

copied this file to /usr/include/postproc/postprocess.h

and ./configure didnt complain anymore,

I guess it is not correct to do that, i figured I'll just give it a try like this...

./configure for vlc again,

checking for ffmpeg/avcodec.h... yes
checking postproc/postprocess.h usability... yes
checking postproc/postprocess.h presence... yes
checking for postproc/postprocess.h... yes
checking for avcodec_init in -lavcodec... no
configure: error: Could not find ffmpeg on your system: you may get it from (cvs version is recommended). Alternatively you can use --disable-ffmpeg to disable the ffmpeg plugins.

so you see, i got a bit further than postproc before...

i see i can disable ffmpeg, but that is not what i want

i also tryed with ffmpeg version from cvs but it didnt work either

any suggestions?
Old 01-23-2005, 11:42 AM   #2
LQ Newbie
Registered: Jan 2005
Location: Switzerland
Distribution: debain lenny, slackware 10.0, vectorlinux 4.3, kubuntu feisty
Posts: 23

Original Poster
Rep: Reputation: 15
oh, by the way,

when i try ./configure for vlc with --disable-ffmpeg

it complains it couldnt find the qt embedded development headers

checking for qt.h... no
configure: error: echo "Cannot find QT Embedded development headers."

i installed

=> Installing pyqt-3.12-i486-1mht... DONE!
=> Installing qt-3.3.3-i486-1pcx... DONE!

with swaret, but it didnt help!
Old 02-21-2005, 04:08 AM   #3
LQ Newbie
Registered: Feb 2005
Location: China
Posts: 1

Rep: Reputation: 0
When you complet ffmpeg you can try

1. --enable-gpl --enable-pp --enable-share-pp --enable-shared

2. make "postproc" alone

3. make ffmpeg
Old 12-11-2005, 05:46 PM   #4
Registered: Oct 2004
Location: Austin, TX
Distribution: Ubuntu Dapper Drake
Posts: 39

Rep: Reputation: 15
If you're getting the error about a missing qt.h or "Cannot find QT Embedded development headers." then you need opie. Do: apt-get install libopie-dev


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with ffmpeg.. BDiddy Linux - Software 0 10-18-2005 04:38 PM
Problem executing a linux script from php that runs ffmpeg darkisolde Linux - Software 4 10-04-2005 08:43 AM
Transcode & FFMPEG compiling error CrEsPo Slackware 2 05-10-2005 04:17 PM
VLC problem n3tw0rk Linux - Software 0 10-15-2004 05:46 AM
Curious problem with ffmpeg EwanG Linux - Software 0 05-07-2004 09:30 AM > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:14 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration