LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-28-2010, 11:39 AM   #1
brucehinrichs
Member
 
Registered: Mar 2008
Location: US
Distribution: Debian Sid; Sabayon, UbuntuStudio, Slackware-multilib 13.1, Peppermint Ice, CentOS
Posts: 575

Rep: Reputation: 69
problem with /etc/init.d/vboxdrv setup


Hi all,
I installed virtualbox, checked that I have kernel headers, kernel source, and build-essential. I go through the Create New Virtual Machine Wizard and the Create New Virtual Disk dialogue. I then open File>>Virtual Disk Manager and add the iso image I want to load on the VM (happens to be ubuntu-netbook-remix-9.10). When I try to power up the VM i get two error boxes:

Failed to open a session for the virtual machine
ubuntu910netbook
Code:
Virtual machine 'ubuntu910netbook' has terminated unexpectedly during startup.


Result Code: 
NS_ERROR_FAILURE (0x80004005)
Component: 
Machine
Interface: 
IMachine {1e509de4-d96c-4f44-8b94-860194f710ac}
and:

Code:
VERR_VM_DRIVER_NOT_INSTALLED (rc=-1908)

The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Re-setup the kernel module by executing

'/etc/init.d/vboxdrv setup'

as root. Users of Ubuntu or Fedora should install the DKMS package at first. This package keeps track of Linux kernel changes and recompiles the vboxdrv kernel module if necessary.
So I fire up a terminal:

Code:
[bruce@Frank2 ~]$ su
Password:
[root@Frank2 bruce]# /etc/init.d/vboxdrv setup
 * Stopping VirtualBox kernel module                                                                 *  done.
 * Recompiling VirtualBox kernel module
 * Look at /var/log/vbox-install.log to find out what went wrong
[root@Frank2 bruce]#
then:

Code:
[root@Frank2 bruce]# cat /var/log/vbox-install.log
make KBUILD_VERBOSE=1 -C /lib/modules/2.6.32-1-mepis64-smp/build SUBDIRS=/var/tmp/vbox.0 SRCROOT=/var/tmp/vbox.0 modules                                                                                
make[1]: Entering directory `/usr/src/linux-headers-2.6.32-1-mepis64-smp'                           
make -C /usr/src/linux-headers-2.6.32-1-mepis64-smp \       

...

-D"KBUILD_MODNAME=KBUILD_STR(vboxdrv)"  -c -o /var/tmp/vbox.0/linux/SUPDrv-linux.o /var/tmp/vbox.0/linux/SUPDrv-linux.c
/var/tmp/vbox.0/linux/SUPDrv-linux.c: In function 'VBoxDrvLinuxCreate':
/var/tmp/vbox.0/linux/SUPDrv-linux.c:650: error: 'struct task_struct' has no member named 'euid'
/var/tmp/vbox.0/linux/SUPDrv-linux.c:663: error: 'struct task_struct' has no member named 'uid'
/var/tmp/vbox.0/linux/SUPDrv-linux.c:664: error: 'struct task_struct' has no member named 'gid'
make[4]: *** [/var/tmp/vbox.0/linux/SUPDrv-linux.o] Error 1
make[3]: *** [_module_/var/tmp/vbox.0] Error 2
make[2]: *** [sub-make] Error 2
make[1]: *** [all] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.32-1-mepis64-smp'
make: *** [vboxdrv] Error 2
I searched the forums, found this post which seems to be related, but not the same. (Tried google, too without much luck).
Any help is appreciated, as this is my first try at VMs.

EDIT: almost forgot: I'm trying this on MEPIS 8.5.00-rc3_64, kernel version 2.6.32-1-mepis64-smp

Last edited by brucehinrichs; 03-28-2010 at 11:46 AM.
 
Old 03-28-2010, 12:12 PM   #2
brucehinrichs
Member
 
Registered: Mar 2008
Location: US
Distribution: Debian Sid; Sabayon, UbuntuStudio, Slackware-multilib 13.1, Peppermint Ice, CentOS
Posts: 575

Original Poster
Rep: Reputation: 69
I just realized this thread should probably be in virtualization. Could a moderator move it for me, if appropriate, please?
 
Old 03-28-2010, 03:54 PM   #3
brucehinrichs
Member
 
Registered: Mar 2008
Location: US
Distribution: Debian Sid; Sabayon, UbuntuStudio, Slackware-multilib 13.1, Peppermint Ice, CentOS
Posts: 575

Original Poster
Rep: Reputation: 69
Nevermind, solved.
 
Old 03-28-2010, 05:49 PM   #4
Hammett
Senior Member
 
Registered: Aug 2003
Location: Barcelona, Catalunya
Distribution: Gentoo
Posts: 1,045

Rep: Reputation: 54
It would be nice if you can post how did you solve it, so other users sharing the same problem can follow your steps.

Thanks!
 
Old 03-28-2010, 08:32 PM   #5
brucehinrichs
Member
 
Registered: Mar 2008
Location: US
Distribution: Debian Sid; Sabayon, UbuntuStudio, Slackware-multilib 13.1, Peppermint Ice, CentOS
Posts: 575

Original Poster
Rep: Reputation: 69
I removed virtualbox through Synaptic (Mark for Complete Removal) and followed the guide for Mepis 8 here. Worked like a charm!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting Virtual Box to run XP problem with the /etc/init.d/vboxdrv setup FrankRhoades Linux - Software 10 01-24-2010 12:06 PM
Installing VirtualBox from SlackBuild - Slackware 12 - vboxdrv problem Do7AN Slackware 9 01-22-2009 01:58 PM
problem with virtualbox and vboxdrv driver shifter Ubuntu 2 06-08-2008 11:10 AM
problem with virtualbox and vboxdrv driver shifter Linux - Software 1 06-07-2008 11:14 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration