LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-20-2008, 01:14 AM   #1
claylong
LQ Newbie
 
Registered: Feb 2003
Location: NY, USA
Distribution: FC7
Posts: 18

Rep: Reputation: 0
Problem with "Always on top" in Rdesktop + SeamlessRDP


I am running Fedora 9 with Gnome and Compiz. I have an XP Pro virtual machine running in VMware server. The XP machine has the SeamlessRDP executables, and I am able to successfully connect to the XP vm using the SeamlessRDP option in rdesktop (-A).

For those that may not know, use of SeamlessRDP means that a new X window is created for each new window on the VM, making the windows applications look native to the gnome desktop.

At some point during all my recent upgrades (upgraded to FC9 from FC7, updated vmware server, updated seamlessrdp binaries on the vm) I started having problems with the SeamlessRDP windows on the linux desktop. As far as I can tell, each X window get it's "Always on top" attribute set every time I focus the window. In other words, I will have iTunes open (running on the VM, showing up as it's own window in Gnome) and every time I focus on the window, the "Always on top" setting is turned on. If I turn it off, unfocusing and refocusing the windows turns the setting back on.

I thought the problem could be one of the following:
1.) Some strange use of the rdesktop always-on-top patch (http://www.fontis.com.au/rdesktop).
2.) Rdesktop forcing the always-on-top setting b/c it thinks I am running a fullscreen RDP window (i think it does this for regular RDP fullscreen sessions, no?)
3.) Compiz forcing the always-on-top setting ON for some strange reason. While I did find a rule in the Window Management -> Window Rules area of the Compiz settings for "Above", it looks like it can only be use to force the setting ON, not OFF.

Any suggestions as to how I can stop rdesktop or SeamlessRDP or Compiz from forcing the "Always on top" setting?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
"Error: Connection rest by peer" with rdesktop Abdallah Al-Dhamin Linux - Networking 1 11-02-2008 05:46 AM
Suggestion: for "subscribed threads" & "top of page" buttons Old_Fogie LQ Suggestions & Feedback 7 07-10-2006 06:10 PM
Where to download precompiled bash binaries, such as "time" and "top"? elinuxqs Linux - Newbie 12 11-14-2005 09:36 PM
problem with "top menu bar" in KDE robbymcw Linux - Software 1 03-25-2005 06:26 PM
Programs don't like "staying on top" or "always on top" -- any help? SBing Linux - Software 8 07-05-2004 05:41 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration