LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Problem using rsync to back up large files to external harddrive (https://www.linuxquestions.org/questions/linux-software-2/problem-using-rsync-to-back-up-large-files-to-external-harddrive-727052/)

donnaaparis 05-19-2009 10:18 AM

Problem using rsync to back up large files to external harddrive
 
I have a 500GB Lacie Quadra 2 external hard drive which I have formatted as ext3.

I'd like to use rsync to backup up my home directory. But the command :

% > sudo rsync -av /home/donna/ /media/Desktop/backup.0/

hangs on large files. By 'large', I only mean files < 100MB. (so not so large). Killing rsync usually works, but then when I do an 'ls' on on mounted file system, even 'ls' hangs. Eventually my whole system gets stuck.

Simply copying the offending files (e.g. data000.hdf5) to the externally mounted disk works instanteonously.

I am copying to the Lacie drive over USB (via a 6 foot extension cable).

Are there any known problems with rsync that might explain this?

farslayer 05-19-2009 11:37 AM

not with rsync that I am aware of. I backup files that are over 250 MB up to and including some multi GB .iso images to my External USB/Firewire drive (yes Ii alternate which connection it's using at times.) using rsync and have not had the issue you are describing.

It is by nomeans a fast process, I run it at off hours so I'm not sitting there watching it or waiting for it to finish

tredegar 05-19-2009 02:52 PM

I have had problems with LaCie drives (their early ones, I do not have a "Quadra"): They look good, but don't always work well. (I had two - one is reliable, the other NOT - it sometimes hung, like yours does, so the enclosure, but not the disk, eventually went to the dump).

6foot for "high speed" USB may be stretching things. Have you tried using a shorter (or just a different) cable ?

Any useful errors in /var/log/messages ?

rsync has always worked perfectly for me, so I don't think the problem lies there.

Hope this helps.

donnaaparis 05-19-2009 04:35 PM

The only thing I can think of is that I am not using rsync correctly. I issued the command :

%> rsync -av /donna/home/ /media/Desktop/backup.0/

I am assuming that

(1) the directory 'backup.0' doesn't need to already exist on the mounted disk and so for first time backups, rsync is behaving
essentially like a copy command.

(2) the final backslash doesn't matter.

I am going to double check, but I am fairly sure that just doing a copy of the larger file worked perfectly. And the long cable was another concern I had, so I'll check that out too.

donnaaparis 05-20-2009 08:18 AM

USB cable too long!
 
I got rid of the USB extension cable and now everything seems to work perfectly. Disk write speeds are reasonable - about 32 mb/s on my Lacie Qaudra.

Don't know what the problem was with the extension cable, though. Was it too long (6ft)?

tredegar 05-20-2009 09:33 AM

The USB 2.0 specification states the maximum cable length is 5m (16.4ft) but maybe you just had a bad cable, or there were timing issues with the LaCie. The only way to find out is by trying different cables and testing their performance.

Anyway, glad you got it working.

farslayer 05-20-2009 09:55 AM

I just threw out a usb cable the other day because it was defective.. they do go bad on occasion, even with no visible indication of damage.

Could just be a cheap poorly made/designed cable too..

donnaaparis 05-20-2009 04:05 PM

USB cable faulty?
 
And I forgot to mention that I had it connected to the USB cable that came with the Lacie drive and so the two cables together were probably about 10 ft.

The extension appeared to work fine when attached to my USB key, although in that situation, I generally transfered much smaller files. But I'll be wary of using the longer cable from now on.

It's just is such a pain to crawl under the desk to plug in a USB key...

thanks again.


All times are GMT -5. The time now is 04:02 AM.