LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Closed Thread
  Search this Thread
Old 06-06-2019, 12:51 AM   #31
Huamin
Member
 
Registered: May 2011
Posts: 562

Original Poster
Rep: Reputation: 12

Yes, below line is un-remarked

anon_upload_enable=YES

and I re-do this
service vsftpd start

But I still got attached error.
Attached Thumbnails
Click image for larger version

Name:	43c.png
Views:	4
Size:	13.6 KB
ID:	30707  
 
Old 06-06-2019, 03:44 AM   #32
scasey
Senior Member
 
Registered: Feb 2013
Location: Tucson, AZ, USA
Distribution: CentOS 7.7.1908
Posts: 4,274

Rep: Reputation: 1495Reputation: 1495Reputation: 1495Reputation: 1495Reputation: 1495Reputation: 1495Reputation: 1495Reputation: 1495Reputation: 1495Reputation: 1495
What are you using on the client side to make that connection?
Are you
Code:
cd pub
before attempting the upload?

I can connect to your server anonymously, but can't upload either. You must not have the permissions set correctly on the pub folder. What are they?

Last edited by scasey; 06-06-2019 at 03:49 AM.
 
Old 06-06-2019, 04:25 AM   #33
Huamin
Member
 
Registered: May 2011
Posts: 562

Original Poster
Rep: Reputation: 12
Hi Scasey,
Can I have more details to adjust privileges of pub folder, like to create proper user account for accessing it?

Last edited by Huamin; 06-06-2019 at 04:42 AM.
 
Old 06-06-2019, 06:58 AM   #34
michaelk
Moderator
 
Registered: Aug 2002
Posts: 19,427

Rep: Reputation: 3105Reputation: 3105Reputation: 3105Reputation: 3105Reputation: 3105Reputation: 3105Reputation: 3105Reputation: 3105Reputation: 3105Reputation: 3105Reputation: 3105
You need to change permissions to allow anyone to write to the directory but please do not allow anonymous login or writing on a public ftp server.

You need to configure ssl/tls. In addition you need to use a ftp client that has ssl capability like lftp or a GUI like filezilla.

https://www.digitalocean.com/communi...n-a-centos-vps
 
Old 06-06-2019, 07:48 AM   #35
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 22,243

Rep: Reputation: 5975Reputation: 5975Reputation: 5975Reputation: 5975Reputation: 5975Reputation: 5975Reputation: 5975Reputation: 5975Reputation: 5975Reputation: 5975Reputation: 5975
Quote:
Originally Posted by scasey View Post
What are you using on the client side to make that connection?
Are you
Code:
cd pub
before attempting the upload? I can connect to your server anonymously, but can't upload either. You must not have the permissions set correctly on the pub folder. What are they?
...and...
Quote:
Originally Posted by michaelk
You need to change permissions to allow anyone to write to the directory but please do not allow anonymous login or writing on a public ftp server. You need to configure ssl/tls. In addition you need to use a ftp client that has ssl capability like lftp or a GUI like filezilla.
Guys, from post #26, where the OP said:
Quote:
Originally Posted by Huamin
I was accessing sftp://113.255.213.124/ and am able to see the folder "pub" within it. What to adjust, within /etc/vsftpd.conf? I expect to be able to write to this SFTP.
(bolded parts for emphasis)

This is much like the OP's MANY other threads; what little you can drag out is contradicted or confusing. He's saying he wants SFTP now, but for some other-worldly reason, thinks making changes to the vsftpd configuration will help.
 
1 members found this post helpful.
Old 06-06-2019, 09:53 AM   #36
scasey
Senior Member
 
Registered: Feb 2013
Location: Tucson, AZ, USA
Distribution: CentOS 7.7.1908
Posts: 4,274

Rep: Reputation: 1495Reputation: 1495Reputation: 1495Reputation: 1495Reputation: 1495Reputation: 1495Reputation: 1495Reputation: 1495Reputation: 1495Reputation: 1495
Quote:
Originally Posted by Huamin View Post
Hi Scasey,
Can I have more details to adjust privileges of pub folder, like to create proper user account for accessing it?
Perhaps, if you were to post some details of what you have set up now. We're not mind readers. We can't tell you what's wrong if you won't show us what you've done.
 
1 members found this post helpful.
Old 06-06-2019, 09:57 AM   #37
scasey
Senior Member
 
Registered: Feb 2013
Location: Tucson, AZ, USA
Distribution: CentOS 7.7.1908
Posts: 4,274

Rep: Reputation: 1495Reputation: 1495Reputation: 1495Reputation: 1495Reputation: 1495Reputation: 1495Reputation: 1495Reputation: 1495Reputation: 1495Reputation: 1495
Quote:
Originally Posted by TB0ne View Post
This is much like the OP's MANY other threads; what little you can drag out is contradicted or confusing. He's saying he wants SFTP now, but for some other-worldly reason, thinks making changes to the vsftpd configuration will help.
Yeah. Don't disagree with your observation at all. He did switch from ftp to sftp and back again...<sigh>
 
1 members found this post helpful.
Old 06-06-2019, 10:19 AM   #38
michaelk
Moderator
 
Registered: Aug 2002
Posts: 19,427

Rep: Reputation: 3105Reputation: 3105Reputation: 3105Reputation: 3105Reputation: 3105Reputation: 3105Reputation: 3105Reputation: 3105Reputation: 3105Reputation: 3105Reputation: 3105
Although the OP posted sftp I think it was in error and actually used ftp. I can use sftp:// in the Windows file browser but it is associated with WinSCP because that is what that particular computer has installed otherwise an error message should be displayed. pub is the ftp default anonymous directory.

Last edited by michaelk; 06-06-2019 at 11:04 AM.
 
Old 06-06-2019, 11:01 AM   #39
scasey
Senior Member
 
Registered: Feb 2013
Location: Tucson, AZ, USA
Distribution: CentOS 7.7.1908
Posts: 4,274

Rep: Reputation: 1495Reputation: 1495Reputation: 1495Reputation: 1495Reputation: 1495Reputation: 1495Reputation: 1495Reputation: 1495Reputation: 1495Reputation: 1495
Quote:
Originally Posted by michaelk View Post
Although the OP posted sftp I think it was in error and actually used ftp. I can use sftp:// in the Windows file browser but it is associated with WinSCP because that is what that particular has installed otherwise an error message should be displayed. pub is the ftp default anonymous directory.
Another point: The OP says they configured an "sftp user" with /sbin/nologin shell. With that shell, the user can't login at all, in my experience. That shell works to allow ftp access only to a user, but sftp won't work.

Still, until the OP decides to tell us what he's actually doing and how he's configured his ftpd server, I'm reluctant to try to help futher.
 
1 members found this post helpful.
Old 06-06-2019, 11:28 AM   #40
tyler2016
Member
 
Registered: Sep 2018
Distribution: Debian, CentOS, FreeBSD
Posts: 250

Rep: Reputation: Disabled
Quote:
Originally Posted by scasey View Post
Another point: The OP says they configured an "sftp user" with /sbin/nologin shell. With that shell, the user can't login at all, in my experience. That shell works to allow ftp access only to a user, but sftp won't work.

Still, until the OP decides to tell us what he's actually doing and how he's configured his ftpd server, I'm reluctant to try to help futher.
I use /sbin/nologin with OpenSSH's sftp server. It works fine.
 
Old 06-06-2019, 11:36 AM   #41
scasey
Senior Member
 
Registered: Feb 2013
Location: Tucson, AZ, USA
Distribution: CentOS 7.7.1908
Posts: 4,274

Rep: Reputation: 1495Reputation: 1495Reputation: 1495Reputation: 1495Reputation: 1495Reputation: 1495Reputation: 1495Reputation: 1495Reputation: 1495Reputation: 1495
Quote:
Originally Posted by tyler2016 View Post
I use /sbin/nologin with OpenSSH's sftp server. It works fine.
Interesting. Doesn't work for me...
OH!, I've set some AllowUsers in sshd.config The user I tested with wasn't one of those. Doh!
 
Old 06-07-2019, 03:53 AM   #42
Huamin
Member
 
Registered: May 2011
Posts: 562

Original Poster
Rep: Reputation: 12
Yes, below line is un-remarked, within file /etc/vsftpd/vsftpd.conf.

anon_upload_enable=YES

and I re-start this
service vsftpd start

I can access

sftp://113.255.219.215/

How to create user account to be able to write SFTP folder?

Last edited by Huamin; 06-11-2019 at 03:13 AM.
 
Old 06-07-2019, 04:27 AM   #43
tshikose
Member
 
Registered: Apr 2010
Location: Kinshasa, Democratic Republic of Congo
Distribution: RHEL, Fedora, CentOS
Posts: 478

Rep: Reputation: 91
Hi Huamin,

You have been told several times that SFTP (really SSH) and FTP are not related, at all.
There is not configuration you can do on vsftpd that will affect sshd.

Make a clear choice: SFTP or FTP?
Then let's us know what error you get (if any).
Also, share details regarding the client you are using to access the server.
 
Old 06-07-2019, 08:07 AM   #44
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 22,243

Rep: Reputation: 5975Reputation: 5975Reputation: 5975Reputation: 5975Reputation: 5975Reputation: 5975Reputation: 5975Reputation: 5975Reputation: 5975Reputation: 5975Reputation: 5975
Quote:
Originally Posted by tshikose View Post
Hi Huamin,

You have been told several times that SFTP (really SSH) and FTP are not related, at all.
There is not configuration you can do on vsftpd that will affect sshd.

Make a clear choice: SFTP or FTP?
Then let's us know what error you get (if any).
Also, share details regarding the client you are using to access the server.
Good luck; third page of posts now, along with repeatedly asking. Please see the OP's posting history, as this is a common theme.

Huamin, unless you're going to actually post a clear question with the relevant details, why bother posting? No one is going to be able to help you without details and a clear question/goal. You were told, point blank, to not use FTP because of security concerns, and you were even handed ways of getting SFTP to allow 'anonymous' connections, but you don't even acknowledge them. You were asked questions which you don't answer. So what's the point?
 
Old 06-07-2019, 08:11 AM   #45
Huamin
Member
 
Registered: May 2011
Posts: 562

Original Poster
Rep: Reputation: 12
Tshikose,
I need SFTP.

I only use Windows file explorer to access the following.

sftp://113.255.219.215/

Last edited by Huamin; 06-11-2019 at 03:12 AM.
 
  


Closed Thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
FTP error -ftp://192.168.122.176/repodata/repomd.xml: [Errrno 14] FTP error 550 - petespa CentOS 3 11-28-2015 06:07 PM
when I use ftp://user@ftp.blah.com it works. But when I type just ftp.blah.com says.. hunterhunter Linux - General 15 03-05-2014 10:12 AM
[SOLVED] FTP Server behind NAT (IPtables) List FTP directories Problem turki_00 Linux - Newbie 5 02-05-2012 09:44 AM
ftp from LInux to Serv-U ftp server problem csross Linux - General 2 11-07-2005 05:35 PM
problem with ftp on mandrake 10.1 Official, ftp speeds system wide (anybody noticed?) equinox Mandriva 15 11-10-2004 03:07 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration