LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-08-2004, 01:28 AM   #1
Cszikszoy
LQ Newbie
 
Registered: Jun 2004
Location: California
Distribution: SuSE 9.1
Posts: 3

Rep: Reputation: 0
problem running the make command


When I run the make command, it outputs a lot of stuff, then at the end, it stop with these errors:
Code:
g++: /usr/lib/libxml2.so: No such file or directory
make[3]: *** [libdc.la] Error 1
make[3]: Leaving directory `/home/chris/dcgui/dclib-0.3.2/dclib'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/chris/dcgui/dclib-0.3.2/dclib'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/chris/dcgui/dclib-0.3.2'
make: *** [all] Error 2
However, libxml2.so exists, and is in /usr/lib/.

I'm very much a newbie, and would appreciate any help. Thanks.
 
Old 06-08-2004, 09:49 AM   #2
jcspray
Member
 
Registered: Mar 2004
Location: York, UK
Distribution: Ubuntu
Posts: 132

Rep: Reputation: 15
What's the output of "ls -l /usr/lib/libxml2.so" ?
 
Old 06-08-2004, 10:27 AM   #3
csfalcon
Member
 
Registered: Jun 2004
Location: MD
Distribution: Fedora Core
Posts: 269

Rep: Reputation: 31
try setting /usr/lib/ in the library search path before you compile.


Code:
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/lib/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
MAKE command problem Spurred_On Linux - Newbie 2 05-12-2005 07:50 PM
Problem running make menuconfig cb9fl Slackware 8 12-07-2004 02:49 AM
problem in running ssh command skvasistha Linux - General 1 11-29-2004 07:12 AM
Problem running make xconfig The GingerNinja Linux - Newbie 2 08-23-2004 09:45 AM
Problem when running make? eXor Linux - Software 5 08-13-2003 12:15 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration