LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-01-2009, 02:32 PM   #1
masmddr
Member
 
Registered: Jun 2005
Location: Israel
Distribution: Arch Linux
Posts: 92

Rep: Reputation: 16
Problem running SRWare Iron, Slackware 12.2.


Hello.
I got me SRWare Iron from their site and I am having some trouble running it.

I got an error about libgconf-2.so.4 being missing so I got the SlackBuilds for ORBit2 and GConf, now I get :
Quote:
iron: /lib/libc.so.6: version `GLIBC_2.8' not found (required by iron)
iron: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.10' not found (required by iron)
/lib/libc.so.6 and /usr/lib/libstdc++.so.6 exist, any advice?


SlackWare 12.2 KDE 3.5
 
Old 09-01-2009, 03:44 PM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2020 CentOS6.10 CentOS7.7 + 50+ other Linux OS, for test only.
Posts: 17,425

Rep: Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622
Short : cannot be used on Slackware 12.2.

Slackware 13 ( and some other ) has the required glibc
minimum compatibility, 2.7 or 2.8 ... and gcc-4.3.x providing
the libstdc++ object GLIBCXX_3.4.9 ( and GLIBCXX_3.4.10 ).

Anyway, it runs fine on 13, when pointing to /usr/lib/firefox
( for 'libnssutil3.so' ).
.....

Last edited by knudfl; 09-01-2009 at 03:56 PM.
 
Old 09-02-2009, 03:56 AM   #3
masmddr
Member
 
Registered: Jun 2005
Location: Israel
Distribution: Arch Linux
Posts: 92

Original Poster
Rep: Reputation: 16
Thank you for your response.

I updated glibc and gcc and now iron *runs* but it does not work.

I get this when ever I run it:
Quote:
[4091:4091:499418707:ERROR:/google/google/iron/src/net/proxy/proxy_config_service_linux.cc(558)] Not implemented reached in void net::ProxyConfigServiceLinux:elegate::SetupAndFetchInitialConfig(MessageLoop*, MessageLoop*)Bug 17363: obey KDE proxy settings.
/home/Denis/Downloads/iron-linux/iron: symbol lookup error: /home/Denis/Downloads/iron-linux/iron: undefined symbol: FT_Get_Advance
[4091:4091:499748011:ERROR:/google/google/iron/src/chrome/common/temp_scaffolding_stubs.h(75)] Not implemented reached in bool printing::PrintViewManager::OnRenderViewGone(RenderViewHost*)
and every address I give iron I get a "something went wrong" message.
was I too optimistic and iron will not run on slk12.2 no matter what I do?
 
Old 09-04-2009, 03:49 PM   #4
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2020 CentOS6.10 CentOS7.7 + 50+ other Linux OS, for test only.
Posts: 17,425

Rep: Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622Reputation: 3622
Well, it is alpha code, may fail by a minor issue.
http://www.srware.net/forum/viewtopic.php?f=18&t=561
Quote :

" Attention:
This is an alpha release, which means that there are
many things uncomplete or broken. "

Looks like this in Slackware 13 :
Quote:
knudfl@88:~$ cd iron-linux
knudfl@88:~/iron-linux$ export LD_LIBRARY_PATH=/usr/lib/firefox-3.5.2/
knudfl@88:~/iron-linux$ ./iron
[3593:3593:688877525:ERROR:/google/google/iron/src/net/proxy/ \
proxy_config_service_linux.cc(558)] Not implemented reached in void net::ProxyConfigServiceLinux:: Delegate::SetupAndFetchInitialConfig \
(MessageLoop*, MessageLoop*)Bug 17363: obey KDE proxy settings.
And no problem with copy / paste the address for e.g. this thread,
and 'iron' works nice in KDE 4.
.....
EDIT : And this line is written in 'iron' , Slackware 13 , KDE-3.5.10 .
.....
P.S.: Not usable as a browser, no bookmarks, no nothing.
.....

Last edited by knudfl; 09-05-2009 at 03:05 AM.
 
Old 09-05-2009, 03:07 AM   #5
masmddr
Member
 
Registered: Jun 2005
Location: Israel
Distribution: Arch Linux
Posts: 92

Original Poster
Rep: Reputation: 16
Thank you for your help.
I'll just wait for a newer release of Iron.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
highly annoying soldering iron problem, solder not sticking to tip at all browny_amiga General 16 05-10-2009 07:47 PM
Problem running deluge 0.5.8.9 in slackware 12.0 yuchankit Slackware 1 08-21-2008 06:27 PM
Problem running HAL on fresh Slackware 12.1 installation on P1510 olefiver Slackware 3 08-19-2008 04:04 PM
problem running hp 960c printer on slackware 10 drussell Slackware 7 11-10-2004 07:14 PM
Re:Running Maya in Slackware, linking problem... MunCH Slackware 4 02-10-2004 04:41 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 09:02 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration