LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-15-2008, 02:28 PM   #1
CaptainReboot
LQ Newbie
 
Registered: Dec 2007
Location: UK
Distribution: Debian (lenny), arm-linux (on GP2x)
Posts: 15

Rep: Reputation: 0
Problem running apt-get on Debian Etch


Hi All,
I have a problem when running apt-get or aptitude on my Deb 4.0 box. I get the following error:

E: Problem parsing dependency Depends
E: Error occurred while processing aspell-bg (NewVersion1)
E: Problem with MergeList /var/lib/apt/lists/ftp.uk.debian.org_debian_dists_etch_main_binary-i386_Packages
E: The package lists or status file could not be parsed or opened.

I've never seen this before and I wondered if anyone could shed any light on it? I've tried apt-get remove aspell-bg but I just get the same error.

I'd really appreciate some help.

Thanks in advance.
 
Old 03-16-2008, 07:58 AM   #2
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian stable
Posts: 5,908

Rep: Reputation: 354Reputation: 354Reputation: 354Reputation: 354
Have you tried running apt-get update to generate a new package list?
 
Old 03-17-2008, 02:31 AM   #3
CaptainReboot
LQ Newbie
 
Registered: Dec 2007
Location: UK
Distribution: Debian (lenny), arm-linux (on GP2x)
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by bigrigdriver View Post
Have you tried running apt-get update to generate a new package list?
Unfortunately that hasn't helped. It did what it does then gave me the same error at the end.

Code:
Ign cdrom://[Debian GNU/Linux 4.0 r1 _Etch_ - Official i386 NETINST Binary-1 20070820-20:21] etch Release.gpg
Ign cdrom://[Debian GNU/Linux 4.0 r1 _Etch_ - Official i386 NETINST Binary-1 20070820-20:21] etch Release
Ign cdrom://[Debian GNU/Linux 4.0 r1 _Etch_ - Official i386 NETINST Binary-1 20070820-20:21] etch/contrib Packages/DiffIndex
Ign cdrom://[Debian GNU/Linux 4.0 r1 _Etch_ - Official i386 NETINST Binary-1 20070820-20:21] etch/main Packages/DiffIndex
Get: 1 http://ftp.uk.debian.org etch Release.gpg [378B]
Get: 2 http://security.debian.org etch/updates Release.gpg [189B]
Hit http://ftp.uk.debian.org etch Release
Hit http://security.debian.org etch/updates Release
Ign http://ftp.uk.debian.org etch/main Packages/DiffIndex
Ign http://security.debian.org etch/updates/main Packages/DiffIndex
Ign http://ftp.uk.debian.org etch/main Sources/DiffIndex
Ign http://security.debian.org etch/updates/contrib Packages/DiffIndex
Ign http://security.debian.org etch/updates/main Sources/DiffIndex
Ign http://security.debian.org etch/updates/contrib Sources/DiffIndex
Hit http://ftp.uk.debian.org etch/main Packages
Hit http://ftp.uk.debian.org etch/main Sources
Hit http://security.debian.org etch/updates/main Packages
Hit http://security.debian.org etch/updates/contrib Packages
Hit http://security.debian.org etch/updates/main Sources
Hit http://security.debian.org etch/updates/contrib Sources
Fetched 2B in 3s (1B/s)
Reading package lists... Error!
E: Problem parsing dependency Depends
E: Error occurred while processing aspell-bg (NewVersion1)
E: Problem with MergeList /var/lib/apt/lists/ftp.uk.debian.org_debian_dists_etch_main_binary-i386_Packages
E: The package lists or status file could not be parsed or opened.
 
Old 03-17-2008, 02:38 AM   #4
farslayer
LQ Guru
 
Registered: Oct 2005
Location: Northeast Ohio
Distribution: linuxdebian
Posts: 7,247
Blog Entries: 5

Rep: Reputation: 191Reputation: 191
First thing I would do is comment out the CDROM in your sources.list, update and try again..

if that doesn't solve the issue fully, try pointing to a different mirror for your packages.

looks like it's having difficulty grabbing the file list from the mirror you are currently using.
 
Old 03-20-2008, 06:35 AM   #5
CaptainReboot
LQ Newbie
 
Registered: Dec 2007
Location: UK
Distribution: Debian (lenny), arm-linux (on GP2x)
Posts: 15

Original Poster
Rep: Reputation: 0
It's all sorted now. For some reason there was a problem reading the file '/var/lib/apt/lists/ftp.uk.debian.org_debian_dists_etch_main_binary-i386_Packages' although it looks ok to me.

I deleted the file then did 'apt-get update' which re-created it.

All is good now :-)

Thanks.
 
Old 03-20-2008, 06:56 AM   #6
makyo
Member
 
Registered: Aug 2006
Location: Saint Paul, MN, USA
Distribution: {Free,Open}BSD, CentOS, Debian, Fedora, Solaris, SuSE
Posts: 732

Rep: Reputation: 75
Hi.
Quote:
Originally Posted by CaptainReboot View Post
It's all sorted now. For some reason there was a problem reading the file '/var/lib/apt/lists/ftp.uk.debian.org_debian_dists_etch_main_binary-i386_Packages' although it looks ok to me.

I deleted the file then did 'apt-get update' which re-created it.

All is good now :-)

Thanks.
Glad to hear it's working.

Often it is better to rename a file rather than delete it, just in case the program in question doesn't re-create it. I usually use a form like old.1.name, old.2.name, etc ... cheers, makyo
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian etch - Help on apt-get kehkok Linux - Software 7 05-24-2007 11:00 PM
/etc/apt/sources.list on debian etch cccc Debian 3 03-30-2007 12:23 PM
Any apt repositories for Beryl for debian Etch/Sid deepclutch Debian 4 12-15-2006 04:14 PM
Apt trying to kill my Debian Etch!? noxious Debian 2 02-12-2006 10:29 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:20 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration