LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-24-2017, 09:49 AM   #1
Glenn D.
Member
 
Registered: May 2009
Location: ACT - Australia
Distribution: Opensuse x86_64 (Latest)
Posts: 132

Rep: Reputation: 26
problem running and updating gramps using opensuse 64 bit


Hello,
problem running and updating gramps using opensuse 64 bit

cant run old version of gramps, need actual name of 'gnome-instrospection' gnome rpm name to install.
# gramps
Your version of gi (gnome-instrospection) seems to be too old. You need a version which has the function 'require_version' to start Gramps

What is the RPM name of 'gnome-instrospection' in opensuse ?
Thanks
--Glenn

# uname -a
Linux zen 4.9.0-3-vanilla #1 SMP PREEMPT Fri Dec 16 19:51:27 UTC 2016 (6fbc0c0) x86_64 x86_64 x86_64 GNU/Linux


# gramps application shows:
Your version of gi (gnome-introspection) seems to be too old. You need a version which has the function 'require_version' to start Gramps

-installed old gramps attempt but cant run it because of dependancy
# zypper in gramps
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: gramps-4.2.5-122.1.noarch requires python(abi) = 3.3, but this requirement cannot be provided
uninstallable providers: python3-base-3.3.2-5.1.4.i586[repo-oss]
python3-base-3.3.2-5.1.4.x86_64[repo-oss]
Solution 1: do not install gramps-4.2.5-122.1.noarch
Solution 2: do not install gramps-4.2.5-122.1.noarch
Solution 3: break gramps-4.2.5-122.1.noarch by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/3/c] (c): c


# smart install gramps-4.1.2-54.1 -y
Loading cache...
Updating cache... ###################################################################################### [100%]

Computing transaction...

Installing packages (1):
gramps-4.1.2-54.1@noarch

4.2MB of package files are needed. 24.2MB will be used.

Committing transaction...
Preparing... ###################################################################################### [ 0%]
1:Installing gramps ###################################################################################### [100%]
Output from gramps-4.1.2-54.1@noarch:
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Unknown media type in type 'uri/mms'
Unknown media type in type 'uri/mmst'
Unknown media type in type 'uri/mmsu'
Unknown media type in type 'uri/pnm'
Unknown media type in type 'uri/rtspt'
Unknown media type in type 'uri/rtspu'

# cant update gramps either:
# zypper install gramps-4.2.5-122.1.noarch
Loading repository data...
Reading installed packages...
Resolving package dependencies...

Problem: gramps-4.2.5-122.1.noarch requires python(abi) = 3.3, but this requirement cannot be provided
uninstallable providers: python3-base-3.3.2-5.1.4.i586[repo-oss]
python3-base-3.3.2-5.1.4.x86_64[repo-oss]
Solution 1: do not install gramps-4.2.5-122.1.noarch
Solution 2: do not install gramps-4.2.5-122.1.noarch
Solution 3: break gramps-4.2.5-122.1.noarch by ignoring some of its dependencies

Choose from above solutions by number or cancel [1/2/3/c] (c): c


#other checks
# gramps -v
Gramps Settings:
----------------
python : 2.7.13
gramps : 4.1.2-1
gtk++ : not found
pygobject : not found
pango : not found
Not using bsddb3
bsddb : 6.0.0
bsddb.db : 4.8.30
cairo : 1.12.14
pycairo : 1.10.0
osmgpsmap : not found
GExiv2 : not found
ICU : 51.2
PyICU : PYICU_VER
o.s. : linux2
kernel : 4.9.0-3-vanilla

Environment settings:
---------------------
LANG : en_US.UTF-8
LANGUAGE : en
GRAMPSI18N: not set
GRAMPSHOME: not set
GRAMPSDIR : not set
PYTHONPATH:
/usr/lib/python2.7/site-packages/gramps
/usr/bin
/usr/lib/python27.zip
/usr/lib64/python2.7
/usr/lib64/python2.7/plat-linux2
/usr/lib64/python2.7/lib-tk
/usr/lib64/python2.7/lib-old
/usr/lib64/python2.7/lib-dynload
/usr/lib64/python2.7/site-packages
/usr/local/lib64/python2.7/site-packages
/usr/local/lib/python2.7/site-packages
/usr/lib64/python2.7/site-packages/gtk-2.0
/usr/lib/python2.7/site-packages

Non-python dependencies:
------------------------
Graphviz : 2.28
Ghostscr. : 9.07

System PATH env variable:
-------------------------
/sbin
/usr/sbin
/usr/local/sbin
/root/bin
/usr/local/bin
/usr/bin
/bin
/usr/bin/X11
/usr/X11R6/bin
/usr/games
/usr/lib/mit/bin


#gramps rpm versions
# cd /home/rpms-customised/
/home/rpms-customised # ll gramps*noarch*
-rw-r--r-- 1 root users 3711209 Jun 18 23:00 gramps-3.2.5-5.1.noarch.rpm
-rw-r--r-- 1 root users 4287243 Feb 14 2016 gramps-3.4.5-5.1.noarch.rpm
-rw-r--r-- 1 root users 4157916 Jun 20 11:51 gramps-4.0.4-4.1.1.noarch.rpm
-rw-r--r-- 1 root users 4265571 Mar 11 2015 gramps-4.1.2-54.1.noarch.rpm
-rw-r--r-- 1 root users 4355518 Sep 5 2015 gramps-4.2.0-63.1.noarch.rpm
-rw-r--r-- 1 root users 4441017 May 4 23:55 gramps-4.2.5-1.2.noarch.rpm
-rw-r--r-- 1 root users 4535538 Jun 18 18:51 gramps-4.2.5-122.1.noarch.rpm
-rw-r--r-- 1 root users 2834326 Mar 11 2015 gramps-lang-4.1.2-54.1.noarch.rpm
-rw-r--r-- 1 root users 2962302 May 4 23:56 gramps-lang-4.2.5-1.2.noarch.rpm
-rw-r--r-- 1 root users 2955718 Jun 18 18:52 gramps-lang-4.2.5-122.1.noarch.rpm
-rw-r--r-- 1 root users 2956790 Jun 18 18:28 gramps-lang-4.2.5-98.1.noarch.rpm




# zypper in pygobject
Loading repository data...
Reading installed packages...
'pygobject' not found in package names. Trying capabilities.
No provider of 'pygobject' found.
Resolving package dependencies...

Nothing to do.
/home/rpms-customised # zypper in python3-base
Loading repository data...
Reading installed packages...
'python3-base' is already installed.
No update candidate for 'python3-base-3.6.1-1.3.x86_64'. The highest available version is already installed.
Resolving package dependencies...

Nothing to do.
#
https://build.opensuse.org/package/s...python-gobject


# rpm -qa | grep -i "python-gobject" | sort
error: rpmdbNextIterator: skipping h# 1467 region trailer: BAD, tag 0 type 0 offset 0 count 0
python-gobject-3.20.1-5.6.x86_64
python-gobject-Gdk-3.20.1-5.6.x86_64
python-gobject-cairo-3.20.1-5.6.x86_64
python-gobject2-2.28.6-29.6.x86_64


zypper up python-gobject python-gobject-Gdk python-gobject-cairo
Loading repository data...
Reading installed packages...
No update candidate for 'python-gobject-3.20.1-5.6.x86_64'. The highest available version is already installed.
No update candidate for 'python-gobject-Gdk-3.20.1-5.6.x86_64'. The highest available version is already installed.
No update candidate for 'python-gobject-cairo-3.20.1-5.6.x86_64'. The highest available version is already installed.
Resolving package dependencies...

Nothing to do.
#
 
Old 06-25-2017, 09:55 AM   #2
hazel
LQ Guru
 
Registered: Mar 2016
Location: Harrow, UK
Distribution: LFS, AntiX, Slackware
Posts: 5,583
Blog Entries: 16

Rep: Reputation: 3316Reputation: 3316Reputation: 3316Reputation: 3316Reputation: 3316Reputation: 3316Reputation: 3316Reputation: 3316Reputation: 3316Reputation: 3316Reputation: 3316
In most distros, it's called GObject introspection, not gnome introspection.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Gramps 4.0.3-1 on Linux Mint 17.2 view problem captain rob Linux - Software 4 09-05-2015 01:00 AM
[SOLVED] Any problem running the 64-bit mkinitrd to make the init RAM disk for 32-bit Slack? stf92 Slackware 4 03-16-2014 12:44 PM
[SOLVED] Kppp have problem with openSUSE 11.2 64-bit and huawei E220 USB-modem. Arnljot Linux - Networking 4 01-11-2010 04:49 AM
I'm having a problem compiling GRAMPS capam Linux - Software 1 03-15-2005 06:23 PM
Error running Gramps (GTK based) fazaman Linux - Software 1 02-10-2005 04:47 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration