LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Problem playing hi-res movies (https://www.linuxquestions.org/questions/linux-software-2/problem-playing-hi-res-movies-747619/)

KimF 08-14-2009 05:06 PM

Problem playing hi-res movies
 
Hi

I have this weird problem, whenever I try to play a hi-res movie (that is a movie with a resolution at or larger than my screen resolution) I get a black screen with a mouse cursor, then (after a couple of seconds) gnome restarts (asks for login).

I have tested this with VLC, Movie player, Totem and Cheese (cannot initiate a web cam with hi-res capability without restarting gnome), all with the same result. Every one (with the possible exception of Cheese, as both my web cams have too great max resolutions) works great with movies with lower resolution than my screen.

I have tried to reinstall video 4 linux and gstreamer without any success.

Any bright ideas will be appreciated.

Kim.

jschiwal 08-14-2009 05:19 PM

Launch the media player from the console and redirect text output to a file.

e.g.
mplayer <themovie> 1>mplayer.log 2>&1

Also check your $HOME/.xsession-errors file.

Maybe provide details such as your video card. The video driver you use.
Most media players let you change the video output driver. E.G. xv, sdl, vidix, etc. Try a different video output driver.
Try playing in full screen mode, e.g.: mplayer -vo xv -fs <videofile>
To display full screen, scaling needs to be used. Some video ouput drivers support scaling and some don't.

Shadow_7 08-15-2009 12:13 AM

You also try a few zooming options and other things.

mplayer -ao alsa -vo xv -vf scale -zoom HD_movie.mp4

And if your computer isn't fast enough to play the content, (2GHz for 720p24) (3GHz for 1080p30) +++++, you might look into enabling frame dropping and other filterless (filtered by default) options. You might also try -vo x11, if it's a driver problem, that might be the only way to get around it. Although terribly slow, but functional when all else fails a lot of the time. There was some sort of -skipfilterall type thing for vlc and mplayer. (actually syntax probably doesn't match, but those terms in some form / order iirc / man vlc / probably loop something or other too) (-lavdopts skiploopfilter=all for mplayer, takes out extra processing for pretty-ing up the image / improves performance)

HTH

KimF 08-15-2009 12:26 PM

Problem solved
 
Hi again

Thanks jschiwal, setting video output to X11 video solved the problem.

Kim


All times are GMT -5. The time now is 01:45 PM.