Latest LQ Deal: Linux Power User Bundle
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 10-12-2005, 07:11 PM   #1
LQ Newbie
Registered: Oct 2005
Posts: 4

Rep: Reputation: 0
problem logging into cvs server

I have installed cvs on my redhat machine.

When I try to login to the cvs server using the following command

cvs -d server:joe:mypassword@csiredhat:/home/cvs login

I get the following error message
cvs login: authorization failed: server csiredhat rejected access to /home/cvs for user joe.

Why does this happen?

Please note that my login has "csi" as its inital group and "cvs" as the next group.

I desparately need some help. Please advise.


***directory permissions****
drwxrwxrwx 4 cvs cvs 4096 Oct 12 14:44 cvs
drwxrwxr-x 3 root root 4096 Oct 12 14:44 CVSROOT

****groups joe*****
joe: csi cvs

*****groups cvs****
cvs: cvs

*****netstat -an | grep 2401*****
tcp 0 0* LISTEN

****/etc/profile ****

export CVSROOT

**** /etc/xinetd.d/cvspserver ****

service cvspserver
disable = no
socket_type = stream
wait = no
user = cvs
group = cvs
log_type = FILE /var/log/cvspserver
protocol = tcp
env = '$HOME=/home/cvs'
bind =
log_on_failure += USERID
port = 2401
server = /usr/bin/cvs
server_args = -f --allow-root=/home/cvs pserver
Old 10-13-2005, 12:21 AM   #2
LQ Newbie
Registered: Oct 2005
Posts: 4

Original Poster
Rep: Reputation: 0
I solved my issue. It was pretty silly actually.

I did not create the passwd file in the CVSROOT directory, which subsequently led to the authentication failures!

I hope I read the docs more carefully in future. Sorry for the trouble guys.



Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
CVS Server Problem aarajthomas Linux - Software 2 12-07-2005 10:49 PM
Running CVS Server on Fedora Core 4 with pserver as "cvs" user rupak Fedora 2 09-17-2005 02:06 PM
CVS server authentication problem eduac Linux - Software 11 07-14-2005 06:55 AM
Problem with Win XP Clients logging in a Domain with a Samba Server YasoKuhl Linux - Networking 0 05-03-2004 01:06 PM
Problem logging off X server on Redhat 9 unclebill Red Hat 2 03-22-2004 03:25 PM > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:01 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration