LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-17-2006, 05:41 PM   #1
Patz2009
LQ Newbie
 
Registered: Feb 2006
Distribution: Slackware
Posts: 11

Rep: Reputation: 0
Problem launching executalbe files on Slackware


Running Slackware 10.2, KDE 3.5. When I try to launch an executable file, nothing happens. Terminal output:

"/here/is/my/file: Bad interpreter: Permission denied"
(or similar)

Help?
 
Old 03-17-2006, 05:45 PM   #2
tomdkat
Member
 
Registered: May 2003
Location: S.F. Bay Area
Distribution: Ubuntu 9.04 AMD64
Posts: 595

Rep: Reputation: 30
Is this something you built yourself or something you downloaded?

"Bad interpreter", sounds like the shell is trying to run it as a script or something.

Have you confirmed the file permissions are set correctly? Run "ls -l" on the file name and post the output here.

Peace...
 
Old 03-17-2006, 11:04 PM   #3
Matir
LQ Guru
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Debian, Arch
Posts: 8,507

Rep: Reputation: 128Reputation: 128
If it is a script, make sure you have the proper path to the interpreter specified in the shebang line, which must be the first line of the file:
Code:
#!/path/to/interpreter
 
Old 03-23-2006, 08:50 AM   #4
Patz2009
LQ Newbie
 
Registered: Feb 2006
Distribution: Slackware
Posts: 11

Original Poster
Rep: Reputation: 0
I get this error when I try to run a number of scripts or executables. Battle For Wesnoth, some MythTV install scripts... The list goes on. However, I will take your suggestions and see what works.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
XMule problem during launching ALInux Linux - Software 4 09-03-2005 01:10 PM
Problems with launching programs in Fresh Slackware 10.0 Install Cecil Linux - Software 5 11-22-2004 10:24 PM
Problem with playing wmv files on Slackware 10 using xine laiboonh Slackware 1 11-03-2004 12:01 AM
mozilla launching problem stompinround Linux - Software 6 09-12-2003 04:53 PM
Launching Files hank@$3800 Linux - General 5 06-20-2002 04:00 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 03:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration