LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-04-2021, 02:12 PM   #1
Andrew Stallard
Member
 
Registered: Nov 2012
Posts: 39

Rep: Reputation: Disabled
Question Problem installing vlc in Centos 8


I tried to install vlc in my Centos 8 machine with the following specs:

Code:
Static hostname: localhost.localdomain
         Icon name: computer-laptop
           Chassis: laptop
        Machine ID: 353aac806aed4c31a0ef5d5a91fe6425
           Boot ID: 82c44bd2ed95466dbf0f1af5ed00551d
  Operating System: CentOS Linux 8
       CPE OS Name: cpe:/o:centos:centos:8
            Kernel: Linux 4.18.0-240.22.1.el8_3.x86_64
      Architecture: x86-64
When I execute the command:

Code:
sudo yum install vlc
I get this error:

Code:
Last metadata expiration check: 1:09:41 ago on Tue 04 May 2021 11:55:46 AM EDT.
Error: 
 Problem: conflicting requests
  - nothing provides libfluidsynth.so.1()(64bit) needed by vlc-1:3.0.12-1.el8.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
Now, I used the --skip-broken option and I was able to install the command like only version but not the graphics version. (I can't get the command line version to work with my browser.)

Yes, I tried dnf too. Same thing happens.

Yes, my rpmfusion and epel repos are installed.

Has anyone else had to deal with this?

In addition can anybody recommend a good video player besides vlc?

Thank you for any help.
 
Old 05-04-2021, 02:29 PM   #2
jefro
Moderator
 
Registered: Mar 2008
Posts: 21,641

Rep: Reputation: 3551Reputation: 3551Reputation: 3551Reputation: 3551Reputation: 3551Reputation: 3551Reputation: 3551Reputation: 3551Reputation: 3551Reputation: 3551Reputation: 3551
Centos was never designed to be a multimedia distro.

VLC is the best but there are many out there. The media you want to run may decide the answer.

https://pkgs.org/download/libfluidsynth.so.1()(64bit)

https://www.videolan.org/vlc/download-redhat.html

Shouldn't you be installing vlc 3.x?
 
Old 05-04-2021, 02:38 PM   #3
shruggy
Senior Member
 
Registered: Mar 2020
Posts: 3,578

Rep: Reputation: Disabled
Try the VLC package from Raven Testing instead. It depends on libfluidsynth.so.2()(64bit) which is currently provided by EPEL. The EPEL FluidSynth package was updated recently, but the RPM Fusion VLC package isn't yet rebuilt against the new FluidSynth. See bz#5983.

Your other (and IMO better) options are
1) to rebuild the RPM Fusion VLC SRPM package against FluidSynth 2.1.8 yourself, or
2) to wait until RPM Fusion devs do this.

Last edited by shruggy; 05-05-2021 at 02:44 AM.
 
Old 05-16-2021, 09:25 PM   #4
centguy
Member
 
Registered: Feb 2008
Posts: 589
Blog Entries: 1

Rep: Reputation: 45
CentOS 8 has a EOL in 2021 so the support is not optimal for vlc? I am using vlc fine on CentOS 7 but no intention of switching to CentOS 8. (To be exact, I installed CentOS 8 and very soon mkfs.ext4 that partition).

Last edited by centguy; 05-16-2021 at 09:28 PM.
 
Old 05-17-2021, 12:46 AM   #5
ondoho
LQ Addict
 
Registered: Dec 2013
Posts: 19,872
Blog Entries: 12

Rep: Reputation: 6038Reputation: 6038Reputation: 6038Reputation: 6038Reputation: 6038Reputation: 6038Reputation: 6038Reputation: 6038Reputation: 6038Reputation: 6038Reputation: 6038
Quote:
Originally Posted by Andrew Stallard View Post
(I can't get the command line version to work with my browser.)
I wonder what that means. I know VLC has a command line version ('cvlc' iirc) but how is it supposed to work with a browser?

Quote:
Originally Posted by jefro View Post
VLC is the best
No, mpv is the best.
 
  


Reply

Tags
vlc


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Vlc issues after installing vlc-2.2.4-x86_64-1alien jowski Slackware 3 11-03-2016 04:16 AM
hi i hve a problem installing vlc on my new centos 5.6 omugerman Linux - Server 1 05-18-2012 05:28 AM
Installing VLC using vlc-0.9.9a-4.el5.rf.i386.rpm--Error relating to Dependencies redhat5 Linux - Newbie 1 12-17-2009 04:23 PM
VLC error: VLC could not open the file "/usr/share/vlc/skins2/text.bmp". brjoon1021 Ubuntu 1 01-14-2009 10:48 PM
I'm Getting 6 VLC Windows At Once - Problem With VLC Player davidx Linux - Software 1 11-03-2008 11:45 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 01:49 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration