LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-27-2004, 10:24 AM   #1
bigjohn
Senior Member
 
Registered: Jun 2002
Location: UK .
Distribution: *buntu (usually Kubuntu)
Posts: 2,692
Blog Entries: 9

Rep: Reputation: 45
Problem installing realplayer


I've had a look at other threads about this, but none of them make sense.

So having downloaded the ".bin" file for realplayer, in the "instructions" it says this

Quote:
Installation Instructions

- Ensure that the .bin file you downloaded is executable. You can make the .bin file executable by running the "chmod a+x RealPlayer10GOLD.bin" command from a terminal window.

- Run the .bin file by typing "./RealPlayer10GOLD.bin". Follow the prompts provided to finish installing the player.

- When you launch the player for the first time, a set-up assistant will take you through configuring your player.

- Enjoy your RealPlayer10 for Linux!
If I try the
Code:
chmod a+x RealPlayer10GOLD.bin
it just returns me to the # prompt - great, no news is good news.

But when I try to run the script, I get this

Code:
bash-2.05b# ./RealPlayer10GOLD.bin
bash: ./RealPlayer10GOLD.bin: Permission denied
bash-2.05b#
Oh and I'm using gentoo.

Any ideas please ??

regards

John

Last edited by bigjohn; 11-27-2004 at 03:05 PM.
 
Old 11-27-2004, 10:35 AM   #2
fail66
Member
 
Registered: Nov 2001
Distribution: Debian
Posts: 35

Rep: Reputation: 15
try this, without the quotes, "./realplay.bin"

nevermind, I didn't read the post fully. I don't have reaplay gold, just the free version. All I did was chmod the bin file and type the command above and it worked fine.

Last edited by fail66; 11-27-2004 at 10:37 AM.
 
Old 11-27-2004, 10:58 AM   #3
jonr
Senior Member
 
Registered: Jan 2003
Location: Kansas City, Missouri, USA
Distribution: Ubuntu
Posts: 1,040

Rep: Reputation: 47
Quote:
Originally posted by fail66
try this, without the quotes, "./realplay.bin"

nevermind, I didn't read the post fully. I don't have reaplay gold, just the free version. All I did was chmod the bin file and type the command above and it worked fine.
The free version is now called RealPlayer Gold (the latest version as far as I know is version 10).

It does sound like a chown and chmod is called for:

As root, do, in the directory where realplay.bin is located:

chown -R [your_user-name] .

chmod -R u+rxw .

The "period" (dot) is to be actually typed. It means "the present directory."

This should make you, as normal (non-root) user the owner of the files in that directory and
any subdirectories (there may not be any, but anyway...), and enable you also as normal user
to read, write, and search/execute files there.

Then try, as normal user, ./realplay.bin while you're still in that directory.

I couldn't get RealPlayer to work this time round. It's always been easy before. But maybe
this will work for you.
 
Old 11-27-2004, 03:21 PM   #4
bigjohn
Senior Member
 
Registered: Jun 2002
Location: UK .
Distribution: *buntu (usually Kubuntu)
Posts: 2,692

Original Poster
Blog Entries: 9

Rep: Reputation: 45
Code:
bash-2.05b$ su
Password:
bash-2.05b# cd /home/john
bash-2.05b# chown -R john .
bash-2.05b# chmod -R u+rxw .
bash-2.05b# su john
bash-2.05b$ ./RealPlayer10GOLD.bin
bash: ./RealPlayer10GOLD.bin: Permission denied
bash-2.05b$ su
Password:
bash-2.05b# cd /home/john
bash-2.05b# chmod a+x /RealPlayer10GOLD.bin
chmod: cannot access `/RealPlayer10GOLD.bin': No such file or directory
bash-2.05b# chmod a+x RealPlayer10GOLD.bin
bash-2.05b# ./Realplayer10GOLD.bin
bash: ./Realplayer10GOLD.bin: No such file or directory
bash-2.05b# sh RealPlayer10GOLD.bin
RealPlayer10GOLD.bin: RealPlayer10GOLD.bin: cannot execute binary file
bash-2.05b# /.RealPlayer10GOLD.bin
bash: /.RealPlayer10GOLD.bin: No such file or directory
bash-2.05b# ./RealPlayer10GOLD.bin
bash: ./RealPlayer10GOLD.bin: Permission denied
bash-2.05b#
As you can see, I've been trying just about every variation, I still get the "Permission denied".

I know that some of the stuff that I tried wouldn't have a hope in hell, but I'm grasping at straws, as I just can't see why it won't run the .bin file even though when I run the cursor over it, it tells me that it's executable!

Are there any other idea's or suggestions please ??

regards

John
 
Old 11-27-2004, 03:35 PM   #5
jonr
Senior Member
 
Registered: Jan 2003
Location: Kansas City, Missouri, USA
Distribution: Ubuntu
Posts: 1,040

Rep: Reputation: 47
It looks to me as though you're not in the right directory.

That would account for all the error messages, I believe...

If you know where the RealPlayer files got placed, do a cd to that directory; if not, you
can do, as root,

updatedb

and after a while you'll have a newly-updated database for the locate command. Then
either as root or normal user, you can

locate -i realplayer | less

which will enable you to find the file.

(The use of less allows you to page up and down easily. To quit the process, press "q".)

Then try again in the directory that has the file.
 
Old 12-29-2004, 09:04 AM   #6
gelmce
LQ Newbie
 
Registered: Dec 2004
Distribution: Slackware
Posts: 1

Rep: Reputation: 0
RealPlayer10GOLD.bin: Permission denied

I downloaded RealPlayer10GOLD.bin
As user 'root':
changed to the directory where I downloaded it.
chmod +x R*
./RealPlayer10GOLD.bin
returns:
./RealPlayer10GOLD.bin: Permission denied

I then downloaded RealPlayer10GOLD.rpm
and, although I am using Slackware, I have the 'rpm' package installed.

rpm -i RealPlayer10GOLD.rpm
error: failed dependencies:
gtk2 is needed by RealPlayer-10.0.2.608-20041214
/bin/sh is needed by RealPlayer-10.0.2.608-20041214
/bin/sh is needed by RealPlayer-10.0.2.608-20041214
/bin/sh is needed by RealPlayer-10.0.2.608-20041214

So, I may not have 'gtk2'
( ! and RealPlayer10GOLD.bin is not showing me the error ! )

I do have a symbolic link /bin/sh -> /bin/bash,
so why do the last three errors exist?

Regards, Chuck
 
Old 12-30-2004, 06:34 AM   #7
kolumbo
LQ Newbie
 
Registered: Dec 2004
Posts: 2

Rep: Reputation: 0
check out noexec flag!

check out that you don't have 'noexec' option set in /etc/fstab for the partition you are trying to install from.

if you have 'noexec' set, fastest way might be to copy the file to another partition and install it from there.
 
Old 01-09-2005, 10:34 AM   #8
TRIaXOR
LQ Newbie
 
Registered: Jan 2005
Distribution: Mandrake 9.2
Posts: 1

Rep: Reputation: 0
Quote:
Originally posted by jonr
[B]
chown -R [your_user-name] .

chmod -R u+rxw .
you were VERY close, how I got it to work was like this..

Code:
su
password
chown -R <username> RealPlayer10Gold.bin
chmod -R u+rxw  RealPlayer10Gold.bin .
./RealPlayer10Gold.bin
and it installed for me (using mandrake 9.2)

Last edited by TRIaXOR; 01-10-2005 at 07:00 AM.
 
Old 02-10-2005, 06:28 PM   #9
miliraj
LQ Newbie
 
Registered: Feb 2005
Posts: 1

Rep: Reputation: 0
Unhappy realplayer installing problem

hi ,

i have same problem for installing realy player. What should i do. I changed the mode of file but whenever i try to run .bin file . it showing me

Cannot execute binary file.
./RealPlayer10GOLD.bin: Exec format error

what should i do?

Can anyone help me.

I would really appricate it.

Thanks,
raj
 
Old 02-10-2005, 06:55 PM   #10
njbrain
Member
 
Registered: Jan 2004
Location: Rhinelander, WI, U.S.
Distribution: Slackware
Posts: 416

Rep: Reputation: 30
I had to type "chmod a+rwx RealPlayer10Gold.bin", and then it worked for me.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
A problem installing Realplayer tribalmasters Ubuntu 2 08-15-2005 04:17 PM
Installing Realplayer NomadABC Linux - Software 8 01-08-2005 03:37 PM
Installing Realplayer 10 LeeHA Linux - Software 3 08-06-2004 09:39 AM
Installing RealPlayer on RedHat Linux 9.0 mkrishnanand Linux - Software 5 07-22-2004 03:36 PM
Installing Realplayer on Mandrake 10.0 ecology447 Linux - Newbie 4 06-12-2004 01:16 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 09:49 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration