-   Linux - Software (
-   -   Problem Installing NS2 in Ubuntu 7.10 (

smetya 03-04-2008 04:35 AM

Problem Installing NS2 in Ubuntu 7.10
I have recently installed Ubuntu 7.10 in my desktop. I was interested in doing some work in NS2 so i download the file ns-allinone-2.29 as well as the ns-allinone-2.31. But while installing the softawre i am having problems as it displays errors or i can say unable to install. So what should i do so that i can run the software.. I will be highly obilized if you guys can help me...

JoeyAdams 03-05-2008 09:27 PM

Could you please post the tail (i.e. last 10 or so lines) of the error messages you're getting? (hint: you can select from the terminal and middle click in a text box to copy and paste). Anyway, if this helps:

When you build a tarball, you typically run the following commands:


sudo make install

though there are occasionally variations such as alternative build systems.

If you don't type the 'sudo', it will try to install with user permissions (regular users aren't allowed to install; they need superuser permission).

You are likely running into dependency problems (i.e. packages that aren't installed that need to be). This is where you use apt-get to resolve them by installing the necessary -dev packages. For instance, if the ./configure fails because you don't have Tcl/Tk, you can install them by running:


sudo apt-get install tcl8.4-dev tk8.4-dev
If you need to know the name of a package, you can type:


apt-cache search tcl
This will spew a lot of results. To refine a bit, you can pipe it through grep:


apt-cache search tcl | grep dev
If you are new and want to know details about commands, you can access the man pages like this:


man grep

fiqbal 04-12-2008 03:45 PM

Problem installing ns2.33 in Ubuntu 7.10
i have installed Ubuntu 7.10 and wanted to install ns-allinone-2.33. I have downloaded it from and followed the commands:

$ tar -xzvf ns-allinone-2.33.tar.gz
$ cd ns-allinone-2.33
$ sudo apt-get install build-essential autoconf automake libxmu-dev

During executing it asked to insert Ubuntu 7.10 CD, after that the following error lines are printed on terminal. (Note that i have installed it using superuser mode)

Media change: please insert the disc labeled
'Ubuntu 7.10 _Gutsy Gibbon_ - Release i386 (20071016)'
in the drive '/cdrom/' and press enter

Failed to fetch cdrom:[Ubuntu 7.10 _Gutsy Gibbon_ - Release i386 (20071016)]/pool/main/g/gcc-4.1/libstdc++6-4.1-dev_4.1.2-16ubuntu2_i386.deb Hash Sum mismatch
Failed to fetch cdrom:[Ubuntu 7.10 _Gutsy Gibbon_ - Release i386 (20071016)]/pool/main/g/gcc-4.1/g++-4.1_4.1.2-16ubuntu2_i386.deb Hash Sum mismatch
Failed to fetch cdrom:[Ubuntu 7.10 _Gutsy Gibbon_ - Release i386 (20071016)]/pool/main/p/patch/patch_2.5.9-4_i386.deb Hash Sum mismatch
Failed to fetch cdrom:[Ubuntu 7.10 _Gutsy Gibbon_ - Release i386 (20071016)]/pool/main/d/dpkg/dpkg-dev_1.14.5ubuntu16_all.deb Hash Sum mismatch
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

Looking forward to have a solution


lukost 04-20-2008 05:46 AM

I have recently created a step-by-step guide on installing ns-2 natively on Ubuntu box:


linderque 04-24-2008 01:28 AM

I tried to install ns-2.31 in ubuntu 7.10
everything seems to fine. It says that "Ns-allinone package has been installed successfully"
And i also did as what in the installation step from the ns2 site (setting up the environment variables)
But when i tried to run an example from ns2,(the tcl script)eventhough i am in the correct gave me this error,

>>> maslinda@maslinda:~/ns-allinone-2.31/ns-2.31/tcl/ex$ ns wireless.tcl
>>> wireless.tcl does not exist, try again

Can someone help me to figure out this problem?


lukost 04-27-2008 08:27 AM

You are running the wrong software ;-)
ns you run by typing 'ns' in command line seems to be part of 'host' package. This is not Network Simulator (check man ns).

Run the script using "../../ns wireless.tcl" or change PATH to point to you 'network simulation' /bin first and then the rest.

If you upgrade to ubuntu 8.04 "host" package is replaced by "bind9-host" where there is no 'ns' binary.
Also you could remove the 'host' package - you can use nslookup or dig for similar purpose (sudo apt-get remove host).

Perhaps host-bind9 is available on ubuntu 7.04 - try:
sudo apt-get install bind9-host


All times are GMT -5. The time now is 05:14 AM.