LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Problem installing lighttpd (https://www.linuxquestions.org/questions/linux-software-2/problem-installing-lighttpd-507960/)

bambam43410 12-06-2006 02:25 PM

Problem installing lighttpd
 
I'm trying to install lighttpd on my NSLU2. It had been installed, but i removed it to try a different server package and it didnt work out for me. So i tried installing it again, but apt gives me this error.

Code:

NSLU2:/etc# apt-get install lighttpd
Reading package lists... Done
Building dependency tree... Done
Suggested packages:
  rrdtool apache2-utils
The following NEW packages will be installed:
  lighttpd
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B/287kB of archives.
After unpacking 827kB of additional disk space will be used.
Selecting previously deselected package lighttpd.
(Reading database ... 11885 files and directories currently installed.)
Unpacking lighttpd (from .../lighttpd_1.4.13-4_arm.deb) ...
Setting up lighttpd (1.4.13-4) ...
Starting web server: lighttpd2006-12-06 16:07:31: (configfile.c.869) opening configfile  /etc/lighttpd/lighttpd.conf failed: No such file or directory
 failed!
invoke-rc.d: initscript lighttpd, action "start" failed.
dpkg: error processing lighttpd (--configure):
 subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
 lighttpd
E: Sub-process /usr/bin/dpkg returned an error code (1)

Any ideas about how to fix it?

cybernet2u 08-06-2009 11:37 AM

i don't know if will work
but try this
uninstall the old version with command

apt-get purge lighttpd

then try to install it again

it might work:D

please tell if it worked
i wanna know if i can give this advice to others


All times are GMT -5. The time now is 04:49 AM.