LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-02-2003, 05:49 AM   #1
cheema
Member
 
Registered: Oct 2003
Distribution: Debian Sarge
Posts: 50

Rep: Reputation: 15
problem installing glib


I've Redhat 9.0 installed on my system but I didn't initially install gnome. while installing gaim-0.71 I got the following error message.

checking for GLIB - version >= 2.0.0... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB is incorrectly installed.
configure: error:
*** GLib 2.0 is required to build Gaim; please make sure you have the GLib
*** development headers installed. The latest version of GLib is
*** always available at http()www()gtk()org/.

So I downloaded latest glib from gtk.org and tried installing it. I got no error while installing glib. But the I keep on getting the above error while installing gaim even after that. I also tried to install GTK, ATK and PANGO from gtk.org but they all give the same above error of not finding glib.

I also get the following error while installing gaim from rpm package.
error: Failed dependencies:
gtk+2.0 >= 2.0.0 is needed by gaim-0.71-1mdk9.1
libnss3 is needed by gaim-0.71-1mdk9.1
libaspell.so.15 is needed by gaim-0.71-1mdk9.1
libgtkspell.so.0 is needed by gaim-0.71-1mdk9.1
libpspell.so.15 is needed by gaim-0.71-1mdk9.1
perl-base >= 2:5.8.0 is needed by gaim-0.71-1mdk9.1

Can somebody help? Should I first delete the files relating to glib from my system?
Thnx in advance

 
Old 11-02-2003, 11:04 AM   #2
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 48
You are trying to install a package for mandrake, not redhat (you can tell by the mdk in the name). That's probably one of the problems since it's looking whether you have a certain rpm package installed. Try getting an rpm for redhat.
 
Old 11-03-2003, 03:33 AM   #3
cheema
Member
 
Registered: Oct 2003
Distribution: Debian Sarge
Posts: 50

Original Poster
Rep: Reputation: 15
thnx for reply quatsch

I am wrong at using mkd package, but even when I use the tar balls i get the same problem. After ./configure i get this message
checking for GLIB - version >= 2.0.0... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB is incorrectly installed.
configure: error:
*** GLib 2.0 is required to build Gaim; please make sure you have the GLib
*** development headers installed. The latest version of GLib is
*** always available at http()www()gtk()org/.

Even while installing gtk,atk and pango I get a similar message.
Plz suggest
 
Old 11-03-2003, 09:50 AM   #4
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 48
well, you do need to install glib. There should be rpm packages for redhat that provide glib. Probably on your installation CDs.
 
Old 11-03-2003, 10:00 AM   #5
davholla
Member
 
Registered: Jun 2003
Location: London
Distribution: Linux Mint 13 Maya
Posts: 729

Rep: Reputation: 32
You need to change your path so that it looks at the new version glib.
I think and I am not an expert you need to go to /etc/ld.so.conf and add where you put glib. I did have the same problem but a long time ago so I can not remember exactly what I did.
I will think about this and get back to you.
 
Old 11-04-2003, 03:31 PM   #6
cheema
Member
 
Registered: Oct 2003
Distribution: Debian Sarge
Posts: 50

Original Poster
Rep: Reputation: 15
I did install glib from my redhat CDs. In fact I reinstallled whole of GNOME since glib came in the GNOME package. But problem refuses to go away.
 
Old 11-04-2003, 10:12 PM   #7
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 48
is there also a glib-devel package? If so, you'll need to install that as well.

also, have you tried looking for a gaim rpm for redhat? If there is one, it'll be a whole lot easier than trying to compile it yourself.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problem installing glib linuxmandrake Debian 0 09-21-2005 10:45 AM
Problem installing glib/pango/gtk+ WRSpithead Linux - Software 10 03-26-2005 12:57 PM
[GLIB] Problems Installing GLIB ThA_eLMo_GoD Linux - Newbie 2 09-04-2004 05:27 PM
problem installing GLIB>ATK>Overnet salokas Linux - Software 5 06-16-2004 02:57 AM
Installing XMMS, Problem with glib Inexactitude Linux - Software 3 10-18-2003 04:01 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:20 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration