LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Problem installing Bumblebee-3.0 on Mageia 2 (https://www.linuxquestions.org/questions/linux-software-2/problem-installing-bumblebee-3-0-on-mageia-2-a-4175414945/)

lghizoni 07-04-2012 09:40 PM

Problem installing Bumblebee-3.0 on Mageia 2
 
Hello,

I'm trying to install Bumblebee from source on Mageia 2. I've already installed all the dependencies, untar the source tarball from: https://github.com/Bumblebee-Project...ebee/downloads

I ran './configure' and all went fine. But when I run 'make' I get the errors:


/home/lghizoni/Downloads/bumblebee-3.0/src/bumblebeed.c:468: undefined reference to `pidfile_write'
/home/lghizoni/Downloads/bumblebee-3.0/src/bumblebeed.c:486: undefined reference to `pidfile_remove'
/home/lghizoni/Downloads/bumblebee-3.0/src/bumblebeed.c:427: undefined reference to `pidfile_open'
/home/lghizoni/Downloads/bumblebee-3.0/src/bumblebeed.c:460: undefined reference to `pidfile_remove'
collect2: ld returned 1 exit status
make: *** [bin/bumblebeed] Error 1

I don't know how to correct this...

Can anyone help me?

Thanks a lot!

paziulek 07-05-2012 03:14 PM

pidfile_write and the rest of the listed functions are part of libbsd.
the configure script looks for libbsd >= 0.2.0 ( minimal version )
you probably have libbsd 0.3.0 which is still causing this problems on some systems .
I would suggest you to

1> get rid of current version of libbsd you got ( probably 0.3.0 - make sure you can get it reinstalled if needed )
2> download/compile and install ( sudo of course ) the 0.2.0 version of libbsd from here:
http://repository.timesys.com/builds.../libbsd-0.2.0/

make sure you do:
sudo make install
and than
sudo ldconfig

than make clean on bumblebee src tree, and try again,

good luck

ps: if you cannot uninstall libbsd in step 1
locate these files in /usr/lib || /usr/lib64 and rename them: ( some of them are symbolic links )

libbsd.a
libbsd.so
libbsd.so.0
libbsd.so.0.3.0

if you have other than 0.3.0 version just look for libbsd* in the /usr/lib

lghizoni 07-05-2012 03:50 PM

Thank you for your attention!

I installed it, but now when I run './configure' in bumblebee/ I get:

checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking how to create a pax tar archive... gnutar
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
checking whether gcc and cc understand -c and -o together... yes
checking for help2man... /usr/bin/help2man
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for x11... yes
checking for glib... yes
checking for libbsd... no
configure: error: Package requirements (libbsd >= 0.2.0) were not met:

No package 'libbsd' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables libbsd_CFLAGS
and libbsd_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

It's like libbsd isn't installed! So I ran 'export PKG_CONFIG_PATH=/usr/lib/pkgconfig:/usr/local/lib/pkgconfig', and then worked.

So I ran 'make' and 'make install', which worked fine too. The next step was to add myself to bumblebee, like:

# groupadd bumblebee
# usermod -a -G bumblebee $USER

which was ok. Then I re-login and ran '# bumblebeed --daemon', but now I get the message: 'FATAL: Module bbswitch not found.'

But I did install bbswitch! I don't know what's wrong...

Thanks.

paziulek 07-05-2012 05:01 PM

did you insmod / modprobe the bbswitch kernel module?

lghizoni 07-05-2012 05:03 PM

Could you explain it easier? I didn't understand...sorry

paziulek 07-05-2012 07:28 PM

https://github.com/Bumblebee-Project/bbswitch/

lghizoni 07-06-2012 04:08 PM

Hello paziulek!!

It works now!! Thank you very much for your attention.

Best regards.


All times are GMT -5. The time now is 12:31 AM.