LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-30-2013, 01:37 PM   #1
dnskdas
Member
 
Registered: Nov 2008
Posts: 56

Rep: Reputation: 15
problem in updating fedora 18 by yum


Recently I have upgraded my linux version from 17 to 18. Then when I tried to update it first time by
Code:
sudo yum update
, then after downloading the packages to be updated/installed, finally I got the following error message:
Quote:
Transaction Summary
==================================================================================================== =================================================
Install 19 Packages (+109 Dependent packages)
Upgrade 1389 Packages
Remove 4 Packages

Total size: 2.0 G
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Check
ERROR with transaction check vs depsolve:
httpd-mmn = 20051115-x86-32 is needed by (installed) mod_python-3.3.1-18.fc17.i686
Please report this error in https://bugzilla.redhat.com/enter_bu...&component=yum
** Found 119 pre-existing rpmdb problem(s), 'yum check' output follows:
GConf2-devel-3.2.5-3.fc17.i686 has missing requires of GConf2 = ('0', '3.2.5', '3.fc17')
apr-util-ldap-1.4.1-2.fc17.i686 has missing requires of apr-util = ('0', '1.4.1', '2.fc17')
bpg-algeti-fonts-2.005-9.fc17.noarch has missing requires of bpg-fonts-common = ('0', '20090205', '9.fc17')
bpg-chveulebrivi-fonts-3.002-9.fc17.noarch has missing requires of bpg-fonts-common = ('0', '20090205', '9.fc17')
bpg-courier-fonts-4.002-9.fc17.noarch has missing requires of bpg-fonts-common = ('0', '20090205', '9.fc17')
bpg-courier-s-fonts-4.000-9.fc17.noarch has missing requires of bpg-fonts-common = ('0', '20090205', '9.fc17')
bpg-elite-fonts-3.000-9.fc17.noarch has missing requires of bpg-fonts-common = ('0', '20090205', '9.fc17')
bpg-excelsior-fonts-2.025-9.fc17.noarch has missing requires of bpg-fonts-common = ('0', '20090205', '9.fc17')
bpg-glaho-fonts-9.000-9.fc17.noarch has missing requires of bpg-fonts-common = ('0', '20090205', '9.fc17')
bpg-ingiri-fonts-4.000-9.fc17.noarch has missing requires of bpg-fonts-common = ('0', '20090205', '9.fc17')
bpg-nino-medium-cond-fonts-4.005-9.fc17.noarch has missing requires of bpg-fonts-common = ('0', '20090205', '9.fc17')
bpg-nino-medium-fonts-4.005-9.fc17.noarch has missing requires of bpg-fonts-common = ('0', '20090205', '9.fc17')
bpg-sans-fonts-1.005-9.fc17.noarch has missing requires of bpg-fonts-common = ('0', '20090205', '9.fc17')
bpg-sans-medium-fonts-1.005-9.fc17.noarch has missing requires of bpg-fonts-common = ('0', '20090205', '9.fc17')
bpg-sans-modern-fonts-2.025-9.fc17.noarch has missing requires of bpg-fonts-common = ('0', '20090205', '9.fc17')
bpg-sans-regular-fonts-1.005-9.fc17.noarch has missing requires of bpg-fonts-common = ('0', '20090205', '9.fc17')
bpg-serif-fonts-1.005-9.fc17.noarch has missing requires of bpg-fonts-common = ('0', '20090205', '9.fc17')
bpg-serif-modern-fonts-2.028-9.fc17.noarch has missing requires of bpg-fonts-common = ('0', '20090205', '9.fc17')
culmus-caladings-clm-fonts-0.121-1.fc17.noarch has missing requires of culmus-fonts-common = ('0', '0.121', '1.fc17')
1:emacs-24.1-7.fc17.i686 has missing requires of libtiff.so.3
ffmpeg-libs-0.10.6-1.fc17.i686 has missing requires of libopenjpeg.so.3
fftw-libs-3.3.3-1.fc17.i686 has missing requires of fftw-libs-single(x86-32) = ('0', '3.3.3', '1.fc17')
fftw-libs-3.3.3-1.fc17.i686 has missing requires of fftw-libs-double(x86-32) = ('0', '3.3.3', '1.fc17')
gamin-devel-0.1.10-12.fc17.i686 has missing requires of gamin = ('0', '0.1.10', '12.fc17')
groff-1.21-9.fc17.i686 has missing requires of groff-base = ('0', '1.21', '9.fc17')
gstreamer-plugins-bad-free-extras-0.10.23-8.fc17.i686 has missing requires of gstreamer-plugins-bad-free = ('0', '0.10.23', '8.fc17')
gstreamer-plugins-bad-free-extras-0.10.23-8.fc17.i686 has missing requires of libopencv_calib3d.so.2.3
gstreamer-plugins-bad-free-extras-0.10.23-8.fc17.i686 has missing requires of libopencv_contrib.so.2.3
gstreamer-plugins-bad-free-extras-0.10.23-8.fc17.i686 has missing requires of libopencv_core.so.2.3
gstreamer-plugins-bad-free-extras-0.10.23-8.fc17.i686 has missing requires of libopencv_features2d.so.2.3
gstreamer-plugins-bad-free-extras-0.10.23-8.fc17.i686 has missing requires of libopencv_flann.so.2.3
gstreamer-plugins-bad-free-extras-0.10.23-8.fc17.i686 has missing requires of libopencv_highgui.so.2.3
gstreamer-plugins-bad-free-extras-0.10.23-8.fc17.i686 has missing requires of libopencv_imgproc.so.2.3
gstreamer-plugins-bad-free-extras-0.10.23-8.fc17.i686 has missing requires of libopencv_legacy.so.2.3
gstreamer-plugins-bad-free-extras-0.10.23-8.fc17.i686 has missing requires of libopencv_ml.so.2.3
gstreamer-plugins-bad-free-extras-0.10.23-8.fc17.i686 has missing requires of libopencv_objdetect.so.2.3
gstreamer-plugins-bad-free-extras-0.10.23-8.fc17.i686 has missing requires of libopencv_video.so.2.3
gvfs-archive-1.12.3-1.fc17.i686 has missing requires of gvfs(x86-32) = ('0', '1.12.3', '1.fc17')
inn-2.5.2-21.fc17.i686 has missing requires of perl(:MODULE_COMPAT_5.14.2)
kdesdk-4.9.3-1.fc17.i686 has missing requires of kdesdk-cervisia = ('0', '4.9.3', '1.fc17')
kdesdk-4.9.3-1.fc17.i686 has missing requires of kdesdk-dolphin-plugins = ('0', '4.9.3', '1.fc17')
kdesdk-4.9.3-1.fc17.i686 has missing requires of kdesdk-kapptemplate = ('0', '4.9.3', '1.fc17')
kdesdk-4.9.3-1.fc17.i686 has missing requires of kdesdk-kcachegrind = ('0', '4.9.3', '1.fc17')
kdesdk-4.9.3-1.fc17.i686 has missing requires of kdesdk-kioslave = ('0', '4.9.3', '1.fc17')
kdesdk-4.9.3-1.fc17.i686 has missing requires of kdesdk-kmtrace = ('0', '4.9.3', '1.fc17')
kdesdk-4.9.3-1.fc17.i686 has missing requires of kdesdk-kompare = ('0', '4.9.3', '1.fc17')
kdesdk-4.9.3-1.fc17.i686 has missing requires of kdesdk-kpartloader = ('0', '4.9.3', '1.fc17')
kdesdk-4.9.3-1.fc17.i686 has missing requires of kdesdk-kstartperf = ('0', '4.9.3', '1.fc17')
kdesdk-4.9.3-1.fc17.i686 has missing requires of kdesdk-kuiviewer = ('0', '4.9.3', '1.fc17')
kdesdk-4.9.3-1.fc17.i686 has missing requires of kdesdk-okteta = ('0', '4.9.3', '1.fc17')
kdesdk-4.9.3-1.fc17.i686 has missing requires of kdesdk-poxml = ('0', '4.9.3', '1.fc17')
kdesdk-4.9.3-1.fc17.i686 has missing requires of kdesdk-scripts = ('0', '4.9.3', '1.fc17')
kdesdk-4.9.3-1.fc17.i686 has missing requires of kdesdk-strigi-analyzer = ('0', '4.9.3', '1.fc17')
kdesdk-4.9.3-1.fc17.i686 has missing requires of kdesdk-thumbnailers = ('0', '4.9.3', '1.fc17')
kdesdk-4.9.3-1.fc17.i686 has missing requires of kdesdk-umbrello = ('0', '4.9.3', '1.fc17')
ktp-text-ui-0.5.1-1.fc17.i686 has missing requires of libtelepathy-logger.so.2
libpciaccess-devel-0.13.1-1.fc17.i686 has missing requires of libpciaccess = ('0', '0.13.1', '1.fc17')
libprojectM-2.0.1-15.fc17.i686 has missing requires of libGLEW.so.1.6
1:libreoffice-ogltrans-3.5.7.2-6.fc17.i686 has missing requires of libreoffice-core = ('1', '3.5.7.2', '6.fc17')
1:libreoffice-ogltrans-3.5.7.2-6.fc17.i686 has missing requires of libreoffice-impress = ('1', '3.5.7.2', '6.fc17')
1:libreoffice-ogltrans-3.5.7.2-6.fc17.i686 has missing requires of libreoffice-ure = ('1', '3.5.7.2', '6.fc17')
libtranslit-icu-0.0.2-1.fc17.i686 has missing requires of libicudata.so.48
libtranslit-icu-0.0.2-1.fc17.i686 has missing requires of libicui18n.so.48
libtranslit-icu-0.0.2-1.fc17.i686 has missing requires of libicuio.so.48
libtranslit-icu-0.0.2-1.fc17.i686 has missing requires of libicuuc.so.48
libtranslit-icu-0.0.2-1.fc17.i686 has missing requires of libtranslit(x86-32) = ('0', '0.0.2', '1.fc17')
minizip-1.2.5-7.fc17.i686 has missing requires of zlib = ('0', '1.2.5', '7.fc17')
mod_python-3.3.1-18.fc17.i686 has missing requires of httpd-mmn = ('0', '20051115', 'x86-32')
netpbm-progs-10.58.03-1.fc17.i686 has missing requires of libtiff.so.3
netpbm-progs-10.58.03-1.fc17.i686 has missing requires of netpbm = ('0', '10.58.03', '1.fc17')
openldap-clients-2.4.33-3.fc17.i686 has missing requires of openldap(x86-32) = ('0', '2.4.33', '3.fc17')
perl-AnyEvent-5.27-7.fc17.noarch has missing requires of perl(:MODULE_COMPAT_5.14.2)
perl-AnyEvent-AIO-1.1-8.fc17.noarch has missing requires of perl(:MODULE_COMPAT_5.14.2)
perl-AnyEvent-BDB-1.1-7.fc17.noarch has missing requires of perl(:MODULE_COMPAT_5.14.2)
perl-Archive-Zip-1.30-7.fc17.noarch has missing requires of perl(:MODULE_COMPAT_5.14.2)
perl-Async-MergePoint-0.03-7.fc17.noarch has missing requires of perl(:MODULE_COMPAT_5.14.2)
perl-BDB-1.88-5.fc17.i686 has missing requires of perl(:MODULE_COMPAT_5.14.2)
perl-Convert-BinHex-1.119-17.fc17.noarch has missing requires of perl(:MODULE_COMPAT_5.14.2)
perl-Coro-6.07-3.fc17.i686 has missing requires of perl(:MODULE_COMPAT_5.14.2)
perl-Curses-1.28-5.fc17.i686 has missing requires of perl(:MODULE_COMPAT_5.14.2)
perl-DateTime-Format-Mail-0.3001-13.fc17.noarch has missing requires of perl(:MODULE_COMPAT_5.14.2)
perl-DateTime-Format-W3CDTF-0.06-2.fc17.noarch has missing requires of perl(:MODULE_COMPAT_5.14.2)
perl-EV-4.03-8.fc17.i686 has missing requires of perl(:MODULE_COMPAT_5.14.2)
perl-Event-1.20-1.fc17.i686 has missing requires of perl(:MODULE_COMPAT_5.14.2)
perl-Event-Lib-1.03-16.fc17.i686 has missing requires of perl(:MODULE_COMPAT_5.14.2)
perl-File-RsyncP-0.70-4.fc17.i686 has missing requires of perl(:MODULE_COMPAT_5.14.2)
perl-Glib-1.241-2.fc17.i686 has missing requires of perl(:MODULE_COMPAT_5.14.2)
perl-Guard-1.022-1.fc17.i686 has missing requires of perl(:MODULE_COMPAT_5.14.2)
perl-Heap-0.80-10.fc17.noarch has missing requires of perl(:MODULE_COMPAT_5.14.2)
perl-IO-AIO-4.15-1.fc17.i686 has missing requires of perl(:MODULE_COMPAT_5.14.2)
perl-IO-Async-0.29-7.fc17.noarch has missing requires of perl(:MODULE_COMPAT_5.14.2)
perl-IO-Tty-1.10-8.fc17.i686 has missing requires of perl(:MODULE_COMPAT_5.14.3)
perl-MIME-tools-5.502-5.fc17.noarch has missing requires of perl(:MODULE_COMPAT_5.14.2)
perl-Math-Round-0.06-12.fc17.noarch has missing requires of perl(:MODULE_COMPAT_5.14.2)
perl-Net-FTP-AutoReconnect-0.3-5.fc17.noarch has missing requires of perl(:MODULE_COMPAT_5.14.2)
perl-Net-FTP-RetrHandle-0.2-5.fc17.noarch has missing requires of perl(:MODULE_COMPAT_5.14.2)
perl-POE-1.350-2.fc17.noarch has missing requires of perl(:MODULE_COMPAT_5.14.2)
perl-Socket-GetAddrInfo-0.19-1.fc17.i686 has missing requires of perl(:MODULE_COMPAT_5.14.2)
perl-TermReadKey-2.30-14.fc17.i686 has missing requires of perl(:MODULE_COMPAT_5.14.2)
perl-Time-modules-2011.0517-3.fc17.noarch has missing requires of perl(:MODULE_COMPAT_5.14.2)
perl-XML-RSS-1.49-1.fc17.noarch has missing requires of perl(:MODULE_COMPAT_5.14.2)
perl-common-sense-3.5-1.fc17.noarch has missing requires of perl(:MODULE_COMPAT_5.14.2)
policycoreutils-sandbox-2.1.12-5.fc17.i686 has missing requires of policycoreutils-python = ('0', '2.1.12', '5.fc17')
sane-backends-drivers-cameras-1.0.23-4.fc17.i686 has missing requires of libgphoto2.so.2
sane-backends-drivers-cameras-1.0.23-4.fc17.i686 has missing requires of libgphoto2_port.so.0
sane-backends-drivers-cameras-1.0.23-4.fc17.i686 has missing requires of sane-backends = ('0', '1.0.23', '4.fc17')
sane-backends-drivers-cameras-1.0.23-4.fc17.i686 has missing requires of sane-backends-libs(x86-32) = ('0', '1.0.23', '4.fc17')
strigi-devel-0.7.7-5.20120626.fc17.i686 has missing requires of strigi-libs(x86-32) = ('0', '0.7.7', '5.20120626.fc17')
subversion-perl-1.7.7-1.fc17.i686 has missing requires of perl(:MODULE_COMPAT_5.14.2)
subversion-perl-1.7.7-1.fc17.i686 has missing requires of subversion(x86-32) = ('0', '1.7.7', '1.fc17')
system-config-firewall-1.2.29-7.fc17.noarch has missing requires of system-config-firewall-base = ('0', '1.2.29', '7.fc17')
system-config-firewall-tui-1.2.29-7.fc17.noarch has missing requires of system-config-firewall-base = ('0', '1.2.29', '7.fc17')
telepathy-logger-qt-0.5.1-1.fc17.i686 has missing requires of libtelepathy-logger.so.2
2:vim-enhanced-7.3.682-1.fc17.i686 has missing requires of perl(:MODULE_COMPAT_5.14.2)
vlc-core-2.0.4-1.fc17.i686 has missing requires of libudev.so.0
xorg-x11-drv-ast-0.93.9-6.fc17.i686 has missing requires of xserver-abi(videodrv-12) >= ('0', '0', None)
xorg-x11-drv-cirrus-1.4.0-1.fc17.i686 has missing requires of xserver-abi(videodrv-12) >= ('0', '0', None)
xorg-x11-drv-dummy-0.3.5-4.fc17.i686 has missing requires of xserver-abi(videodrv-12) >= ('0', '0', None)
xorg-x11-drv-void-1.4.0-8.fc17.i686 has missing requires of xserver-abi(xinput-16) >= ('0', '0', None)
Your transaction was saved, rerun it with:
yum load-transaction /tmp/yum_save_tx.2013-05-30.22-40.QTW78R.yumtx
What could be the reasons. Please help.
- SKD
 
Old 05-31-2013, 06:20 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981Reputation: 1981
well you've got yum wanting to install fc17 RPM's there, so clearly the upgrade has NOT worked at some level. what version of the fedora-release package do you have installed? The version number is taken directly from the /etc/fedora-release / /etc/redhat-release file from that package, so that presumably has not been updated.
 
Old 05-31-2013, 11:42 AM   #3
RockDoctor
Senior Member
 
Registered: Nov 2003
Location: Minnesota, US
Distribution: Fedora, Ubuntu, Manjaro
Posts: 1,752

Rep: Reputation: 409Reputation: 409Reputation: 409Reputation: 409Reputation: 409
To update fedora-release, you can go here, download fedora-release-18-1.noarch.rpm (not sure if you'll need fedora-release-rawhide-18-1.noarch.rpm, but if you do, you'll know where to find it), and install it (or them)
Code:
sudo yum localinstall fedora-release-18-1.noarch.rpm
 
Old 06-04-2013, 11:21 AM   #4
dnskdas
Member
 
Registered: Nov 2008
Posts: 56

Original Poster
Rep: Reputation: 15
I downloaded fedora-release-18-1.noarch.rpm and fedora-release-rawhide-18-1.noarch.rpm and installed as you have suggested. For fedora-release-18-1.noarch.rpm, it gave nothing to do. But the other one was installed. But when I again updated by yum it ended up with same kind of error message. I am using Fedora Release 18(Spherical Cow) and the OS:Linux 3.6.10-4.fc18.i686.PAE i686.
 
Old 06-07-2013, 01:36 PM   #5
RockDoctor
Senior Member
 
Registered: Nov 2003
Location: Minnesota, US
Distribution: Fedora, Ubuntu, Manjaro
Posts: 1,752

Rep: Reputation: 409Reputation: 409Reputation: 409Reputation: 409Reputation: 409
First thought - make sure yum is (and has been) using the F18 rpmfusion repos. If yum has been using the F17 repos, ensure that it's using the F18 repos and retry the upgrade. If that still doesn't work, I'd try upgrading one package (or a few packages) at a time.
 
Old 06-07-2013, 05:40 PM   #6
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,502

Rep: Reputation: 2617Reputation: 2617Reputation: 2617Reputation: 2617Reputation: 2617Reputation: 2617Reputation: 2617Reputation: 2617Reputation: 2617Reputation: 2617Reputation: 2617
fedora 17 still used "preupgrade"
fedora 18 is now using "fedup"

or
use the install dvd of fedora 18 to upgrade the fedora 17 install

or the BEST option
is use the fedora 18 install dvd to do a new clean install of fedora 18
 
Old 06-08-2013, 01:31 PM   #7
sunjayasri
LQ Newbie
 
Registered: Nov 2011
Location: Srilanka
Posts: 23
Blog Entries: 7

Rep: Reputation: Disabled
Thumbs up

https://fedoraproject.org/wiki/Upgra...dora_using_yum
 
Old 06-09-2013, 01:33 PM   #8
dnskdas
Member
 
Registered: Nov 2008
Posts: 56

Original Poster
Rep: Reputation: 15
Yes, yum is using F18 rpmfusion(both free & nonfree) repos in my case.

I have used fedup for upgrading from F17 to F18 using F18 install DVD iso.

I am not very sure whether it is realistically possible to upgrade one package at a time.

Thanks & hoping for more of your inputs.
 
Old 06-09-2013, 07:13 PM   #9
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
john vv posted
Quote:
fedora 17 still used "preupgrade"
Have you tried that since your sources were originally using f17 repos
 
Old 06-10-2013, 09:57 AM   #10
dnskdas
Member
 
Registered: Nov 2008
Posts: 56

Original Poster
Rep: Reputation: 15
No I haven't tried preupgrade.

Now I am having another kind of problem. I was trying to upgrade groups separately. I upgraded gnome*, kde*, kernel*, libreoffice* etc. successfully using yum. But then when restarted the computer next time, fedora is booting upto the initial blue screen and then stops doing anything further without giving me the option of logging in to any of the user account since that option in the screen is not coming. Now I am in a hopeless situation and could not fathom out the problem. Since fortunately my other booting option (Windows 7) is still alive I could work with my laptop. Please suggest how to come out of it or whether I have to fresh install F18.

Last edited by dnskdas; 06-10-2013 at 09:59 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Dependency error updating with YUM on Fedora Core 4 tron_thomas Linux - Software 7 04-18-2006 03:25 AM
Problems updating Fedora Core 4 with Yum Extender tron_thomas Linux - Software 1 11-06-2005 08:22 PM
yum updating problem bonus_uk Linux - Software 3 10-01-2005 11:06 PM
Updating Fedora 3 with yum pongmaster Fedora 3 03-15-2005 01:11 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 09:13 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration