LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-10-2010, 01:34 PM   #1
kanodiapawan
LQ Newbie
 
Registered: Jan 2010
Posts: 12

Rep: Reputation: 0
Angry problem in installing mplayer


rhel5 user
getting following errors.....

Transaction Check Error: file /usr/lib/libfaad.so.0.0.0 conflicts between attempted installs of faad2-libs-2.6.1-5.el5 and faad2-2.6.1-1.el5.rf


please help

Last edited by kanodiapawan; 01-10-2010 at 01:37 PM.
 
Old 01-10-2010, 02:52 PM   #2
alunduil
Member
 
Registered: Feb 2005
Location: San Antonio, TX
Distribution: Gentoo
Posts: 684

Rep: Reputation: 62
How are you installing mplayer? What command are you running?

Regards,

Alunduil
 
Old 01-10-2010, 11:28 PM   #3
kanodiapawan
LQ Newbie
 
Registered: Jan 2010
Posts: 12

Original Poster
Rep: Reputation: 0
[root@localhost cenation]# yum --disablerepo='epel' install mplayer
Loading "installonlyn" plugin
Loading "rhnplugin" plugin
This system is not registered with RHN.
RHN support will be disabled.
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package mplayer.i386 0:1.0-0.101.20080903svn.el5.1 set to be updated
--> Running transaction check
--> Processing Dependency: liblzo2.so.2 for package: mplayer
--> Processing Dependency: libliveMedia.so.0 for package: mplayer
--> Processing Dependency: libcaca.so.0 for package: mplayer
--> Processing Dependency: libBasicUsageEnvironment.so.0 for package: mplayer
--> Processing Dependency: libfaad.so.0 for package: mplayer
--> Processing Dependency: faad2-libs >= 1:2.6.1 for package: mplayer
--> Processing Dependency: libdca.so.0 for package: mplayer
--> Processing Dependency: libgroupsock.so.0 for package: mplayer
--> Processing Dependency: libenca.so.0 for package: mplayer
--> Processing Dependency: libxvidcore.so.4 for package: mplayer
--> Processing Dependency: libungif.so.4 for package: mplayer
--> Processing Dependency: libUsageEnvironment.so.0 for package: mplayer
--> Processing Dependency: libgif.so.4 for package: mplayer
--> Processing Dependency: libaa.so.1 for package: mplayer
--> Processing Dependency: libmpcdec.so.5 for package: mplayer
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package faad2.i386 0:2.6.1-1.el5.rf set to be updated
---> Package libmpcdec.i386 0:1.2.6-1.el5.rf set to be updated
---> Package lzo2.i386 0:2.02-3.el5.rf set to be updated
---> Package live555.i386 0:0-0.20.2008.07.25.el5 set to be updated
---> Package xvidcore.i386 0:1.2.2-1.el5.rf set to be updated
---> Package aalib.i386 0:1.4.0-5.el5.rf set to be updated
---> Package enca.i386 0:1.10-1.el5.rf set to be updated
---> Package libcaca.i386 0:0.99-0.1.beta11.el5.rf set to be updated
---> Package faad2-libs.i386 1:2.6.1-5.el5 set to be updated
---> Package giflib.i386 0:4.1.3-7.1.el5_3.1 set to be updated
---> Package libdca.i386 0:0.0.5-3.el5 set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
Package Arch Version Repository Size
=============================================================================
Installing:
mplayer i386 1.0-0.101.20080903svn.el5.1 rpmfusion-free-updates-testing 4.4 M
Installing for dependencies:
aalib i386 1.4.0-5.el5.rf rpmforge 167 k
enca i386 1.10-1.el5.rf rpmforge 166 k
faad2 i386 2.6.1-1.el5.rf rpmforge 329 k
faad2-libs i386 1:2.6.1-5.el5 rpmfusion-free-updates-testing 166 k
giflib i386 4.1.3-7.1.el5_3.1 base 39 k
libcaca i386 0.99-0.1.beta11.el5.rf rpmforge 236 k
libdca i386 0.0.5-3.el5 rpmfusion-free-updates-testing 108 k
libmpcdec i386 1.2.6-1.el5.rf rpmforge 52 k
live555 i386 0-0.20.2008.07.25.el5 rpmfusion-free-updates-testing 314 k
lzo2 i386 2.02-3.el5.rf rpmforge 131 k
xvidcore i386 1.2.2-1.el5.rf rpmforge 511 k

Transaction Summary
=============================================================================
Install 12 Package(s)
Update 0 Package(s)
Remove 0 Package(s)

Total download size: 6.5 M
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Test
Finished Transaction Test


Transaction Check Error: file /usr/lib/libfaad.so.0.0.0 conflicts between attempted installs of faad2-libs-2.6.1-5.el5 and faad2-2.6.1-1.el5.rf

Last edited by kanodiapawan; 01-10-2010 at 11:38 PM.
 
Old 01-11-2010, 01:01 PM   #4
alunduil
Member
 
Registered: Feb 2005
Location: San Antonio, TX
Distribution: Gentoo
Posts: 684

Rep: Reputation: 62
I know this probably isn't the proper solution, but can you remove both faad2's and all of their related files and have them get installed again?

Regards,

Alunduil
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem installing mplayer warun Ubuntu 1 03-03-2008 06:44 AM
problem installing mplayer thearchitect Linux - Software 1 11-17-2005 05:56 AM
Problem with installing mplayer.... avols143 Linux - General 2 02-20-2004 07:34 AM
problem installing mplayer pradu Linux - Newbie 4 11-25-2003 01:53 AM
problem installing mplayer mobassir Linux - Software 19 08-23-2003 02:29 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 09:04 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration