LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   problem:Dbus Reject send message! (https://www.linuxquestions.org/questions/linux-software-2/problem-dbus-reject-send-message-744943/)

minge.zu 08-04-2009 02:44 AM

problem:Dbus Reject send message!
 
Hi,everyone
I encountered a problem when send dbus method call message.Program A which runs as root user provides system-wide dbus service interfaces.When another program B with root permission send method call message to A,It received the error info:
Error org.freedesktop.DBus.Error.AccessDenied: Rejected send message, 1 matched rules; type="method_call", sender=":1.41" (uid=0 pid=3397 comm="dbus-send --system --print-reply --type=method_cal") ...

But when I run prgram B in generic user permission,localmachine for example,it success to send message.It confused me all the day.Is there anyone also encountered this issue? Any clue is appreciated.

minge.zu 08-10-2009 02:10 AM

I have yet solved this issue.Just modified the configure file under /etc/dbus-1/system.d
add the following lines in ***.conf
<policy context="default">
<allow send_interface="the interface to be exported"/>
...
</policy>

pantalone 08-31-2009 04:05 PM

Thank you very much for the follow up to your own post. I was having a similar problem, and then saw your solution. You probably saved me several days of work. Many thanks!

-- Brett


All times are GMT -5. The time now is 05:35 AM.