-   Linux - Software (
-   -   Problem connecting to wireless using wicd (

jonbvgood 01-10-2012 07:48 AM

Problem connecting to wireless using wicd
Using kubuntu 10.04, I have recently loaded wicd to manger connections. When connecting with wireless i get either "Bad Password" or "unable to find IP address".

All components of wicd seem to be loaded, I have tried to reload but get the same message fault. A wired connection works fine.
My wireless networks are showing and the password is correct.

Has anyone seen a similar fault with wicd or wireless connections?

Ion Silverbolt 01-10-2012 09:39 AM

Have you tried temporarily disabling encryption on your router to see if it can connect to open wifi? That might narrow down the cause for you. What is the output of dmesg? Try this in a terminal and see what the output is after a failed connection:

sudo dmesg
If it's an encryption issue, check the preferences-->advanced settings in Wicd and see which extrenal program it's using. It should be wext (wpa_supplicant), but I saw settings in there for like ndiswrapper and others. So if your setup is slightly different, that might be causing the issue.

frankbell 01-10-2012 09:17 PM

I have occasionally run into similar issues.

Normally I have been able to fix them by experimenting with the WPA 1/2 encryption settings in the properties dialog for the individual connection. In particular, some connections seem to want the "use these settings for all . . ." checked and some don't.

All times are GMT -5. The time now is 02:31 PM.