-   Linux - Software (
-   -   Problem burning DVD+RW with k3b on Slackware 13 (

EricTRA 04-19-2010 11:50 AM

Problem burning DVD+RW with k3b on Slackware 13
Hi all,

I'm confronted with a problem to which I cannot seem to find an answer. I'm trying to burn a DVD+RW and it continuously fails, whatever options I use. I've tried to burn an iso image, extracted the files from the image and tried burning to a 'new' k3b project, but all with the same result. Regular CD and DVD (not RW) works like a charm. This is the first try using DVD+RW. Below is the log from k3b session. Anyone any idea? All help is greatly appreciated.


Optiarc DVD RW AD-7530A EX31 (/dev/sr0, CD-R, CD-RW, CD-ROM, DVD-ROM, DVD-R, DVD-RW, DVD-R DL, DVD+R, DVD+RW, DVD+R DL) [DVD-ROM, DVD-R Sequential, DVD-R Dual Layer Sequential, DVD-R Dual Layer Jump, DVD-RAM, DVD-RW Restricted Overwrite, DVD-RW Sequential, DVD+RW, DVD+R, DVD+R Dual Layer, CD-ROM, CD-R, CD-RW] [TAO, Restricted Overwrite, Layer Jump] [%7]

reading sectors 0 to 2223235 with sector size 2048. Length: 2223236 sectors, 4553187328 bytes.
using buffer size of 64 blocks.
Problem while reading. Retrying from sector 212992.
Read error in sector 213008.
Read a total of 212992 sectors (436207616 bytes)

mkisofs print size result: 2223236 (4553187328 bytes)

K3b Version: 1.63.0
KDE Version: 4.2.4 (KDE 4.2.4)
QT Version:  4.5.1

Used versions
mkisofs: 2.1.1a57
cdrecord: 2.1.1a57

scsidev: '/dev/sr0'
devname: '/dev/sr0'
scsibus: -2 target: -2 lun: -2
Warning: Open by 'devname' is unintentional and not supported.
Linux sg driver version: 3.5.27
SCSI buffer size: 64512
/usr/bin/cdrecord: Warning: The DMA speed test has been skipped.
Cdrecord-ProDVD-ProBD-Clone 2.01.01a57 (i686-pc-linux-gnu) Copyright (C) 1995-2009 Jörg Schilling
TOC Type: 1 = CD-ROM
Using libscg version 'schily-0.9'.
Driveropts: 'burnfree'
atapi: 1
Device type    : Removable CD-ROM
Version        : 5
Response Format: 2
Capabilities  :
Vendor_info    : 'Optiarc '
Identifikation : 'DVD RW AD-7530A '
Revision      : 'EX31'
Device seems to be: Generic mmc2 DVD-R/DVD-RW/DVD-RAM.
Current: DVD+RW
Profile: DVD-RAM
Profile: DVD-R/DL sequential recording
Profile: DVD-R/DL layer jump recording
Profile: DVD+R/DL
Profile: DVD+R
Profile: DVD+RW (current)
Profile: DVD-RW sequential recording
Profile: DVD-RW restricted overwrite
Profile: DVD-R sequential recording
Profile: DVD-ROM
Profile: CD-RW
Profile: CD-R
Profile: CD-ROM
Profile: Removable Disk
Using generic SCSI-3/mmc-3 DVD+RW driver (mmc_dvdplusrw).
Supported modes: PACKET SAO LAYER_JUMP
Drive buf size : 1048576 = 1024 KB
FIFO size      : 4194304 = 4096 KB
Track 01: data  4342 MB       
Total size:    4342 MB = 2223236 sectors
Current Secsize: 2048
Trying to clear drive status.
Blocks total: 2295104 Blocks current: 2295104 Blocks remaining: 71868
Reducing transfer size from 64512 to 32768 bytes.
Starting to write CD/DVD/BD at speed 4 in real SAO mode for single session.
Last chance to quit, starting real write in 3 seconds.
  2 seconds.
  1 seconds.
  0 seconds. Operation starts.
Waiting for reader process to fill input buffer ... input buffer ready.
Starting new track at sector: 0
Track 02:    0 of 4342 MB written.
Track 02:    1 of 4342 MB written (fifo  92%) [buf 100%]  2.7x.
Track 02: 4337 of 4342 MB written (fifo 100%) [buf  99%]  4.0x.
Track 02: 4338 of 4342 MB written (fifo  98%) [buf  99%]  4.0x.

cdrecord command:
/usr/bin/cdrecord -v gracetime=2 dev=/dev/sr0 speed=4 -sao driveropts=burnfree -data -tsize=2223236s -

/usr/bin/mkisofs: Warning: Cannot add inode hints with -no-cache-inodes.
=== last message repeated 2 times. ===
Setting input-charset to 'ISO-8859-1' from locale.
The pad was 16 for file VIDEO_TS.IFO
  0.02% done, estimate finish Mon Apr 19 16:32:15 2010
  0.05% done, estimate finish Mon Apr 19 16:32:15 2010
 99.97% done, estimate finish Mon Apr 19 16:47:02 2010
 99.99% done, estimate finish Mon Apr 19 16:47:02 2010
Total translation table size: 0
Total rockridge attributes bytes: 0
Total directory bytes: 8344
Path table size(bytes): 42
Max brk space used 21000
2223236 extents written (4342 MB)

mkisofs calculate size command:
/usr/bin/mkisofs -gui -graft-points -print-size -quiet -volid K3b data project -volset  -appid K3B THE CD KREATOR (C) 1998-2007 SEBASTIAN TRUEG -publisher  -preparer  -sysid LINUX -volset-size 1 -volset-seqno 1 -sort /tmp/kde-root/k3bNY5292.tmp -no-cache-inodes -udf -iso-level 1 -path-list /tmp/kde-root/k3bGm5292.tmp -dvd-video -f /tmp/kde-root/k3bVideoDvd0

mkisofs command:
/usr/bin/mkisofs -gui -graft-points -volid K3b data project -volset  -appid K3B THE CD KREATOR (C) 1998-2007 SEBASTIAN TRUEG -publisher  -preparer  -sysid LINUX -volset-size 1 -volset-seqno 1 -sort /tmp/kde-root/k3bxD5292.tmp -no-cache-inodes -udf -iso-level 1 -path-list /tmp/kde-root/k3bjt5292.tmp -dvd-video -f /tmp/kde-root/k3bVideoDvd0

Kind regards,


clifford227 04-19-2010 04:08 PM

so cdrecord actually writes the disc? moves from 0 to 3432? but when you explore it, theres nothing there?

EricTRA 04-20-2010 12:07 AM


I don't get any errors apparently when writing to the DVD but when the verify process begins after some time it exits with an error. Same thing when I try to access/play the DVD after burning. Strange enough I don't have any problems burning images/data to regular CD.

Kind regards,


EricTRA 04-23-2010 02:44 PM


After some digging, testing and trying, I replaced the drive and everything is working again, so basically it was a hardware failure. Thanks to those who replied.

Kind regards,


All times are GMT -5. The time now is 06:26 AM.